# Table of Contents

**Introduction** ................................................................................................................................. i

1. Changes to This Manual ................................................................................................................... i

2. Document Conventions ................................................................................................................... ii

3. Copying and Pasting Text With X ..................................................................................................... iv

4. Using the Mouse ............................................................................................................................... v

5. We Need Feedback! ............................................................................................................................ v

6. Sign Up for Support .......................................................................................................................... v

## 1. Getting Started ................................................................................................................................ 1

1.1. Setup Agent .................................................................................................................................. 1

1.2. Introductory Terms ......................................................................................................................... 3

1.3. Logging In .................................................................................................................................... 5

1.3.1. Graphical Login ....................................................................................................................... 5

1.3.2. Virtual Console Login ............................................................................................................. 6

1.4. Graphical Interface ........................................................................................................................ 6

1.5. Opening a Shell Prompt ................................................................................................................. 7

1.6. Creating a User Account ............................................................................................................... 7

1.7. Documentation and Help .............................................................................................................. 8

1.7.1. Manual Pages ........................................................................................................................... 9

1.7.2. Red Hat Linux Documentation ............................................................................................... 10

1.8. Logging Out .................................................................................................................................. 11

1.8.1. Graphical Logout ...................................................................................................................... 11

1.8.2. Virtual Console Logout .......................................................................................................... 11

1.9. Shutting Down your Computer .................................................................................................... 11

1.9.1. Graphical Shutdown ............................................................................................................... 11

1.9.2. Virtual Console Shutdown ..................................................................................................... 12

## 2. Using the Graphical Desktop ........................................................................................................ 13

2.1. Using the Desktop .......................................................................................................................... 13

2.2. Using the Panel ............................................................................................................................ 14

2.2.1. Using the **Main Menu** ........................................................................................................ 14

2.2.2. Using Applets ........................................................................................................................ 14

2.2.3. Using the Notification Area .................................................................................................... 15

2.2.4. Adding Icons and Applets to the Panel .................................................................................. 16

2.2.5. Configuring the Desktop Panel ............................................................................................... 16

2.3. Using **Nautilus** ......................................................................................................................... 16

2.4. Start Here .................................................................................................................................... 17

2.4.1. Customizing the Desktop ....................................................................................................... 18

2.4.2. Customizing your System ....................................................................................................... 19

2.5. Logging Out .................................................................................................................................. 20

## 3. Configuring the Date and Time ..................................................................................................... 21

3.1. Time and Date Properties ............................................................................................................. 21

3.2. Time Zone Configuration .............................................................................................................. 21

## 4. Diskettes and CD-ROMs .............................................................................................................. 23

4.1. Using Diskettes ............................................................................................................................. 23

4.1.1. Mounting and Unmounting a Diskette .................................................................................. 23

4.1.2. Putting Linux Files on an MS-DOS Diskette ......................................................................... 24

4.1.3. Formatting a Diskette ............................................................................................................. 24

4.2. CD-ROMs .................................................................................................................................... 25

4.2.1. Using CD-ROMs with your File Manager ............................................................................. 26

4.2.2. Using CD-ROMs From a Shell Prompt ................................................................................. 26

4.3. CD-Rs and CD-RWs ..................................................................................................................... 26

4.3.1. Using **CD Creator** ............................................................................................................. 27

4.3.2. Using **X-CD-Roast** ............................................................................................................ 28
Welcome to the Red Hat Linux Getting Started Guide!

By now, you should have read the Red Hat Linux Installation Guide and successfully installed Red Hat Linux. This manual is designed to help new and intermediate Linux users navigate and perform common tasks. Keep in mind that Linux looks, feels, and performs differently from other operating systems you may have used. Forget about the conventions of other operating systems and, with an open mind, approach Red Hat Linux as a new, interesting, and versatile alternative.

This manual is task-oriented. You will find useful tips, hints, warnings, and screen shots interspersed throughout. First, you will learn the basics of using Red Hat Linux, such as customizing a desktop, configuring a printer, and getting online. Once the basics are covered, the tasks covered in this manual become progressively more advanced.

Most users choose to work within either the GNOME or KDE graphical desktop environments (other desktop environments are also available). The Red Hat Linux Getting Started Guide focuses primarily on how to perform tasks in these two environments.

Topics discussed include:

- Using the graphical desktop environment
- Managing files and directories
- Working with documents
- Using the Web and email
- Working with a digital camera

After conquering the basics of your Red Hat Linux system, you may need information on more advanced topics. You can find this information in the Red Hat Linux Customization Guide, the Red Hat Linux Reference Guide, the Red Hat Linux System Administration Primer, and the Red Hat Linux Security Guide.

HTML and PDF versions of the Red Hat Linux manuals are available on the Red Hat Linux Documentation CD and online at http://www.redhat.com/docs/.

Note

Although this manual reflects the most current information possible, you should read the Red Hat Linux Release Notes for information that may not have been available prior to our documentation being finalized. They can be found on the Red Hat Linux CD #1 and online at:

http://www.redhat.com/docs/

1. Changes to This Manual

This manual has been expanded to include new features in Red Hat Linux 9 as well as topics requested by our readers. Changes to this manual include:

Working with Digital Cameras

This new chapter discusses using a digital camera with gtKam.
**Introduction**

*Configuring Date and Time*

A chapter on configuring your system time, your time zone, and how to connect to a network time server to get accurate time and date information for your Red Hat Linux system has been moved from the *Red Hat Linux Customization Guide* to this manual.

*Diskettes and CD-ROMs*

This chapter now includes information about backing up files to CD-R and CD-RW media using **CD Creator** in **Nautilus**.

*Working with Documents*

This chapter includes information on editing text files in a graphical environment (with **gEdit**) and at a shell prompt (with **vi**).

*Using the Graphical Desktop*

This chapter has been modified to reflect the new desktop environment and the various ways you can use and configure it, including how to change your desktop background, manage your printer, and more.

### 2. Document Conventions

When you read this manual, you will see that certain words are represented in different fonts, typefaces, sizes, and weights. This highlighting is systematic; different words are represented in the same style to indicate their inclusion in a specific category. The types of words that are represented this way include the following:

**command**

Linux commands (and other operating system commands, when used) are represented this way. This style should indicate to you that you can type the word or phrase on the command line and press [Enter] to invoke a command. Sometimes a command contains words that would be displayed in a different style on their own (such as filenames). In these cases, they are considered to be part of the command, so the entire phrase will be displayed as a command. For example:

Use the `cat testfile` command to view the contents of a file, named `testfile`, in the current working directory.

**filename**

Filenames, directory names, paths, and RPM package names are represented this way. This style should indicate that a particular file or directory exists by that name on your Red Hat Linux system. Examples:

- The `bashrc` file in your home directory contains bash shell definitions and aliases for your own use.
- The `/etc/fstab` file contains information about different system devices and filesystems.
- Install the `webalizer` RPM if you want to use a Web server log file analysis program.

**application**

This style indicates that the program is an end-user application (as opposed to system software). For example:

Use **Mozilla** to browse the Web.
Introduction

A key on the keyboard is shown in this style. For example:

To use [Tab] completion, type in a character and then press the [Tab] key. Your terminal will display the list of files in the directory that start with that letter.

A combination of keystrokes is represented in this way. For example:

The [Ctrl]-[Alt]-[Backspace] key combination will exit your graphical session and return you to the graphical login screen or the console.

text found on a GUI interface

A title, word, or phrase found on a GUI interface screen or window will be shown in this style. When you see text shown in this style, it is being used to identify a particular GUI screen or an element on a GUI screen (such as text associated with a checkbox or field). Example:

Select the Require Password checkbox if you would like your screensaver to require a password before stopping.

top level of a menu on a GUI screen or window

When you see a word in this style, it indicates that the word is the top level of a pulldown menu. If you click on the word on the GUI screen, the rest of the menu should appear. For example:

Under File on a GNOME terminal, you will see the New Tab option that allows you to open multiple shell prompts in the same window.

If you need to type in a sequence of commands from a GUI menu, they will be shown like the following example:

Go to Main Menu Button (on the Panel) => Programming => Emacs to start the Emacs text editor.

button on a GUI screen or window

This style indicates that the text will be found on a clickable button on a GUI screen. For example:

Click on the Back button to return to the webpage you last viewed.

computer output

When you see text in this style, it indicates text displayed by the computer on the command line. You will see responses to commands you typed in, error messages, and interactive prompts for your input during scripts or programs shown this way. For example:

Use the ls command to display the contents of a directory:

$ ls
Desktop about.html logs paulwesterberg.png
Mail backupfiles mail reports

The output returned in response to the command (in this case, the contents of the directory) is shown in this style.

prompt

A prompt, which is a computer’s way of signifying that it is ready for you to input something, will be shown in this style. Examples:

$ 
# 
[stephen@maturin stephen]$
leopard login:

user input

Text that the user has to type, either on the command line, or into a text box on a GUI screen, is displayed in this style. In the following example, text is displayed in this style:

To boot your system into the text based installation program, you will need to type in the text command at the boot: prompt.

Additionally, we use several different strategies to draw your attention to certain pieces of information. In order of how critical the information is to your system, these items will be marked as note, tip, important, caution, or a warning. For example:

- **Note**
  
  Remember that Linux is case sensitive. In other words, a rose is not a ROSE is not a rOsE.

- **Tip**
  
  The directory /usr/share/doc contains additional documentation for packages installed on your system.

- **Important**
  
  If you modify the DHCP configuration file, the changes will not take effect until you restart the DHCP daemon.

- **Caution**
  
  Do not perform routine tasks as root — use a regular user account unless you need to use the root account for system administration tasks.

- **Warning**
  
  If you choose not to partition manually, a server installation will remove all existing partitions on all installed hard drives. Do not choose this installation class unless you are sure you have no data you need to save.
3. Copying and Pasting Text With X

Copying and pasting text is easy using your mouse and the X Window System. To copy text, simply click and drag your mouse over the text to highlight it. To paste the text somewhere, click the middle mouse button in the spot where the text should be placed.

4. Using the Mouse

Red Hat Linux is designed to use a three-button mouse. If you have a two-button mouse, you should have selected three-button emulation during the installation process. If you’re using three-button emulation, pressing both mouse buttons at the same time equates to pressing the missing third (middle) button.

In this document, if you are instructed to click with the mouse on something, that means click the left mouse button. If you need to use the middle or right mouse button, that will be explicitly stated. (This will be reversed if you’ve configured your mouse to be used by a left handed person.)

The phrase "drag and drop" may be familiar to you. If you’re instructed to drag and drop an item on your GUI desktop, click on something and hold the mouse button down. While continuing to hold down the mouse button, drag the item by moving the mouse to a new location. When you’ve reached the desired location, release the mouse button to drop the item.

5. We Need Feedback!

If you spot a typographical error in the *Red Hat Linux Getting Started Guide*, or if you have thought of a way to make this manual better, we would love to hear from you! Please submit a report in Bugzilla (http://bugzilla.redhat.com/bugzilla/) against the component rhl-gsg.

When submitting a bug report, be sure to mention the manual’s identifier:

rhl-gsg(EN)-9-Print-RHI (2003-02-20T01:05)

If you have a suggestion for improving the documentation, try to be as specific as possible when describing it. If you have found an error, please include the section number and some of the surrounding text so we can find it easily.

6. Sign Up for Support

If you have an edition of Red Hat Linux 9, please remember to sign up for the benefits you are entitled to as a Red Hat customer.

You will be entitled to any or all of the following benefits, depending upon the Red Hat Linux product you purchased:

- Red Hat support — Get help with your installation questions from Red Hat, Inc.’s support team.
- Red Hat Network — Easily update your packages and receive security notices that are customized for your system. Go to http://rhn.redhat.com for more details.
- *Under the Brim: The Red Hat E-Newsletter* — Every month, get the latest news and product information directly from Red Hat.

To sign up, go to http://www.redhat.com/apps/activate/. You will find your Product ID on a black, red, and white card in your Red Hat Linux box.
To read more about technical support for Red Hat Linux, refer to the *Getting Technical Support Appendix* in the *Red Hat Linux Installation Guide*.

Good luck, and thank you for choosing Red Hat Linux!

*The Red Hat Documentation Team*
Chapter 1.
Getting Started

From booting up to shutting down, whether you are working or playing, Red Hat Linux provides tools and applications to help you get the most out of your computing environment. This chapter guides you through some basic tasks that you can perform on your Red Hat Linux system.

1.1. Setup Agent

The first time you start your Red Hat Linux system, the Setup Agent is presented. The Setup Agent guides you through the configuration of your Red Hat Linux system. Using this tool, you can set your system time and date, add users to your system, install software, register your machine with the Red Hat Network, and more. Setup Agent allows you to configure your environment at the beginning, so that you can get started using your Red Hat Linux system quickly.

Figure 1-1. Setup Agent

The Setup Agent first prompts you to create a user account that you should use on a routine basis. It is not recommended to log in to your root account for common computing tasks, as you may damage your system or unintentionally delete a file. The Setup Agent lets you enter a username, an optional full name for the account, and a password (which you must enter twice). This creates a user account that you can use to log into your Red Hat Linux system and which has its own home directory on the system to store files.
Chapter 1. Getting Started

Figure 1-2. User Account

The Setup Agent allows you to manually set your machine’s date and time, which adjusts the clock on your computer’s BIOS (Basic Input Output System). To set the day, month, and year on your system, use the calendar interface. To set your time in hours, minutes, and seconds, use the provided text boxes.

You may also synchronize your date and time automatically with a network time server — a computer that sends accurate date and time settings to your system through a network connection. Check the box labeled Enable Network Time Protocol and use the drop-down menu to select the time server you want to use. Once you have set your time and date, click Forward to continue.

Figure 1-3. Date and Time Configuration

To register your system with Red Hat Network and receive automatic updates of your Red Hat Linux system, choose Yes, I would like to register my system with Red Hat Network. This will start the Red Hat Update Agent — a utility that guides you step-by-step through the registration of your machine with Red Hat Network. Selecting No, I do not want to register my system skips the registration. For more information about Red Hat Network and registering your machine, refer to the Red Hat Network documentation at http://www.redhat.com/docs/manuals/RHNetwork/.
To install Red Hat Linux RPM packages that you did not install during installation, software from third-party providers, or documentation from the Red Hat Linux Documentation CD, you can do so at the Additional CDs screen. Insert the CD containing the software or documentation you want to install, click the Install... button, and follow the instructions.

**Note**

If you are installing a package from the Red Hat Linux Installation CDs, you must insert CD 1, click the Install... button, choose the package(s) or component you want to install, and, if prompted, change the CD.

Now that your system is configured, you are ready to log in and start using Red Hat Linux. Press Forward to exit the Setup Agent.

### 1.2. Introductory Terms

When you learn about a new operating system, you should also learn new terminology. This section defines a few basic terms you should learn. You will see these terms often throughout all Red Hat Linux documentation including the Red Hat Linux Getting Started Guide:
• **Command**: An instruction given to the computer, most often with the keyboard or mouse.

• **Command line**: The space at the shell prompt where commands are typed.

• **Graphical Desktop**: The most visible area of a GUI. The desktop is where your user Home and Start Here icons are located. You can customize your desktop to have special backgrounds, colors, and pictures to add a personal touch.

• **Graphical User Interface (GUI)**: A general term for interactive windows, icons, menus, and panels which allow a user to initiate actions such as starting applications and opening files using a mouse and keyboard.

• **Icons** are small images representing an application, folder, shortcut or system resource (such as a diskette drive). **Launcher** icons usually refer to application shortcuts.

• **Man page and Info page**: Man (short for manual) and Info pages give detailed information about a command or file (man pages tend to be brief and provide less explanation than Info pages). For example, to read the man page for the `su` command, type `man su` at a shell prompt (or type `info su` for the info page). To close man or info pages, press `[q]`.

• **Panel**: A desktop toolbar, usually located across the bottom of your desktop (such as Figure 1-6). The panel contains the **Main Menu** button and shortcut icons to start commonly used programs. Panels can also be customized to suit your needs.

![Figure 1-6. The Desktop Panel](image)

• **Root**: Root is an administrative user account created during installation and has complete access to the system. You must be logged in as root to accomplish certain system administration tasks, such as changing administrative passwords and running system configuration tools. User accounts are created so that typical user tasks can be done without using the root account, which can reduce the chance of damaging your Red Hat Linux installation or applications permanently.

• **RPM**: RPM stands for RPM Package manager and is how Red Hat builds and delivers its software files. An RPM is a software package file you can install on your Red Hat Linux computer.

• **Shell prompt**: A command line interface between the user and the operating system (Figure 1-7). The shell interprets commands entered by the user and passes them on to the operating system.

![Figure 1-7. A Shell Prompt](image)
• *su* and *su -*: The command *su* gives you access to the root account or other accounts on your system. When you type *su* to switch to your root account while still inside your user account shell, you have access to important system files that you can change (or damage if you are not careful). Logging in with the *su -* command makes you root within the root account shell. *Use caution when you are logged in as root.*

• *X* or *X Window System*: These terms refer to the graphical user interface environments. If you are "in X" or "running X", you are working in a GUI rather than a console environment.

Although the emphasis throughout this book is on navigation and productivity using the graphical desktop environment, both the graphical and shell prompt methods of logging in and using your Red Hat Linux system are discussed for your reference.

### 1.3. Logging In

The next step to using your Red Hat Linux system is to log in. When you log in, you are introducing yourself to the system (also called *authentication*). If you type the wrong user name or password, you will not be allowed access to your system.

Unlike some other operating systems, your Red Hat Linux system uses accounts to manage privileges, maintain security, and more. Not all accounts are created equal: some accounts have fewer rights to access files or services than others.

![Note](image)

Red Hat Linux applications and files are case sensitive, which means that typing *root* refers to a different account than *Root*. By default, *root* refers to the root user (also known as the superuser), or system administrator.

If you have already created and logged in to a user account, you can skip ahead to Chapter 2 *Using the Graphical Desktop*. If you created only the root account, refer to Section 1.6 *Creating a User Account* to learn how to set up a user account.

If you did not create a user account using the *Setup Agent*, you must log in as root. After you create a user account, it is highly recommended that you log in as that user instead of root to prevent accidental damage to your Red Hat Linux installation.

![Caution](image)

Because your Red Hat Linux system creates the root account during installation, some new users are tempted to use only this account for all of their activities. This is a dangerous idea, because the root account is allowed to do anything on the system. You can easily damage your system by accidentally deleting or modifying sensitive system files. You may be tempted to forego creating and using a user account during or after installation, but it is *not* recommended.

### 1.3.1. Graphical Login

When your system has booted, a graphical login screen is displayed as shown in Figure 1-8. Again, unless you have chosen to give your machine its own hostname, which is primarily used in a network setting, your machine will probably be called *localhost*.
6 Chapter 1. Getting Started

Figure 1-8. The Graphical Login Screen

To log in as root from the graphical login screen, type root at the login prompt, press [Enter], type the root password that you chose during installation at the password prompt, and press [Enter]. To log in as a normal user, type your username at the login prompt, press [Enter], type your password that you selected when creating the user at the password prompt, and press [Enter].

Logging in from the graphical login screen automatically starts the graphical desktop for you.

1.3.2. Virtual Console Login

During installation, if you selected an installation type other than Workstation or Personal Desktop and chose text as your login type, you will see a login prompt similar to the following after booting your system:

Red Hat Linux release 9
Kernel 2.4.18-14 on an i686

localhost login:

Unless you have chosen to give your machine its own hostname, which is primarily used in a network setting, your machine will probably be called localhost.localdomain.

To log in as root from the console, type root at the login prompt, press [Enter], then type the root password that you chose during installation at the password prompt and press [Enter]. To log in as a normal user, type your username at the login prompt, press [Enter], type your password that you selected when creating the user at the password prompt, and press [Enter].

After logging in, you can type the command startx to start the graphical desktop.

1.4. Graphical Interface

When you installed Red Hat Linux you had the opportunity to install a graphical environment. Once you start the X Window System, you will find a graphical interface known as a desktop similar to Figure 1-9.
1.5. Opening a Shell Prompt

The desktop offers access to a shell prompt, an application that allows you to type commands instead of using a graphical interface for all computing activities. While the Red Hat Linux Getting Started Guide primarily focuses on performing tasks using the graphical interface and graphical tools, it is sometimes useful and faster to perform tasks from a shell prompt. Refer to Chapter 13 Shell Prompt Basics for further details.

You can open a shell prompt by selecting Main Menu => System Tools => Terminal.

You can also start a shell prompt by right-clicking on the desktop and choosing New Terminal from the menu.

To exit a shell prompt, click the X button on the upper right corner of the shell prompt window, type exit at the prompt, or press [Ctrl]-[D] at the prompt.

1.6. Creating a User Account

When you first started your Red Hat Linux system after installation, you were given the opportunity to create one or more user accounts using the Setup Agent. If you did not create at least one account (not including the root account) you should do so now. You should avoid working in the root account for daily tasks.

There are two ways to create new and/or additional user accounts: using the graphical User Manager application or from a shell prompt.

To create a user account graphically using the User Manager:

1. Click the Start Here icon on the desktop. In the new window that opens, click the System Settings icon, and then click the Users & Groups icon. You can also select Main Menu => System Settings => Users & Groups from the panel.

   You can also start the User Manager by typing redhat-config-users at a shell prompt.

2. If you are not logged in as root, you will be prompted for your root password.

3. The window shown in Figure 1-10 will appear. Click Add User.
4. In the **Create New User** dialog box, enter a username (this can be an abbreviation or nickname), the full name of the user for whom this account is being created, and a password (which you will enter a second time for verification). The name of this user’s home directory and the name of the login shell should appear by default. For most users, you can accept the defaults for the other configuration options. Refer to the *Red Hat Linux Customization Guide* for details about additional options.

5. Click **OK**. The new user will appear in the user list, signaling that the user account creation is complete.

To create a user account from a shell prompt:

1. Open a shell prompt.
2. If you are not logged in as root, type the command `su -` and enter the root password.
3. Type `useradd` followed by a space and the username for the new account you are creating at the command line (for example, `useradd jsmith`). Press [Enter]. Often, usernames are variations on the user’s name, such as jsmith for John Smith. User account names can be anything from the user’s name, initials, or birthplace to something more creative.
4. Type `passwd` followed by a space and the username again (for example, `passwd jsmith`).
5. At the `New password:` prompt enter a password for the new user and press [Enter].
6. At the `Retype new password:` prompt, enter the same password to confirm your selection.

**Important**

You should take precautions when you choose a password. The password is the key to your account, so it should be both unique and easy for you to remember. Your password should be at least six characters. You can use both uppercase and lowercase letters, as well as numbers and characters. Avoid easy selections, such as *qwerty* or *password*. If you want to pick an easy-to-remember but somewhat unique password, consider a variation of a word, such as *airPl4nE* for *airplane*.

### 1.7. Documentation and Help

There are several resources available to get the information you need to use and configure your Red Hat Linux system. Along with the Red Hat Linux documentation there are *manual pages*, documents that detail usage of important applications and files; *INFO pages* which break information about an
application down by context-sensitive menus; and help files that are included in the main menubar of graphical applications. You can choose any method of accessing documentation that best suits your needs, as all of these resources are either already installed on your Red Hat Linux system or can be easily installed.

### 1.7.1. Manual Pages

Applications, utilities, and shell prompt commands usually have corresponding manual pages (also called man pages) that show the reader available options and values of file or executable. Man Pages are structured in such a way that users can quickly scan the page for pertinent information, which is important when dealing with commands that they have never previously encountered.

#### 1.7.1.1. Using man

Man Pages can be accessed via shell prompt by typing the command `man` and the name of the executable. For example, to access the man page for the `ls` command, type the following:

```bash
man ls
```

The **NAME** field shows the executable’s name and a brief explanation of what function the executable performs. The **SYNOPSIS** field shows the common usage of the executable, such as what options are declared and what types of input (such as files or values) the executable supports. The **DESCRIPTION** field shows available options and values associated with a file or executable. **See Also** shows related terms, files, and programs.

![Figure 1-11. Reading a Man Page with the Shell Prompt](image)

To navigate the man page you can use the [Page Down] and [Page Up] keys or use the [Spacebar] to move down one page and [B] to move up. To exit the man page, type [Q].

To search a man page for keywords type `/` and then a keyword or phrase and press [Enter]. All instances of the keyword will be highlighted throughout the man page, allowing you to quickly read the keyword in context.
1.7.1.2. Printing a Man Page

Printing man pages is a useful way to archive commonly used commands, perhaps in bound form for quick reference. If you have a printer available and configured for use with Red Hat Linux (refer to Chapter 8 Printer Configuration for more information), you can print a man page by typing the following command at a shell prompt:

```
man command | col -b | lpr
```

The example above combines separates commands into one unique function. `man command` will output the contents of the `command` man page to `col`, which formats the contents to fit within a printed page. The `lpr` command sends the formatted content to the printer.

1.7.1.3. The man Man Page

Just like other commands, `man` has its own man page. Type `man man` at the shell prompt for more information.

1.7.2. Red Hat Linux Documentation

If you have the Red Hat Linux boxed set, remember to take a look at the Red Hat Linux Documentation CD. All of the Red Hat Linux manuals are on this CD. Individual downloads of our documentation in HTML, RPM, PDF, and compressed tarball format (.tar.gz) are also available at http://www.redhat.com/docs/. Once you have logged in to your user account, inserting the Documentation CD in your CD-ROM drive should automatically start the Package Management Tool and allow you to install any of the Red Hat Linux documentation. Follow the instructions and choose the documentation you would like to install.

![Figure 1-12. Package Management Tool Displaying Documentation Available for Installation](image)

After you have installed the documentation packages you want, you can access them at any time by clicking **Main Menu => Documentation**.

If you have downloaded individual documentation RPM packages from the Red Hat website at http://www.redhat.com/docs/ you can install these manuals from a shell prompt. Open a shell prompt, and type the following at the command line:

```
su
```
Press [Enter]. You will be asked for your root password. Enter the password at the prompt and press [Enter]. You are now logged in as root. To install all of the Red Hat Linux manuals, change to the directory that contains the RPM files and type the following:

```
rpm -ivh rhl-*.rpm
```

Press [Enter].

To install only certain manuals, replace `rhl-*.rpm` with the full file name of the manual that you want to install. For example, the file name for the Red Hat Linux Getting Started Guide will look something like `rhl-gsg-en-9.noarch.rpm`, so you would type the following to install it on your system:

```
rpm -ivh /mnt/cdrom/rhl-gsg-en-9.noarch.rpm
```

Press [Enter]. Type `exit` at the command line and press [Enter]. This logs you out of the root account and back to your user account.

Now go to Main Menu => Documentation and select the manual you want to read.

### 1.8. Logging Out

#### 1.8.1. Graphical Logout

To log out your graphical desktop session, select Main Menu => Log Out.

When the confirmation dialog appears as shown in Figure 1-13, select the Logout option and click the Yes button. To save the configuration of your desktop, as well as any programs which are running, check the Save current setup option.

![Logout Confirmation](image.png)

**Figure 1-13. Logout Confirmation**

#### 1.8.2. Virtual Console Logout

If you are not using the X Window System, and you logged in at the console, type `exit` or [Ctrl]-[D] to log out of the console session.

### 1.9. Shutting Down your Computer

Before turning off your computer, it is important to properly shut down Red Hat Linux. Never turn your computer off without shutting down first, as you may lose unsaved data or damage your system.
1.9.1. Graphical Shutdown

If you are in the graphical desktop, log out of your session as described in Section 1.8 Logging Out. From the graphical desktop logout screen shown in Figure 1-13, select **Shutdown** and click **OK** to confirm.

Some computers automatically turn the power off after shutting down Red Hat Linux. If your computer does not, you can safely turn off the power to your computer after you see the message:

*Power down.*

1.9.2. Virtual Console Shutdown

To shutdown your computer at a shell prompt, type the following command:

```
halt
```

Some computers automatically turn the power off after shutting down Red Hat Linux. If your computer does not, you can safely turn off the power to your computer after you see the message: *System halted.*
Chapter 2.
Using the Graphical Desktop

Red Hat Linux includes a powerful graphical desktop environment where you can easily access your applications, files, and system resources. Both new and experienced users will be able to take full advantage of their Red Hat Linux systems using the graphical desktop.

This chapter covers the fundamentals of the desktop and how you can configure it for your needs.

2.1. Using the Desktop

Your first view of the graphical desktop will look something like Figure 2-1.

![Figure 2-1. The Graphical Desktop](image)

The graphical desktop gives you access to the applications and system settings on your computer. You will notice that it offers three main tools to make use of the applications on your system: panel icons, desktop icons, and menus.

The long bar across the bottom of the desktop is the panel. The panel contains application launcher icons, a notification area for notification icons, and small applications called applets that let you control sound volume, switch workspaces, and displays the status of your system.

The icons elsewhere on the desktop can be shortcuts to file folders, application launchers, and shortcuts to removable devices such as CD-ROM and diskettes when they have been mounted. To open a folder or launch an application, double-click on its icon.

The menu systems can be found by clicking on the Main Menu button. They can also be found by double-clicking on the Start Here icon on the desktop and then clicking the Applications icon.

The desktop works in the manner you might expect it to when working with other operating systems. You can drag and drop files and application icons to areas that are easily accessible. You can add new
icons for files and applications to the desktop, panel, and file manager. You can change the appearance of most of the tools and applications and change system settings with provided configuration tools.

### 2.2. Using the Panel

The desktop panel is the bar that stretches across the bottom of the screen and holds icons and small applications which makes using your system easier. The panel also holds the Main Menu, which contains shortcuts for all of your applications. Applets embedded on the panel allow you to run specific tasks or monitor your system or services while remaining out of your way. The notification area holds alert icons such as the one for Red Hat Network so that you can be quickly alerted to critical messages.

![Figure 2-2. The Panel](image)

#### 2.2.1. Using the Main Menu

You can click on the Main Menu button to expand it into a large set of menus that allow you to access the applications on your system. From here, you can start most applications included in Red Hat Linux. Notice that, in addition to the recommended applications, you can also access additional applications within each sub-menu. These sub-menus give you access to a full range of applications on your system. From the Main Menu, you can also log out, run applications from a command line, find files, and lock your screen (which runs a password protected screen saver).

#### 2.2.2. Using Applets

Applets are small applications that run on the panel. Applets let you monitor various aspects of your system. Some applets perform useful tasks while others are designed to be entertaining.

There are a few applets that run on your panel by default. These applets are fairly important and are covered in the following list.

**Workspace Switcher**

The graphical desktop gives you the ability to use multiple workspaces so you do not have to have all of your running applications crowding one viewable desktop area. The Workspace Switcher represents each workspace (or desktop) in small squares and shows the applications running on them. Click on one of the squares with your mouse to move to that desktop. You can also use the keyboard shortcut [Ctrl]-[Alt]-[up-arrow], [Ctrl]-[Alt]-[down-arrow], [Ctrl]-[Alt]-[right-arrow], or [Ctrl]-[Alt]-[left-arrow] to switch between desktops.

![Figure 2-3. Workspace Switcher](image)
Taskbar

Next to the Workspace Switcher is the Taskbar. The Taskbar is an applet which shows you the titles of running applications on any one virtual desktop. This is very helpful if you decide to minimize an application as it will seem to disappear from the desktop. Once it disappears, you can bring it back by clicking on its title in the Taskbar.

![Figure 2-4. The Taskbar](image)

2.2.3. Using the Notification Area

Red Hat Network Notification Tool

Part of the Notification Area, the Red Hat Network Notification Tool provides you with an easy way to make sure your system is up-to-date with current errata and bug fixes from Red Hat. The applet shows you different images that indicate whether your system is up to date or needs upgrades. If you click on the icon, a list of available updates will be displayed. To update your system, click the button to launch the Red Hat Update Agent. If you are not registered with Red Hat Network, it will launch the registration component. Right-click on the applet icon for a list of options from which to choose.

![Figure 2-5. Red Hat Network Notification Tool](image)

The Authentication Icon

The key icon that is sometimes displayed in the Notification Area is a security notification that displays whenever you have gained root authentication for your system (such as running a graphical system configuration tool). It disappears when the authentication times out.

![Figure 2-6. Authentication Icon](image)

Printer Notification Icon

The Printer Notification Icon allows you to manage your print jobs. Click on the icon to view running print jobs, and cancel jobs by right-clicking on the job and selecting Cancel.

![Figure 2-7. The Printer Notification Icon](image)
Chapter 2. Using the Graphical Desktop

2.2.4. Adding Icons and Applets to the Panel

To make the panel fit your needs, you may want to add more applets and launcher icons.

To add an applet to the panel, right-click in an unused area on the panel, select Add to Panel, and choose from the various types of applets. When you select an applet, it will appear on your panel. In Figure 2-8, the Weather Report applet has been added to show the current local weather and temperature.

Figure 2-8. The Weather Report Applet on the Panel

To add a launcher icon to the panel, right-click in an unused area on the panel and select Add to Panel => Launcher.... This will launch a dialog box that allows you to enter the name of the application, the location and name of the command that starts the application (such as /usr/bin/foo), and even choose an icon for the application. Click OK and the new launcher icon will appear on the panel.

2.2.5. Configuring the Desktop Panel

You can hide the panel automatically or manually, place it on any edge of your desktop, change its size and color, and change the way it behaves. To alter the default panel settings, right-click in an unused area of the panel and select Properties. You can set the size of the panel, its position on the desktop, and whether you want the panel to be automatically hidden (Autohide) when not in use. If you choose to autohide the panel, it will not appear on the desktop until you move your mouse pointer over the panel area (called hovering).

2.3. Using Nautilus

The graphical desktop includes a file manager called Nautilus that gives you a graphical display of your system and personal files. Nautilus is designed to be much more than a visual listing of files, however. It allows you to configure your desktop, configure your Red Hat Linux system, browse your photo collection, access your network resources, and more all from one integrated interface. In essence, Nautilus becomes a shell for your entire desktop experience.
Working in Nautilus is efficient and provides an alternative to searching through the various submenus connected to the Main Menu or using a shell prompt to navigate the file system. The following sections explain how to use the Nautilus to enhance your desktop experience.

To start Nautilus as a file manager, double-click on your home directory icon:

Once Nautilus appears, you can navigate through your home directory or the rest of the file system. To return to your home directory, click the Home button.

The browser window contains folders and files which you can drag with your mouse to move and copy into new locations. You can open another Nautilus window by selecting File => New Window. Once you have another Nautilus window, you can drag and drop files to different directories. By default, dragging a file from one directory to another moves the file. To copy the file to another directory, press the [Ctrl] key while dragging and dropping the file.

By default, image files in your home directory will be seen as thumbnails. For text files, this means you see a portion of the actual text in the icon. For images, you see a scaled-down (or thumbnail) version of the image. To turn off this feature, select Edit => Preferences. Select the Preview tab, then select Never in the drop down for Show Thumbnails. Disabling this (and other) previewing feature increases the speed of Nautilus.

2.4. Start Here

Figure 2-9. The Start Here Window

Start Here was designed to hold all of the tools and applications you need to access when using your system. From your favorite applications to system and configuration tools, the Start Here window provides a central location for using and customizing your system.

You can access the Start Here screen at any time by double-clicking on the desktop icon labeled Start Here.

The Start Here screen includes icons that allow you to access your favorite applications, desktop preferences, Main Menu items, server configuration tools, and system settings.
Tip

You can add your favorite locations to the Bookmarks. Navigate to the location you want to bookmark, and then select Bookmarks => Add Bookmark.

2.4.1. Customizing the Desktop

From the Start Here screen, you can select the Preferences icon to configure your desktop, which presents you with a wide selection of configuration options. The following lists some of the options and tools in each area.

Background

You can configure your background with new colors or a new image. To learn more about configuring your desktop background, refer to Section 2.4.1.1 Changing your Desktop Background.

Sound

In this section you can configure the system sounds associated with various functions. For example, to play a sound when you log in to your desktop, you can configure it.

Keyboard Shortcuts

You can configure shortcuts — pressing a combination of keystrokes on the keyboard — to perform actions within an application or on your desktop. For example, you can configure a shortcut to move from your current Workspace to Workspace 2 by pressing [Ctrl]-[F2].

2.4.1.1. Changing your Desktop Background

One way to dramatically alter the appearance of your graphical desktop is to change the background using the Background Preferences tool. You can choose from several background images included with Red Hat Linux in the /usr/share/backgrounds/ directory, or you can use your own image.

To start the Background Preferences tool, right-click on the desktop and choose Change Desktop Background from the menu. You can also double-click the Start Here icon, select Preferences, and finally select Background.

![Figure 2-10. The Background Preferences Tool](image-url)
The **Background Preferences** tool allows you to load a new background from a directory of provided images (`/usr/share/backgrounds/images`). You can also drag an image into the window from your own image directory. There are several additional options for displaying your background image. The **Wallpaper** option displays multiple instances of your image across the desktop, which is useful if you use a small image or if you use a *tile* (or pattern) image from `/usr/share/backgrounds/tiles/` or from your own image collection. The **Centered** option places your image in the center of the desktop, leaving the default background colors to fill in any remaining desktop space. To fill the desktop with an image without tiling it, use the **Scaled** or **Stretched** options. Figure 2-11 shows a background image of flowers and plants that is stretched to fill the entire desktop.

![Background Image](image)

**Figure 2-11. The Desktop with a New Background**

If you want to create a background with your own custom colors and no images, choose the **No Picture** option and adjust your colors using the **Background Style** options. Choose your own **Top Color** and **Bottom Color** and the color **gradient** (or the blending of colors). Click **Close** to save and exit the **Background Preferences** tool.

### 2.4.2. Customizing your System

The **Start Here** screen in **Nautilus** contains additional configuration tools that help you with your new Red Hat Linux system and the server applications included.

The **System Settings** icon includes tools that help you set up your system for personal everyday use. The following lists some of the tools included in **System Settings** and what you can do with them.

**Date & Time**

This tool allows you to set the date and time of your machine. You will be able to set your time zone information as well. Refer to Chapter 3 *Configuring the Date and Time* for details on using this tool.
Soundcard Detection

The **Sound Card Configuration Tool** tool probes your machine for available sound devices. Refer to Section 10.3 *Troubleshooting Your Sound Card* for more details on configuring your sound hardware.

Users & Groups

The **User Manager** tool allows you to add and remove users from your system. Refer to Section 1.6 *Creating a User Account* for details.

Printing

The **Printer Configuration Tool** allows you to add a new printer to your system. The printer may be connected to your machine or available on a network. Refer to Chapter 8 *Printer Configuration* and the *Red Hat Linux Customization Guide* for details.

You may also find server configuration tools in the **Start Here** area, depending on which install type you specified during installation. These tools help you configure services and applications you are using on the local machine to serve other machines. The server configuration tools are found by clicking on the **System Settings** icon and then the **Server Settings** icon. A few examples of the tools found in this area are the **HTTP Configuration Tool** and the **Bind Configuration Tool**. You must have those server applications installed before these tools appear in this section. Refer to the *Red Hat Linux Customization Guide* for details.

### 2.5. Logging Out

When you have finished working and want to quit GNOME, you are presented with the choice of logging out of GNOME (leaving the system running), restarting the machine, or halting the system completely.

![Figure 2-12. The Desktop Log Out Confirmation](image)

To quit the graphical desktop, select the **Log Out** menu item from the **Main Menu**. This will bring up a dialog which presents you with the options listed above.
Chapter 3.

Configuring the Date and Time

The Time and Date Properties Tool allows the user to change the system date and time, to configure the time zone used by the system, and to setup the Network Time Protocol (NTP) daemon to synchronize the system clock with a time server.

You must be running the X Window System and have root privileges. To start the application from the desktop go to the Main Menu Button => System Settings => Date & Time or type the command `redhat-config-date` at a shell prompt (for example, in an XTerm or a GNOME terminal).

3.1. Time and Date Properties

As shown in Figure 3-1, the first tabbed window that appears is for configuring the system date and time and the NTP daemon (ntpd).

![Figure 3-1. Time and Date Properties](image)

To change the date, use the arrows to the left and right of the month to change the month. Use the arrows to the left and right of the year to change the year, and click on the day of the week to change the day of the week. Changes will not take place until you click the OK button.

To change the time, use the up and down arrow buttons beside the Hour, Minute, and Second in the Time section. Changes will not take place until you click the OK button.

The Network Time Protocol (NTP) daemon synchronizes the system clock with a remote time server or time source (such as a satellite). The application allows you to configure a NTP daemon to synchronize your system clock with a remote server. To enable this feature, click the Enable Network Time Protocol button. This will enable the Server pulldown menu. You can choose one of the predefined servers or type a server name in the pulldown menu. Your system will not start synchronizing with the NTP server until you click OK. After you click OK, the configuration will be saved and the NTP daemon will be started (or restarted if it is already running).

Clicking the OK button will apply any changes that you have made to the date and time, the NTP daemon settings, and the time zone settings and then exit the program.
3.2. Time Zone Configuration

To configure the system time zone, click the **Time Zone** tab. The time zone can be changed by either using the interactive map or by choosing the desired time zone from the list below the map. To use the map, click on the city that represents the desired time zone. A red X will appear and the time zone selection will change in the list below the map. Click **OK** to apply the changes and exit the program.

![Timezone Properties](image)

Figure 3-2. Timezone Properties

If your system clock is set to use UTC, select the **System clock uses UTC** option. UTC stands for the universal time zone, also known as Greenwich mean time (GMT). Other time zones are determined by adding or subtracting from the UTC time.
Using diskettes and CD-ROMs with Red Hat Linux requires some understanding about removable media. This chapter discusses how to read and write files to and from diskettes, how to format diskettes, and how to read and copy data from a CD-ROM. This chapter also covers using CD-writable and CD-rewritable drives.

4.1. Using Diskettes

Diskettes are one of the oldest removable media solutions available for the personal computer (PC). Diskettes are ideal as a portable storage solution for small files that need to be physically moved around. For example, if two PCs are not on the same network, diskettes are a great solution to transfer files from one computer to the other.

4.1.1. Mounting and Unmounting a Diskette

A diskette must first be mounted before it can be used. To mount a diskette, insert it into the diskette drive and type `mount /mnt/floppy/` at a shell prompt.

The diskette drive activity light should blink as the diskette’s file system is mounted to the `/mnt/floppy` directory.

You can access the contents of the diskette by changing into that directory with the `cd /mnt/floppy/` command.

Alternatively, you can also mount a diskette by right-clicking on the desktop and choosing `Disks => Floppy`. This mounts the diskette and adds a desktop icon which you can double-click to explore the diskette contents.

Now that the diskette has been mounted it is available to be copied from or written to. You can open, save, and copy files to/from it as you would normally do to your hard drive. You can even explore the diskette’s contents in Nautilus (as shown in Figure 4-1) or Konqueror.

![Figure 4-1. Viewing files on a Diskette with Nautilus](image)

When you are done using the diskette, you should unmount it before ejecting it from the drive. To do this, close any applications that may be using files on the diskette or exploring the diskette’s contents (such as Nautilus or Konqueror), and at a shell prompt type the following command:

`umount /mnt/floppy/`
If you are using GNOME, you can unmount the diskette by right-clicking on the icon and choosing **Unmount Volume** from the menu. You can now safely eject the diskette from the drive.

### 4.1.2. Putting Linux Files on an MS-DOS Diskette

To copy files from a Linux machine to an MS-DOS formatted diskette so that a Windows machine can read it you should format your diskette with an MS-DOS (FAT) file system. This can be done with the Windows OS or with **g floppy** (see Section 4.1.3.1 Using **g floppy**). Then mount it in Linux as described in Section 4.1.1 **Mounting and Unmounting a Diskette**. Copy files using the following command (substituting `filename` with the name of the file you wish to copy):

```
cp filename /mnt/floppy
```

You can then unmount the diskette and eject it from the drive. The new file on the diskette should now be accessible from your Windows machine.

### 4.1.3. Formatting a Diskette

To use a diskette specifically with Red Hat Linux, you need to format the diskette using the ext2 file system. ext2 is one of the file systems supported by Red Hat Linux, and is the default method used for formatting diskettes.

**Warning**

Formatting a diskette will erase all of its contents. Be sure to backup any files that you need before performing any of the following operations on your diskettes.

Once you have created an ext2 file system on the diskette, you can manipulate its contents in the same ways that you manipulate directories and files on your hard drive.

### 4.1.3.1. Using **g floppy**

To start **g floppy**, choose **Main Menu** => **System Tools** => **Floppy Formatter**. From a shell prompt, type `/usr/bin/gfloppy`. As shown in Figure 4-2, the **g floppy** interface is small and has few options. The default settings are sufficient for most users and needs; however, you can format your diskette with an MS-DOS file system type if necessary. You can also choose the density of your diskette (if you are not using the usual high density 3.5" 1.44MB diskette). You can also elect to **quick format** the diskette if it was previously formatted as ext2.
Insert a diskette and change the settings in *gloppy* to suit your needs; then click **Format**. The status box will appear on top of the main window, showing you the status of formatting and verification (see Figure 4-3). Once complete, you can eject the diskette and close *gloppy*.

**Figure 4-3. gloppy Status Box**

### 4.1.3.2. Using *mke2fs*

The *mke2fs* command is used to create a Linux ext2 file system on a device such as a hard drive partition or (in this case) a diskette. *mke2fs* essentially formats the device and creates an empty, Linux-compatible device which can then be used for storing files and data.

Insert your diskette into the drive and issue the following command at a shell prompt:

```
/sbin/mke2fs /dev/fd0
```

On Linux systems, `/dev/fd0` refers to the first diskette drive. If your computer has more than one diskette drive, your primary diskette drive is `/dev/fd0`, your second `/dev/fd1`, and so on.

The *mke2fs* utility has a number of options. The `-c` option makes the *mke2fs* command check the device for bad blocks before creating the file system. The other options are covered in the *mke2fs* man page.

Once you have created an ext2 file system on the diskette, it is ready to be used with your Red Hat Linux system.
4.2. CD-ROMs

The CD-ROM format is a popular medium to deliver typically large software applications as well as multimedia games and presentations. Most of the software that can be purchased from retail outlets come in the form of CD-ROMs. This section shows you how to use CD-ROMs on your Red Hat Linux system.

4.2.1. Using CD-ROMs with Your File Manager

By default, CDs are automatically mounted and the file manager is displayed allowing you to explore the contents of the CD. Figure 4-4 shows the contents of a CD-ROM within the Nautilus file manager.

![Figure 4-4. Contents of a CD-ROM in Nautilus](image)

A CD desktop icon also appears, which you can use to unmount and eject your CD-ROM after use. Right-click on the icon to view all of the available choices. For example, to unmount and eject the CD-ROM, choose Eject from the menu.

4.2.2. Using CD-ROMs From a Shell Prompt

You can also manually mount and unmount your CD-ROMs from a shell prompt. Insert a CD into your CD-ROM drive, open a shell prompt, and type the following command:

```
mount /mnt/cdrom
```

The CD-ROM should now be mounted and available for use with your file manager. You can access your CD-ROM by clicking the home icon on the desktop and typing `/mnt/cdrom` in the location bar.

After working with your CD, you must unmount it before you can eject it from your CD-ROM drive. Close any applications or file managers that are using the CD-ROM and type the following command at a shell prompt:

```
umount /mnt/cdrom
```

You can now safely press the eject button on your CD-ROM drive to retrieve your CD.

4.3. CD-Rs and CD-RWs

CD-writable (CD-R) drives have grown in popularity as an inexpensive way to backup and archive several megabytes of data, including applications, personal files, and even multimedia (audio/video and
still image) presentations. Red Hat Linux includes several tools for using CD-Rs and CD-rewritable (CD-RW) drives.

4.3.1. Using CD Creator

If you want to perform a quick file or directory backup to a CD-R or CD-RW, there is a tool included in the Nautilus file manager called CD Creator.

CD Creator allows you to drag and drop files from a Nautilus window to the CD Creator interface. To access the CD Creator feature in Nautilus, insert a blank CD-R(W) into your drive and the CD Creator window will automatically display. You can also double click your home directory icon from the desktop and choose Go => CD Creator from the window menus. You can also type burn: in the Location bar to start CD Creator.

Figure 4-5. The CD Creator Interface in Nautilus

Open a new Nautilus window and select the files or directories you want to write to CD-R(W). To select multiple files, press and hold the [Ctrl] key, and click on the files and folders. Then release the [Ctrl] key, press and hold the left mouse button, and drag the files and folders to the CD Creator window.

When you are ready to write the files to your CD-R(W), click the Write to CD button in the CD Creator window, which displays a dialog box where you can select the writing speed, name the CD, and choose other options.

Figure 4-6. The CD Creator Write Dialog Box
Click the **Write files to CD** button to start burning. A status window displays the writing progress, as shown in Figure 4-7.

![Writing to CD, Please wait.](image1.png)

**Figure 4-7. The CD Creator Write Status Window**

By default, the CD-R(W) should automatically eject from your drive when it is finished. Since it is generally recommended to periodically backup personal files, the **CD Creator** can help you do so quickly.

### 4.3.2. Using X-CD-Roast

**X-CD-Roast** is a graphical application for duplicating and creating (also known as mastering) CD-ROMs. **X-CD-Roast** automates the process of burning CD-Rs and CD-RWs and is highly configurable to many CD mastering or duplicating needs.

To start **X-CD-Roast** choose **Main Menu => System Tools => CD Writer**. To start it at a shell prompt, type `/usr/bin/xcdroast`. **X-CD-Roast** first scans your device busses and finds your CD-R(W) drive. It then allows you to configure settings for CD-writer, CD-ROM drive, and more. Figure 4-8 illustrates the **Setup** screen and its configuration options. Note that your CD-R(W) drive brand may be different from the drive shown.

![Setup screen](image2.png)

**Figure 4-8. X-CD-Roast Setup Screen**

Check your CD-R(W) manufacturer documentation to set some of the **CD Settings** options, such as **CD Writer Speed** and **CD Writer FIFO-Buffer Size**. All CD image (.iso or .img) files need to be stored in a central location accessible to **X-CD-Roast**. You must specify a path on your hard drive’s file system that has at least 700 Megabytes (MB) of free space available. You can configure the path where you wish to store CD images in the **HD Settings** tab under **Path**.
**X-CD-Roast** is well-documented within the interface itself, as several of the options have long, descriptive pop-up tips that informs you of the associated function in detail. You can access these tooltips by leaving your mouse pointer on a button or drop-down menu for at least two seconds.

### 4.3.2.1. Using X-CD-Roast to Duplicate CD-ROMs

To duplicate an existing CD-ROM for backup purposes, click the **Duplicate CD** button in the main panel. You can read all of the *tracks* on a CD — all CD-ROM information, including data and audio, is stored on tracks — by clicking **Read CD**. You can set the speed at which you read a CD-ROM as well as find out some information about the CD-ROM track such as its type and size. If you are copying tracks from an audio CD, you can preview each track with **Play Audio-Tracks**. Since **X-CD-Roast** reads all tracks of a CD-ROM by default, you can delete unwanted tracks with **Delete Tracks**.

Finally, to burn your tracks onto CD-R(W) media, choose **Write CD**. Figure 4-9 shows the **Write CD** dialog box, where you can configure the speed at which you read and write the tracks to CD-R(W), as well as whether you wish to copy the CD-ROM *on-the-fly* or create an image file first before burning (which is recommended to prevent write or read errors from occurring during the duplication process). Click the **Write CD** button to start the burning process.

![Figure 4-9. Using X-CD-Roast to Duplicate CDs](image)

### 4.3.2.2. Using X-CD-Roast to Create a CD

It is always recommended to backup personal data and information often in case of hardware failure or file system corruption. **X-CD-Roast** allows you to backup files on your hard drive partition using **Create CD**. This facility allows you to add files and directories into a CD *session* using **Master Tracks**. There are other options within the **Master Tracks** dialog that allows you to configure advanced settings; however, the defaults are set correctly to create data CD-ROMs, so no further configuration is necessary. Figure 4-10 shows a session that is preparing the entire `/home` directory for backup.
Chapter 4. Diskettes and CD-ROMs

Figure 4-10. Using X-CD-Roast to Back-up Hard Drive Files

Highlight the files and directories that you wish to add to the session and click Add. After you have added all files and directories you want to write to the CD-R(W), click the Create session/image tab to create the .img file. You must first click Calculate size, then click Master to image file to create the image.

To write your tracks to the CD-R(W), click Write Tracks from the panel on the left. In the Layout Tracks tab, highlight the image file you created in the box on the right, and click Add. The image displays in the Tracks to write box on the left side. Click Accept track layout, and click the Write Tracks tab to return to the main writing dialog. Click Write tracks to write the image to the CD-R(W).

Tip
You can also create and write the image to the CD-R(W) in one step by clicking Master and write on-the-fly in the Create session image tab. This saves a few steps but can sometimes cause read-write errors. It is recommended that you use the multi-step method instead of the on-the-fly methods.

4.3.2.3. Writing ISOs with X-CD-Roast

Large files that end in .iso are known as ISO9660 (or ISO) image files. For example, Red Hat Linux is freely available as ISO images that you can download and write to the CD-R(W). There are also other ISO image files available on FTP and websites. There are other file types that can be burned as images, such as .img and .raw, but ISO images are the most common CD image format.

To write an ISO image file to a CD-R(W) with X-CD-Roast, move the ISO file to the path specified during setup, then click Create CD. In the Layout tracks tab, highlight the ISO image file you wish to burn and click Add, then Accept track layout. This automatically loads the Write Tracks tab, where you can click Write Tracks to burn the image to the CD-R(W).

4.3.3. Using CD-Rs and CD-RWs with Command Line Tools

If you want to use a shell prompt to write images to CD-R or CD-RWs, there are two utilities available: mkisofs and cdrecord. These utilities have several advanced options that are beyond the scope of
this guide; however, for basic image creation and writing, these tools save some time over the graphical alternatives such as X-CD-Roast.

### 4.3.3.1. Using mksisos

The `mksisos` utility creates ISO9660 image files that can be written to a CD-R(W). The images created by `mksisos` can include all types of files. It is most useful for archival and file backup purposes.

Suppose you wish to backup a directory called `/home/joeuser/`, but exclude the subdirectory `/home/joeuser/junk/` because it contains unnecessary files. You want to create an ISO image called `backup.iso` and write it to CD-R(W) so that you can use it on your Red Hat Linux PC at work and your Windows laptop for trips. This can be done with `mksisos` by running the following command:

```
mksisos -o backup.iso -x /home/joeuser/junk/ -J -R -A -V -v /home/joeuser/
```

The image is created in the same directory that you ran the command. Table 4-1 explains each command line option. For more information on using `mksisos`, refer to the additional resources in Section 4.4 Additional Resources.

You can now use the ISO image file with either X-CD-Roast as described in Section 4.3.2.3 Writing ISOs with X-CD-Roast, or using `cdrecord`, the command line based CD recording utility. For more information about using `cdrecord`, refer to Section 4.3.3.2 Using cdrecord.

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>-o</td>
<td>Specifies an output file name of the ISO image.</td>
</tr>
<tr>
<td>-J</td>
<td>Generates Joliet naming records; useful if the CD is used in Windows environments.</td>
</tr>
<tr>
<td>-R</td>
<td>Generates Rock Ridge (RR) naming records to preserve filename length and casing, especially for UNIX/Linux environments.</td>
</tr>
<tr>
<td>-A</td>
<td>Sets an Application ID — a text string that will be written into the volume header of the image which can be useful to determine what applications are on the CD.</td>
</tr>
<tr>
<td>-V</td>
<td>Sets a Volume ID — a name that is assigned to it if the image is burned, and the disc is mounted in Solaris and Windows environments.</td>
</tr>
<tr>
<td>-v</td>
<td>Sets verbose execution, which is useful for viewing the status of the image as it is being made.</td>
</tr>
<tr>
<td>-x</td>
<td>Excludes any directory immediately following this option; this option can be repeated (for example, ... -x/home/joe/trash -x /home/joe/delete ...).</td>
</tr>
</tbody>
</table>

Table 4-1. mksisos Options

### 4.3.3.2. Using cdrecord

The `cdrecord` utility writes audio, data, and mixed-mode (a combination of audio, video, and/or data) CD-ROMs using options to configure several aspects of the write process, including speed, device, and data settings.

To use `cdrecord`, you must first establish the device address of your CD-R(W) device by running the following command as root at a shell prompt:
cdrecord -scanbus

This command shows all CD-R(W) devices on your computer. It is important to remember the device address of the device used to write your CD. The following is an example output from running cdrecord -scanbus.

Cdrecord 1.8 (i686-pc-linux-gnu) Copyright (C) 1995-2000 Jorg Schilling
Using libscg version 'schily-0.1'
scsibus0:
  0,0,0  0) *
  0,1,0  1) *
  0,2,0  2) *
  0,3,0  3) 'HP ' 'CD-Writer+ 9200 ' '1.0c' Removable CD-ROM
  0,4,0  4) *
  0,5,0  5) *
  0,6,0  6) *
  0,7,0  7) *

To write the backup file image created with mkisofs in the previous section, switch to the root user and type the following at a shell prompt:

cdrecord -v -eject speed=4 dev=0,3,0 backup.iso

The command sets the write speed (4), the device address (0,3,0), and sets write output (verbose [-v]), which is useful for tracking the status of the write process. The -eject argument ejects the CD-ROM after the write process is complete. The same command can also be used for burning ISO image files downloaded from the Internet, such as Red Hat Linux ISO images.

You can use cdrecord to blank CD-RW discs for reuse by typing the following:

cdrecord --dev=0,3,0 --blank=fast

4.4. Additional Resources

This chapter briefly covers several applications. Refer to the following resources for more information about the applications in this chapter

4.4.1. Installed Documentation

- cdrecord man page — Discusses how to burn data, audio and mixed-mode CD-ROMs. Offers all options and commands in detail, including some example commands for common CD-R(W) burning tasks.
- /usr/share/doc/cdrecord-<version> (where <version> is the version of cdrecord installed on your system) — Several documentation files are included with general usage and licensing information.
- mkisofs man page — Comprehensive detail of the utility, including some warnings about creating certain types of ISO images. Offers all options and commands in detail, including some example commands for creating common ISO image files.
- /usr/share/doc/mkisofs-<version> (where <version> is the version of mkisofs installed on your system) — Several documentation files are included with general usage and licensing information.
• /usr/share/doc/xcdroast-<version> (where <version> is the version of X-CD-Roast installed on your system) — Contains useful command-line options and usage information for this graphical CD-R(W) mastering application.

• /usr/share/doc/dvdrecord-<version>/ (where <version> is the version of dvdrecord installed on your system) — For users who have DVD-R(+W) devices, this set of documentation helps you get started mastering DVD-ROMs for data backup and multimedia presentation.

### 4.4.2. Useful Websites

- [http://freshmeat.net/projects/cdrecord/](http://freshmeat.net/projects/cdrecord/) — The cdrecord project page on Freshmeat is regularly updated with the newest releases, news, and user commentary.
- [http://www.freesoftware.fsf.org/dvdrtools/](http://www.freesoftware.fsf.org/dvdrtools/) — The official website of the dvdrtools project, which includes the dvdrecord utility for writing DVD-R(+W) discs.
Exploring the Internet has become a popular activity. People use the Internet for everything from information to finances to getting medical prescriptions on the Web. However, in order to use the Internet, you must have a connection to it. There are many types of Internet connections, including:

- ISDN Connection
- Modem Connection
- Wireless Connection
- xDSL Connection
- Ethernet Connections

Red Hat Linux includes the **Internet Configuration Wizard**, which can be used to create an Internet connection. You can then configure the connection that you created at any time using the **Network Administration Tool**. More information about the **Network Administration Tool** can be found in the chapter entitled **Network Configuration** in the *Red Hat Linux Customization Guide*.

To use **Internet Configuration Wizard**, you must be running the X Window System and have root privileges. To start the application, use one of the following methods:

- In the graphical desktop environment, go to the **Main Menu => System Tools => Internet Configuration Wizard**.
- At a shell prompt, type the command `internet-druid`

In both cases you will have to enter your root password to continue.

Your own ISP may have specific connection requirements for their service which differ from the instructions in this chapter. Before connecting, check with your ISP for any specific instructions that they provide, including the following information:

- The phone number that your modem must dial to connect to your ISP if you are using a modem.
- Your login name and password for your account if you are using an xDSL or modem connection.
- A *gateway address*. Some ISPs may require you to configure a master address (called the gateway) that authenticates your computer and allows it to connect to the Internet.
- **DNS entries**: DNS means *Domain Name System*. DNS servers act as a road map for the Internet. When you use the Internet, the DNS tells your machine where to send its traffic. DNS tracks *IP* (Internet Protocol) addresses; each computer connected to the Internet must have an IP address, which is a unique set of numbers like `2xx.2xx.2x.2`. You may receive one or more DNS entries from your Internet provider when you sign up.
Figure 5-1. Internet Configuration Wizard

ISDN Connection

An ISDN (Integrated Services Digital Network) connection uses high-speed, high-quality digital telecommunication lines as opposed to an analog modem connection. This special phone line must be installed by a phone company. To configure this type of connection, start Internet Configuration Wizard, select ISDN Connection, and follow the steps in the wizard.

Modem Connection

A modem connection uses a modem to establish a connection to the Internet. Digital data is modulated into analog signals and sent over phone lines. To configure this type of connection, start Internet Configuration Wizard, select Modem Connection, and follow the steps in the wizard.

xDSL Connection

An xDSL (Digital Subscriber Line) connection uses high-speed transmissions through telephone lines. There are different types of DSL such as ADSL, IDSL, and SDSL. Internet Configuration Wizard uses the term xDSL to mean all types of DSL connections.

Some DSL providers require you to configure your system to obtain an IP address through DHCP with an Ethernet card. To configure this type of connection, start Internet Configuration Wizard, select Ethernet Connection, and select DHCP on the Configure Network Settings screen. Some DSL providers require you to configure a PPPoE (Point-to-Point Protocol over Ethernet) connection with an Ethernet card. To configure this type of connection, start the Internet Configuration Wizard, select xDSL Connection, and follow the steps in the wizard. If you must supply a username and password to connect, you are probably using PPPoE. Ask your DSL provider which method you should use.

Cable Modem Connection

A cable modem connection uses the same coaxial cable that your TV cable travels on to transmit data. Most cable Internet providers require you to install an Ethernet card in your computer that connects to the cable modem. Then, the cable modem connects to the coaxial cable. The Ethernet card is usually required to be configured for DHCP. To configure this type of connection, start Internet Configuration Wizard, select Ethernet Connection, and select DHCP on the Configure Network Settings screen.
Wireless Connection

If you are connecting your Red Hat Linux computer to a wireless access point (WAP) or peer-to-peer (also called ad-hoc) network with a wireless (802.11x) network card, then you will need to configure your wireless device. Choose the **Wireless Connection**, then select the device from the list provided. You can then configure the device for DHCP or fixed IP addresses in the pop-up device configuration window.

The **Internet Configuration Wizard** is a utility that guides you step-by-step through the process of establishing your Internet connection. Once your connection is up and running, you can then configure it to suit your needs or particular connection. For more detailed instructions, refer to the **Network Configuration** chapter in the *Red Hat Linux Customization Guide*. 
Chapter 6.
Web Browsing

Once you have configured your Internet connection (see Chapter 5 Getting Online), you are ready to get online. Red Hat Linux comes with several Web browsers, graphical applications that use your Internet connection to access the World Wide Web: news, research, shopping, banking, and more. This chapter briefly explains how to surf the Web using Mozilla and Galeon. For information about using the Konqueror Web browser, refer to Section A.6 Browsing the Web with Konqueror.

6.1. Mozilla

Part of the mozilla.org organization’s wide range of Open Source Internet application developments, Mozilla is a powerful, integrated, and standards-compliant Web browser, email client, news reader, and more. The Web browsing component displays Web content such as webpages and images. Mozilla also uses plug-ins for interactive multimedia such as streaming video and Web animation. This section shows you how to use the Mozilla Web browser to explore the Internet.

To start Mozilla click the Mozilla Web Browser launcher on the panel or choose Main Menu => Internet => Mozilla Web Browser.

![Mozilla Main Browser Window](image)

6.1.1. Using Mozilla

Mozilla functions like any Web browser that you may have used before. It has the standard navigational toolbars, buttons, and menus.
The navigation bar has an address field with which you can type a *Uniform Resource Locator* (URL) — the name or address of a website — into the address field at the top of the browser window. **Mozilla** supports keyword searching via the address field as well. Type in a keyword or phrase into the address field and click the **Search** button. The search results appears in the main browsing area.

![Figure 6-2. The Mozilla Navigational Bar](image)

There is also a sidebar on the left that contains additional options, such as integrated search functionality, bookmarks, and a **What’s Related** option that displays webpages similar in topic to the page currently displayed in the main browsing area.

![Figure 6-3. The Mozilla SideBar](image)

At the bottom left corner of the browser window, there are the following small icons: **Navigator**, **Mail**, **Composer**, **Address Book**, and **IRC Chat**. These are separate applications integrated into the **Mozilla** suite and are useful for experiencing email, chat, news, and other aspects of the Internet besides the Web. For information on using the **Mozilla Mail** email client, refer to Chapter 7 **Email Applications**.

Finally, there is the **Personal Toolbar**, which you can customize with your own bookmarks or quickly go back to your homepage. The Personal Toolbar is useful for keeping and categorizing webpages so that you do not have to type the address every time you want to access the page. To add a site to your Personal Toolbar, click and hold the left mouse button on the small icon next to the URL in the address field and drag it directly to the Personal Toolbar or into a folder icon. You can access Personal Toolbar folders by clicking the icon and choosing the website from the drop-down menu.
Mozilla also allows you to browse multiple websites within one browser window using navigational tabs. Instead of using two or more separate windows to read multiple webpages, you can open a tab by clicking File => New => Navigation Tab or by pressing [Ctrl] and [T] at the same time. This will open the new tab and allow you to switch between tabs by clicking on them. To close a tab, right-click on the tab and choose Close Tab from the menu or click the X at the right of the tab bar to close the tab currently displayed.

For additional information on using Mozilla, click on Help (on the top menu panel) and then on Help Contents.

6.1.2. Mozilla Composer

You can use Mozilla Composer to create webpages. You do not need to know HTML to use this tool. To open Composer, go to Window => Composer on the Mozilla main menu, or click on the Composer icon in the lower left part of the screen:

The Mozilla help files provide information on creating webpages with Composer.

Go to Help on the main menu and select Help Contents. When the help screen opens, click on the Contents tab and expand the Creating Webpages menu by clicking on the arrow next to it. A list of topics will appear and clicking on any of these will provide you with information for creating and editing webpages using Mozilla Composer.

![Mozilla Composer](image)

Figure 6-4. Mozilla Composer

6.2. Galeon

Galeon is a Web browser that is based on Mozilla. It is only a Web browser and does not feature email, newsgroups, or anything other than Web browsing and searching. This can be useful if you want to browse the Web without the need to email or chat with others. Galeon also has some extra features that are not included in Mozilla.

To use Galeon, a working installation of Mozilla is required. Galeon uses Mozilla’s HTML and image renderer and plug-in system to display Web and multimedia content.
To launch **Galeon**, go to **Main Menu => Internet => More Internet => Galeon**.

The first time you launch **Galeon**, it will take you through the configuration process.

![Figure 6-5. Configuring Galeon](image)

During the initial configuration, you have the option of importing bookmarks and preferences from **Mozilla** or other Web applications you may have installed on your system. You can also configure **Galeon**’ personal toolbar with bookmarks, integrated search features, and even browser navigation shortcuts.

Once you have finished your configuration of **Galeon**, the main browser will appear.

![Figure 6-6. Online with Galeon](image)

Using **Galeon** is much like using **Mozilla**. There are navigational buttons for moving from one visited webpage to another using the **Forward**, **Back**, and **Home** buttons, as well as **Reload** and **Stop** buttons to refresh a webpage and stop it from loading, respectively.
Like Mozilla, Galeon also has a navigational tab feature that can help you avoid having your desktop cluttered with browser windows. Multiple pages can be stored in a single Galeon window, and you can switch between them by clicking on the each tab. To launch a new Tab, use the [Ctrl]-[T] key combination or select New Tab from the File menu. To close a tab, click the X button within the tab, or right-click the tab and choose Close Tab from the drop-down menu. The tabbed browsing mode can be configured in the Tabs page of the Preferences Window, which is accessible by choosing Settings => Preferences from the browser’s main menu.

For additional information or help with Galeon, click Help on the top menu bar. From there, you can choose to view the Galeon FAQ and Galeon manual.

### 6.3. Web Browser Keyboard Shortcuts

Table 6-1 shows some common keyboard shortcuts available in both Mozilla and Galeon. Keyboard shortcuts can help you efficiently browse the Web.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Ctrl]-[T]</td>
<td>Open a new tab for browsing multiple websites within one browser window</td>
</tr>
<tr>
<td>[Ctrl]-[N]</td>
<td>Open a new browser window</td>
</tr>
<tr>
<td>[Ctrl]-[Q]</td>
<td>Close all browser windows and exits the application</td>
</tr>
<tr>
<td>[Ctrl]-[L]</td>
<td>Move the cursor to the browser’s address field</td>
</tr>
<tr>
<td>[Ctrl]-[P]</td>
<td>Print the current displayed webpage or document</td>
</tr>
<tr>
<td>[Ctrl]-[right arrow]</td>
<td>Move forward by one link or page</td>
</tr>
<tr>
<td>[Ctrl]-[left arrow]</td>
<td>Move backward by one link or page</td>
</tr>
<tr>
<td>[Ctrl]-[R]</td>
<td>Reload the current page</td>
</tr>
<tr>
<td>[Ctrl]-[H]</td>
<td>Open the browsing history</td>
</tr>
<tr>
<td>[Ctrl]-[F]</td>
<td>Find a keyword or string within a page</td>
</tr>
</tbody>
</table>

Table 6-1. Keyboard Shortcuts
Email is a very popular way of communicating with others over the Internet. You can use email with an email client, an application that understands the various email transmission standards and allows you to send, receive, and read email. Red Hat Linux includes several email applications, including graphical email clients like Evolution and Mozilla Mail, and text-based clients like mutt. All of the email client applications are designed to suit certain types of users; so, you can choose one with the features that best suits your particular needs.

The purpose of this chapter is to demonstrate how to use some of the popular email applications included in Red Hat Linux. Since all email clients perform the same basic tasks (send and receive email), choose the one that is most convenient and easy to use.

This chapter will briefly discuss the following email clients:

- **Evolution**
- **Mozilla Mail**
- Text-based email clients

Before you launch an email client, you should have some information from your Internet Service Provider (ISP) handy so that you can configure the client properly. The following lists a few important things you may need to know:

Your email address

The email address you will use to send and receive mail. This is usually in the form of your-name@yourisp.net.

Server type for receiving email (POP or IMAP)

In order to receive mail, you must know what type of server your network administrator or ISP is using. This POP or IMAP address, is usually in the form of mail.someisp.net.

POP, short for Post Office Protocol, is used to send email from a mail server to your email client’s inbox, the place where incoming email is stored. Most ISP email servers use the POP protocol, although some can use the newer IMAP (Internet Message Access Protocol).

IMAP, short for Internet Message Access Protocol, is a protocol for retrieving email messages from your ISP’s email server. IMAP differs from POP in that email from IMAP servers are stored on the server and stays there even as you download and read your mail, whereas POP mail is downloaded to your email client directly and does not stay on the server.

Server type for sending email (SMTP)

The Simple Mail Transfer Protocol (SMTP) is a protocol for sending email messages between servers. Most email systems that send mail over the Internet use SMTP to send messages from one server to another; the messages can then be retrieved with an email client using either POP or IMAP. SMTP is also used to send messages from a mail client to a mail server. This is why you need to specify both the POP or IMAP server and the SMTP server when you configure your email application.

If you have any questions regarding what information you need, contact your ISP or network administrator. Unless properly configured, you will not be able to make full use of the email clients discussed in this chapter.
7.1. Evolution

Evolution is more than just an email client. It provides all of the standard email client features, including powerful mailbox management, user-defined filters, and quick searches. It additionally features a flexible calendar/scheduler which allows users to create and confirm group meetings and special events online. Evolution is a full-featured personal and workgroup information management tool for Linux and UNIX-based systems, and is the default email client for Red Hat Linux.

To launch Evolution from the desktop panel, go to Main Menu => Internet => Email.

Figure 7-1. Evolution Welcome Screen

The first time you start Evolution you will be presented with the Welcome Screen (Figure 7-1), which allows you to configure your email connection. Follow the on-screen instructions and fill in the information you collected from your ISP or administrator in the text boxes provided. When you are done, click Finish, and you will be presented with the Main Screen as shown in Figure 7-2.

Figure 7-2. Evolution Main Screen

To see what is in your inbox or to send an email, click on the Inbox icon.
Chapter 7. Email Applications

Figure 7-3. Evolution Inbox Screen

To compose a mail, select **New Message** from the toolbar.

Figure 7-4. Evolution New Email Message Screen

Once you have composed a message and entered an email address to send the email to, click **Send** on the toolbar.

While **Evolution** does so much more than read and send email, this chapter focusses exclusively on its email capabilities. If you would like to learn more about using some of the other features of **Evolution**, like calendering/scheduling and group messaging, click **Help** from the main toolbar and choose the component you want to learn more about.
7.2. Mozilla Mail

This section briefly covers the basic steps for sending and receiving email with Mozilla. If you need further information about using Mozilla Mail, the Mozilla Help contents are located under Help on the main menu.

To start Mozilla Mail, select Main Menu => Extras Internet => Mozilla Mail.

To open Mozilla Mail while in Mozilla, click on the mail icon near the lower left corner of the Mozilla screen.

Figure 7-5. Mozilla Mail and News

Figure 7-6. Mozilla Mail New Email Message Screen
To send an email, click on the Send button or go to File => Send Now or Send Later. If you choose to send later, you can go back to the main mail screen and go to File => Send unsent messages.

To read email, click on the mail folder you created for yourself to see a list of messages waiting for you. Then, click on the message you want to read.

Once you read a message, you can delete it, save it to a separate folder, and more.

### 7.2.1. Mozilla and Newsgroups

Newsgroups are Internet discussion groups with specific topics. The discussions are in threaded format (which means all topics and responses to the topic are sorted and organized for convenient reading) and subscribing to a group is very easy. You do not have to post messages if you do not want to; you can just lurk, which is a Newsgroup term for reading without posting messages. There are a great many newsgroups on the Web with topics ranging from politics to computer games to random strange thoughts. You can even post and download pictures and files to Newsgroups (although your ISP may restrict Newsgroups to text-based postings only).

To join a newsgroup, you first need to set up a newsgroup account. Click on your mail account name in the sidebar and select Create a new account from the options that appear on the right of the screen. The New Account Setup screen will appear. Select Newsgroup account and then click Next.

![New Account Setup](image)

**Figure 7-7. Newsgroup Account Setup**

Enter your name and email address on the next screen and click Next. On the following screen, enter the name of your news server (if you do not know the name of your news server, contact your Internet service provider or network administrator for this information). On the last few screens, you can determine the name that this account will be referred to and review your settings.

The newsgroup account you created will appear in the sidebar of the Mozilla mail screen. Right-click on this account name and select Subscribe. A dialog box appears, listing all the newsgroups available. Select the groups you are interested in reading and click Subscribe. When you are done, click on OK.

Now, click on the arrow next to the newsgroup account name and the list of groups you are subscribed to will appear beneath. Select the newsgroup you want to access and a dialog box appears with information about downloading and reading existing messages. Posting to a newsgroup is just like writing
an email, except that the newsgroup name appears in the To field rather than an email address. To unsubscribe from a newsgroup, right-click on the group name and select Unsubscribe.

7.3. Plain Text Email Clients

Most modern email clients allow the user to select whether they want to send their emails in plain text or in HTML. The advantage of HTML formatted email is that they can contain graphics and interactive links to Web sites. The particular font can be specified, the layout is very controllable, textures, and pictures or backgrounds can be added; all this makes for a visually appealing message when it gets to the recipient.

On the other hand, plain text email is just that — plain text. They is nothing fancy, there are no pictures embedded in the email, and there are no special fonts. Plain text emails are simple.

The term plain text refers to textual data in ASCII format. Plain text (also called clear text) is the most portable format because it is supported by nearly every email application on various types of machines.

This chapter will discuss the mutt plain text email client.

7.3.1. Using Mutt

Mutt is a small but very powerful text-based mail client for UNIX operating systems.

Mutt’s configuration file, ~/.muttrc, gives mutt its flexibility and configurability. It is also this file that might give new users problems. The number of options that mutt has available to it are truly astounding. mutt allows the user to control nearly all of the functions that mutt uses to send, receive, and read your mail. As is true with all powerful software, it takes time to understand the features and what they can do for you.

Most of the options are invoked using the set or unset commands, with either boolean or string values, e.g. set folder = ~/Mail.

All configuration options can be changed at any time by typing a [:] followed by the relevant command. For example :unset help turns off the handy keyboard command hints at the top of the screen. To turn those hints back on, type :set help.

If you cannot remember the command you want to use, there is always tab-completion to help you.

You do not have to type all your preferred configuration commands each time you run mutt, you can save them in a file which is loaded every time the program starts up. This configuration file must exist in your home directory, it has to be named either ~/.muttrc or ~/.mutt/muttrc.

When you launch mutt, the first thing you see is a screen with a list of email messages. This initial menu is called the index.
These messages are in a default mail folder, often called the mailspool, that you can think of as your inbox. Use the [K] and [J] keys on your keyboard to move the highlighted cursor up and down the list of messages.

In the index or pager views, use the [R] key to reply to a message or the [M] key to create a new one. Mutt will prompt for the To: address and the Subject: line. A text editor (defined by your $EDITOR environmental variable in the configuration file) will then launch allowing you to compose your message. Type your message, save your file and exit the editor.

After editing your email, Mutt displays the compose menu, where you can customize your message headers, change the encoding, add file attachments or simply press the [Y] key to send your email on its way.

To learn more about mutt, refer to the man pages for muttrc and mutt (type man muttrc or man mutt at the shell prompt). You may also find the mutt manual to be very helpful. The mutt manual is installed in /usr/share/doc/mutt-1.2.X, where X is the version number of mutt installed on your system.
Most computer users either own a printer at home or use one at work. Printers have become a very popular PC peripheral due to their increasing quality and decreasing prices. Printer hardware manufacturers distribute CD-ROMs or diskettes with their printers, as most operating systems require these CD-ROMs because they contain printer drivers — software that communicates with both the printer and the operating system. Red Hat Linux provides drivers for most printer models, thus the drivers and software on the printer manufacturer’s CD-ROM and diskettes are not needed. With few exceptions, all you need to do is attach the printer to your Red Hat Linux system, turn on the printer, and configure it with the useful tools provided by Red Hat Linux.

8.1. The Printer Configuration Tool

Red Hat Linux includes a graphical utility for configuring local and remote printers without the need to install additional drivers and applications. The Printer Configuration Tool uses a step-by-step process that can help you configure a printer faster than editing configuration files manually. This chapter shows you how to set up and test a printer directly connected to your Red Hat Linux system. For remote printer setup and more advanced printer configuration issues, refer to the chapter called Printer Configuration in the Red Hat Linux Customization Guide.

8.2. Adding a Local Printer

To add a local printer, such as one attached through a parallel port or USB port on your computer, click the New button in the main Printer Configuration Tool window to display the window in Figure 8-1. Click Forward to proceed.

In the window shown in Figure 8-2, enter a unique name for the printer in the Name text field. The printer name cannot contain spaces and must begin with a letter. The printer name may contain letters, numbers, dashes (-), and underscores (_). Optionally, enter a short description for the printer, which can contain spaces.
After clicking Forward, Figure 8-3 appears. Select Locally-connected from the Select a queue type menu, and select the device. The device is usually /dev/lp0 for a parallel printer or /dev/usb/lp0 for a USB printer. If no devices appear in the list, click Rescan devices to rescan the computer or click Custom device to specify it manually. Click Forward to continue.

The next step is to select the type of printer. Go to Section 8.3 Selecting the Printer Model and Finishing to continue.

8.3. Selecting the Printer Model and Finishing

After selecting the queue type of the printer, the next step is to select the printer model. You will see a window similar to Figure 8-4. If it was not auto-detected, select the model from the list. The printers are divided by manufacturers. Select the name of the printer manufacturer from the pulldown menu. The printer models are updated each time a different manufacturer is selected. Select the printer model from the list.
The recommended print driver is selected based on the printer model selected. The print driver processes the data that you want to print into a format the printer can understand. Since a local printer is attached directly to your computer, you need a print driver to process the data that is sent to the printer.

If you are configuring a remote printer (IPP, LPD, SMB, or NCP), the remote print server usually has its own print driver. If you select an additional print driver on your local computer, the data is filtered multiple times and is converted to a format that the printer can not understand.

To make sure the data is not filtered more than once, first try selecting **Generic** as the manufacturer and **Raw Print Queue** or **Postscript Printer** as the printer model. After applying the changes, print a test page to try out this new configuration. If the test fails, the remote print server might not have a print driver configured. Try selecting a print driver according to the manufacturer and model of the remote printer, applying the changes, and printing a test page.

**Tip**

You can select a different print driver after adding a printer by starting the **Printer Configuration Tool**, selecting the printer from the list, clicking **Edit**, clicking the **Driver** tab, selecting a different print driver, and then applying the changes.

### 8.3.1. Confirming Printer Configuration

The last step is to confirm your printer configuration. Click **Apply** to add the print queue if the settings are correct. Click **Back** to modify the printer configuration.

Click the **Apply** button in the main window to save your changes and restart the printer daemon. After applying the changes, print a test page to ensure the configuration is correct. Refer to Section 8.4 **Printing a Test Page** for details.

If you need to print characters beyond the basic ASCII set (including those used for languages such as Japanese), you must review your driver options and select **Prerender Postscript**. Refer to Section 8.5 **Modifying Existing Printers** for details. You can also configure options such as paper size if you edit the print queue after adding it.
8.4. Printing a Test Page

After you have configured your printer, you should print a test page to make sure the printer is functioning properly. To print a test page, select the printer that you want to try out from the printer list, then select the appropriate test page from the Test pulldown menu.

If you change the print driver or modify the driver options, you should print a test page to test the different configuration.

![Test Page Options](image)

8.5. Modifying Existing Printers

To delete an existing printer, select the printer and click the Delete button on the toolbar. The printer is removed from the printer list. Click Apply to save the changes and restart the printer daemon.

To set the default printer, select the printer from the printer list and click the Default button on the toolbar. The default printer icon □ appears in the Default column of the default printer in the list.

After adding the printer(s), the settings can be edited by selecting the printer from the printer list and clicking the Edit button. The tabbed window shown in Figure 8-6 is displayed. The window contains the current values for the selected printer. Make any necessary changes, and click OK. Click Apply in the main Printer Configuration Tool window to save the changes and restart the printer daemon.
8.5.1. Queue Name

To rename a printer or change its short description, change the value in the Queue name tab. Click OK to return to the main window. The name of the printer should change in the printer list. Click Apply to save the change and restart the printer daemon.

8.5.2. Queue Type

The Queue type tab shows the queue type that was selected when adding the printer and its settings. The queue type of the printer can be changed or just the settings. After making modifications, click OK to return to the main window. Click Apply to save the changes and restart the printer daemon.

Depending on which queue type is chosen, different options are displayed. Refer to the appropriate section on adding a printer for a description of the options.

8.5.3. Printer Driver

The Printer driver tab shows which print driver is currently being used. If it is changed, click OK to return to the main window. Click Apply to save the change and restart the printer daemon.

8.5.4. Driver Options

The Driver Options tab displays advanced printer options. Options vary for each print driver. Common options include:

- **Send Form-Feed (FF)** should be selected if the last page of the print job is not ejected from the printer (for example, the form feed light flashes). If this does not work, try selecting **Send End-of-Transmission (EOT)** instead. Some printers require both **Send Form-Feed (FF)** and **Send End-of-Transmission (EOT)** to eject the last page. This option is only available with the LPRng printing system.

- **Send End-of-Transmission (EOT)** should be selected if sending a form-feed does not work. Refer to **Send Form-Feed (FF)** above. This option is only available with the LPRng printing system.
• **Assume Unknown Data is Text** should be selected if the print driver does not recognize some of the data sent to it. Only select this option if there are problems printing. If this option is selected, the print driver assumes that any data that it can not recognize is text and attempts to print it as text. If this option is selected along with the **Convert Text to Postscript** option, the print driver assumes the unknown data is text and then converts it to PostScript. This option is only available with the LPRng printing system.

• **Prerender Postscript** should be selected if characters beyond the basic ASCII set are being sent to the printer but they are not printing correctly (such as Japanese characters). This option prerenders non-standard PostScript fonts so that they are printed correctly.

  If the printer does not support the fonts you are trying to print, try selecting this option. For example, select this option to print Japanese fonts to a non-Japanese printer.

  Extra time is required to perform this action. Do not choose it unless problems printing the correct fonts exist.

  Also select this option if the printer can not handle PostScript level 3. This option converts it to PostScript level 1.

• **GhostScript pre-filtering** — allows you to select **No pre-filtering**, **Convert to PS level 1**, or **Convert to PS level 2** in case the printer can not handle certain PostScript levels. This option is only available if the PostScript driver is used with the CUPS printing system.

• **Convert Text to Postscript** is selected by default. If the printer can print plain text, try unselecting this when printing plain text documents to decrease the time it takes to print. If the CUPS printing system is used, this is not an option because text is always converted to PostScript.

• **Page Size** allows the paper size to be selected. The options include US Letter, US Legal, A3, and A4.

• **Effective Filter Locale** defaults to C. If Japanese characters are being printed, select ja_JP. Otherwise, accept the default of C.

• **Media Source** defaults to Printer default. Change this option to use paper from a different tray.

To modify the driver options, click **OK** to return to the main window. Click **Apply** to save the change and restart the printer daemon.

### 8.6. Managing Print Jobs

When you send a print job to the printer daemon, such as printing text file from Emacs or printing an image from The GIMP, the print job is added to the print spool queue. The print spool queue is a list of print jobs that have been sent to the printer and information about each print request, such as the status of the request, the username of the person who sent the request, the hostname of the system that sent the request, the job number, and more.

If you are running a graphical desktop environment, click the **Printer Manager** icon on the panel to start the GNOME Print Manager as shown in Figure 8-7.
Chapter 8. Printer Configuration

Figure 8-7. GNOME Print Manager

It can also be started by selecting Main Menu Button (on the Panel) => System Tools => Print Manager. To change the printer settings, right-click on the icon for the printer and select Properties. The Printer Configuration Tool is then started.

Double-click on a configured printer to view the print spool queue as shown in Figure 8-8.

Figure 8-8. List of Print Jobs

To cancel a specific print job listed in the GNOME Print Manager, select it from the list and select Edit => Cancel Documents from the pulldown menu.

If there are active print jobs in the print spool, a printer notification icon might appear in the Panel Notification Area of the desktop panel as shown in Figure 8-9. Because it probes for active print jobs every five seconds, the icon might not be displayed for short print jobs.

Figure 8-9. Printer Notification Icon

Clicking on the printer notification icon starts the GNOME Print Manager to display a list of current print jobs.

Also located on the Panel is a Print Manager icon. To print a file from Nautilus, browse to the location of the file and drag and drop it on to the Print Manager icon on the Panel. The window shown in Figure 8-10 is displayed. Click OK to start printing the file.
Figure 8-10. Print Verification Window

To view the list of print jobs in the print spool from a shell prompt, type the command `lpq`. The last few lines will look similar to the following:

```
Rank  Owner/ID   Class  Job Files  Size  Time
active user@localhost+902   A  902 sample.txt  2050 01:20:46
```

**Example 8-1. Example of `lpq` output**

If you want to cancel a print job, find the job number of the request with the command `lpq` and then use the command `lprm job number`. For example, `lprm 902` would cancel the print job in Example 8-1. You must have proper permissions to cancel a print job. You can not cancel print jobs that were started by other users unless you are logged in as root on the machine to which the printer is attached.

You can also print a file directly from a shell prompt. For example, the command `lpr sample.txt` will print the text file `sample.txt`. The print filter determines what type of file it is and converts it a format the printer can understand.

**8.7. Additional Resources**

To learn more about printing on Red Hat Linux, refer to the following resources.

**8.7.1. Installed Documentation**

- `man printcap` — The manual page for the `/etc/printcap` printer configuration file.
- `man lpr` — The manual page for the `lpr` command that allows you to print files from the command line.
- `man lpd` — The manual page for the LPRng printer daemon.
• **man lprm** — The manual page for the command line utility to remove print jobs from the LPRng spool queue.

• **man mpage** — The manual page for the command line utility to print multiple pages on one sheet of paper.

• **man cupsd** — The manual page for the CUPS printer daemon.

• **man cupsd.conf** — The manual page for the CUPS printer daemon configuration file.

• **man classes.conf** — The manual page for the class configuration file for CUPS.

### 8.7.2. Useful Websites

• [http://www.linuxprinting.org](http://www.linuxprinting.org) — *GNU/Linux Printing* contains a large amount of information about printing in Linux.

• [http://www.cups.org/](http://www.cups.org/) — Documentation, FAQs, and newsgroups about CUPS.
Red Hat Linux includes several tools for managing all of your documents. Whether you are preparing for a business or school presentation, writing a formal letter, or opening a document from an email attachment, Red Hat Linux has a tool that suits your needs.

### 9.1. The OpenOffice.org Suite

*Productivity suites* are collections of applications designed to save time and assist users at work, at school, and at home. Usually, productivity suites are graphical and include such applications as word processors, spreadsheets, and presentation utilities. The applications that comprise a productivity suite are *integrated* — which means that you can, for example, write a document with an embedded chart created by the spreadsheet application as well as a slide from a graphical presentation application. Integration of the software that make up a productivity suite helps you to give impact to your presentations, lectures, or printed collateral.

Red Hat Linux includes a powerful business productivity suite called [OpenOffice.org](http://openoffice.org), which incorporates several complementary applications into one integrated package. Using [OpenOffice.org](http://openoffice.org) is much faster and easier than learning complex tags and code to format your documents and presentations. It allows you complete control over the layout and content of your documents and lets you see the results as you edit it. This real-time, visual form of document formatting is called *what you see is what you get* (or WYSIWYG) editing.

#### 9.1.1. OpenOffice.org Features

The [OpenOffice.org](http://openoffice.org) suite contains several applications for creating and editing documents, spreadsheets, business presentations, and artwork. It includes templates, forms, and wizards for creating basic professional documents and presentations quickly. If you have ever worked with or received `.doc` or `.xls` files, you know they are commonly associated with the Microsoft Office suite. The [OpenOffice.org](http://openoffice.org) suite is able to read, edit, and create files in several formats, including files which are commonly associated with Microsoft Office. Table 9-1 shows the many different types of files you can use and tasks you can accomplish with the [OpenOffice.org](http://openoffice.org) suite.

<table>
<thead>
<tr>
<th>Application</th>
<th>File Compatibility</th>
<th>Document Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenOffice.org Writer</td>
<td><code>.sxw</code>, <code>.sdw</code>, <code>.doc</code>, <code>.rtf</code>, <code>.txt</code>, <code>.htm</code>, <code>.html</code></td>
<td>Formal letters, business forms, school papers, resumes, newsletters, reports</td>
</tr>
<tr>
<td>OpenOffice.org Calc</td>
<td><code>.sxc</code>, <code>.dbf</code>, <code>.xls</code>, <code>.sdc</code>, <code>.slk</code>, <code>.csv</code>, <code>.htm</code>, <code>.html</code></td>
<td>Spreadsheets, charts, tables, graphs, personnel directories, address books, budgets, simple databases</td>
</tr>
<tr>
<td>OpenOffice.org Impress</td>
<td><code>.sxi</code>, <code>.ppt</code>, <code>.sxd</code>, <code>.add</code></td>
<td>Business and academic presentations, Web presentations, lectures, slide shows</td>
</tr>
<tr>
<td>OpenOffice.org Draw</td>
<td><code>[Image formats, including </code>.jpg<code>, </code>.bmp<code>, </code>.gif<code>, and </code>.png`]</td>
<td>Illustrations, line drawings, clip art, organizational charts</td>
</tr>
</tbody>
</table>

Table 9-1. OpenOffice.org Features

As you can see, the [OpenOffice.org](http://openoffice.org) suite has many file compatibility features, and allows you to...
accomplish several tasks for academic, business, or home use. The following sections shows you how to use the OpenOffice.org suite.

9.1.2. OpenOffice.org Writer

Writing documents using OpenOffice.org is similar to other word processing applications you may have used before. A word processor is like a text editor but has several additional features that allow you to format, design, and print your documents without the need to memorize complex formatting tags or codes. OpenOffice.org Writer is a powerful word processor that features WYSIWYG formatting — what you see in the OpenOffice.org Writer window is exactly what you get if you printed the document or if you gave the document file to someone else for them to view. Figure 9-1 shows OpenOffice.org Writer in action:

![Figure 9-1. OpenOffice.org Writer](image)

To start OpenOffice.org Writer from your desktop panel, choose Main Menu => Office => OpenOffice.org Writer; to start it from a shell prompt, type `oowriter`.

The main interface is the document editing area (the white space in the middle of the window) where you can add and edit text. At the top of the window are various functions collected into toolbars that let you choose your fonts, letter sizes, justification (aligning the text of your document to the left, center, or right margins), and more. There is also a text box that enables you to specify the exact location of a document on your machine and load the document into the editing area. There are also buttons for opening, saving, and printing documents, as well as buttons for creating new documents (which will open up a new window with a blank document for you to add content).

Along the left side of the window, there is a toolbar with buttons for checking your spelling, toggling the automatic highlighting of misspelled words, justification (aligning the text of your document to the left, center, or right margins), and more. There is also a text box that enables you to specify the exact location of a document on your machine and load the document into the editing area. There are also buttons for opening, saving, and printing documents, as well as buttons for creating new documents (which will open up a new window with a blank document for you to add content).

Along the left side of the window, there is a toolbar with buttons for checking your spelling, toggling the automatic highlighting of misspelled words, justification (aligning the text of your document to the left, center, or right margins), and more. There is also a text box that enables you to specify the exact location of a document on your machine and load the document into the editing area. There are also buttons for opening, saving, and printing documents, as well as buttons for creating new documents (which will open up a new window with a blank document for you to add content).

The main interface is the document editing area (the white space in the middle of the window) where you can add and edit text. At the top of the window are various functions collected into toolbars that let you choose your fonts, letter sizes, justification (aligning the text of your document to the left, center, or right margins), and more. There is also a text box that enables you to specify the exact location of a document on your machine and load the document into the editing area. There are also buttons for opening, saving, and printing documents, as well as buttons for creating new documents (which will open up a new window with a blank document for you to add content).

Along the left side of the window, there is a toolbar with buttons for checking your spelling, toggling the automatic highlighting of misspelled words, keyword and phrase searching, and other convenient editing functions. If you hover the mouse cursor over a toolbar button, a pop-up Tip is displayed with a brief explanation of the button’s functionality. You can display more detailed Tips by clicking the Help menu and choosing Extended Tips.

You can immediately begin typing text into the document editing area at any time using the default settings. To save your text, click the Save button , which opens the pop-up file browser. You can choose the file format from the File type drop down menu at the bottom of the browser window. The default file type is appropriate for files that you are working on exclusively with OpenOffice.org applications. However, for files that you need to distribute to Microsoft Office users, or if you are
editing a file that was sent as an email attachment with the .doc extension, you can save the file as a Microsoft Word file type that others will be able to open it in Microsoft Word.

While OpenOffice.org Writer is useful for general document editing, you can also add objects such as images, illustrations, charts, and tables to your document to complement your text or give impact to your documents. To add an image to the document, select Insert => Graphics => From File, and choose the image from the pop-up file browser. The image will appear where you placed your cursor and can be made larger or smaller by clicking on the resizing borders around the image. Figure 9-2 shows an image added to a document.

Figure 9-2. Adding an Image to Your Document

Once you have created your document, you can save it in any format that you wish. Consult Table 9-1 for available file formats. Note that you can also export your document to HTML or PDF format, formats which can be read by almost every computer with a Web browser (such as Mozilla) or PDF viewer application (such as xpdf or Adobe Acrobat Reader).

9.1.3. OpenOffice.org Calc

From large enterprises to home offices, professionals in every industry use spreadsheets for keeping records, creating business charts, and manipulating data. OpenOffice.org Calc is a software spreadsheet application that allows you to enter and manipulate data cells organized in columns and rows. A cell is a container for individual pieces of data, such as a quantity, label, or mathematical formula. You can perform calculations on groups of cells (such as adding or subtracting a column of cells) or create charts based on the quantities contained in a group of cells. You can even incorporate spreadsheet data into your documents for a professional touch.

To start OpenOffice.org Calc from the desktop panel, select Main Menu => Office => OpenOffice.org Calc. To start OpenOffice.org Calc from a shell prompt, type oocalc.

Figure 9-3 shows OpenOffice.org Calc in action.
OpenOffice.org Calc allows you to enter and manipulate personal or business data. For example, you can create a personal budget by entering data descriptions (such as rent, groceries, and utilities) into column A and the quantities of those data descriptions in column B. OpenOffice.org Calc allows you to enter the data either in the cell itself by double clicking the cell and typing your information or by using the Input Line (the text box on the toolbar). Then you can run a formula on column B to come up with a total. OpenOffice.org Calc has several preset functions and calculations (such as =SUM() for addition/multiplication, =quotient() for division, and =subtotal() for preparing receipts). For detailed information about creating functions for calculating your numerical data in OpenOffice.org Calc, refer to the documentation by selecting Help => Contents.

If you need to create charts or graphs for class or business presentations, OpenOffice.org has several chart and graph templates available. Highlight the areas you would like to chart, then click Insert => Chart.... In the Chart window, the data ranges you chose will be shown in the text box for you to customize further if desired. Click Next to display the many different charts and graphs you can create using your data. Choose the style you want, and click Create. The graph will be displayed anchored within the spreadsheet window. You can move it anywhere on the screen for printing, or you can save the graph as an object that you can then embed in OpenOffice.org Writer documents or OpenOffice.org Impress presentations.
Figure 9-4. Creating Charts with OpenOffice.org Calc

You can save spreadsheets created with OpenOffice.org Calc in several file formats, including the native \texttt{.sxc} as well as Microsoft Office compatible \texttt{.xls} formats. Additionally, you can export rendered charts and graphs to several image file formats and integrate them with document files, webpages, and presentations.

For more information about using OpenOffice.org Calc, refer to the help page located in Help $\Rightarrow$ Contents from the file menus.

9.1.4. OpenOffice.org Impress

Visual aids can give your presentations an added impact that catches your audience’s attention and keeps them interested. OpenOffice.org Impress is a graphical tool that can help you make a more convincing presentation.

To start OpenOffice.org Impress from the graphical desktop, select Main Menu $\Rightarrow$ Office $\Rightarrow$ OpenOffice.org Impress. To start OpenOffice.org Impress from a shell prompt, type \texttt{ooimpress}.

OpenOffice.org Impress features a step-by-step automated presentation wizard called AutoPilot that allows you to create presentations from a collection of default style templates. You can make slides with itemized lists, outlines, or images. You can even import charts and graphs created by OpenOffice.org Calc into a slide.

Figure 9-5 shows OpenOffice.org Impress in action.
When you first start **OpenOffice.org Impress**, you will be presented with the AutoPilot. You can choose the style of your slides, the medium with which you will present your slides (plain paper, transparent paper for overhead projectors, slides, or a display monitor), and any animated visual effects you want to apply to the slides if you run presentations from your computer.

Once you have chosen your preferences with AutoPilot tool, you can choose the type of slide you want to create. You can select a pre-formatted slide from the list or start with a blank slide and customize the layout yourself. To add new slides to your presentation, click **Insert Slide...** in the floating toolbar, and a pop-up window will appear allowing you to choose the layout of the new slide. You can have as many slides in your presentation as you need.

You can also preview your presentation at any point by selecting **Slide Show => Slide Show** from the file menus. The presentation will be presented in full screen, which you can exit by cycling through every slide until you reach the end or by pressing the [Esc] key at any point in the slide show.

Your presentation can be saved in several file formats. You can save in the native **OpenOffice.org Impress** format (for example, `mypresentation.sxi`), the Microsoft PowerPoint format (`mypresentation.ppt`), or StarImpress format (`mypresentation.sdd`). You can also print your presentation to plain or transparent paper formats by clicking **File => Print** from the file menu.
To learn more about **OpenOffice.org Impress**, click **Help => Contents** from the file menus.

### 9.1.5. OpenOffice.org Draw

If you want to create graphics for your documents and presentations, you can use **OpenOffice.org Draw**. Using your mouse as you would a pen or a paintbrush, **OpenOffice.org Draw** allows you to make illustrations and save them in several formats that you can add to printed documents, place on websites, or attach to emails.

To start **OpenOffice.org Draw** from the desktop panel, click **Main Menu => Office => OpenOffice.org Draw**. To start **OpenOffice.org Draw** from a shell prompt, type `oodraw`.

Figure 9-7 Shows **OpenOffice.org Draw** in action.

![Figure 9-7. OpenOffice.org Draw](image)

If you are familiar with illustration and graphics applications such as **The GIMP** (refer to Chapter 11 **Working with Images** for more information), you will find that **OpenOffice.org Draw** has some of the same basic functions. There are toolbars for creating straight and curved lines, basic shapes such as squares and circles, 3D objects such as cones and cubes, and more. You can create images and fill them with the color of your choice using the **Area Style/Filling** drop-down menu on the main toolbar. You can additionally insert text into your illustrations. **OpenOffice.org Draw** also allows you to open and import images and modify them with the tools provided.

When you complete your illustration or image modifications, you can save the file in one of several native file formats or export your work to several popular formats such as `.jpg` or `.png`. Refer to Table 9-1 for the complete list of compatible image file formats.

For more information on using **OpenOffice.org Draw**, refer to the documentation located at **Help => Contents** from the file menus.
9.2. Editing Text Files

Red Hat Linux includes several text editors, applications that allow you to view and modify plain text files. Plain text files are files that contain text without any font or style formatting applied to it, such as system logs and configuration files.

`gedit` is a graphical text editor. It can open, edit, and save plain text files. You can also cut and paste text to and from other graphical desktop applications, create new text files, and print files. `gedit` has a clear and understandable interface that uses tabs so that you can open more than one file at the same time without opening more than one `gedit` window.

To start `gedit`, click **Main Menu => Accessories => Text Editor**. You can also start `gedit` by typing `gedit` at a shell prompt.

**Note**
`gedit` can only be used in a graphical desktop environment.

![Figure 9-8. gedit](image)

Once `gedit` is running, you are presented with a blank editing area. You can begin using `gedit` immediately or click the **Open** button to locate the plain text file you want to edit. The file will load into the main editing area as shown in Figure 9-8. You can navigate the text file by clicking and holding the scroll bar on the right edge of the window and moving your mouse cursor up and down; or, use the arrow keys to navigate through the text file line-by-line. Press the [Page Up] and [Page Down] keys to advance the document a page at a time.

**Tip**
`gedit` allows you to open multiple text files in one window using separate tabs for each file. If you have a file already open and want to copy text from another file, click **Open**, choose the file you want
to access, and the file will open in a new tab within the gedit window. You can navigate between each file by clicking on the the tab associated with the particular filename.

Once you have modified or written your text file, you can save it by pressing the Save button in the toolbar, or by choosing File => Save from the file menus. If you are writing a new text file, a pop-up window will prompt you to name the file and save it in the directory of your choice. If you are editing an existing file, then any changes you make will automatically appear in the file the next time you open it. You can also choose File => Save As... to save an existing file under a new name or in a different location, which is convenient if, for example, you are editing a configuration file and you want to test your changes without losing your original configuration.

For more information about gedit, choose Help => Contents from the file menus to access the gedit manual.

9.2.1. Shell Prompt Text Editors

If you are not using a graphical desktop and want to read and modify a text or configuration file, Red Hat Linux includes the vi (pronounced vee-eye) text editor. vi is a simple application that opens within the shell prompt and allows you to view, search, and modify text files. To start vi, type vi at a shell prompt. To open a file with vi type vi <filename> at a shell prompt.

![Figure 9-9. vi](image)

By default, vi opens a file in Normal mode, meaning that you can view and run built-in commands on the file but you cannot add text to it. To add text, press [i] (for Insert mode), which will allow you to make any modifications you need to. To exit insert mode, press [Esc], and vi reverts to Normal mode.

To exit vi, press [:] (which is the vi command mode) and press [q] then [Enter]. If you have made changes to the text file that you want to save, press [:] and type [w] then [q] to write your changes to the file and exit the application. If you accidentally made changes to a file and you want to exit vi without saving the changes, type [:] and then type [q] followed by [!], which exits without saving changes.

More information about using vi can be found by typing man vi at a shell prompt.
9.3. Viewing PDFs

A PDF (Portable Document Format) file is an electronic image of a document. PDF captures formatting information from a variety of desktop publishing applications, making it possible to send formatted documents and have them appear on the recipient’s monitor or printer as they were intended. To view a PDF you must have a PDF reader.

An open source application called xpdf is included with Red Hat Linux. The xpdf toolbar at the bottom has navigational tools that let you move backward and forward through the PDF document, as well as standard zoom, print, and find tools. The xpdf man page provides useful information on the xpdf options. To view the xpdf man page, at a shell prompt type man xpdf.

To view a PDF with xpdf:

1. In your desktop environment, go to Main Menu => Graphics => PDF Viewer. You can also launch xpdf by typing xpdf at a shell prompt.
2. Right-click in the xpdf screen to display a list of options.
3. Select Open to display the file browser.
4. Select the PDF file you want to view and click Open.

Another popular PDF viewer is Adobe Acrobat Reader. While it is not included with Red Hat Linux, you can download it free of charge at http://www.adobe.com/.
Chapter 10.

Audio, Video, and General Amusement

This chapter presents you with the lighter side of Red Hat Linux. From games and toys to multimedia applications, Red Hat Linux provides many packages to assist you in having some fun with your computer.

10.1. Playing Audio CDs

To play an audio CD, place the CD in your CD-ROM drive. The CD Player application should appear automatically and begin playing the first audio track. If the interface does not appear, click Main Menu => Sound & Video => CD Player to launch the CD Player application.

![Figure 10-1. CD Player Interface](image)

The CD Player interface acts similar to a standard CD player, with play, pause, and stop functions. There is even a sliding bar that allows you to adjust the volume. Press the Next track and Previous Track buttons to skip forward or backward one track; you can also use the Track List drop down menu to select a track from the available listing.

You can edit the track listings for your CDs by clicking the Open track editor button. You can also change the way the application functions by clicking on the Open Preferences button. Here you can set themes for the player as well as set the behavior of the CD-ROM drive when you open or quit the CD Player application.

![Figure 10-2. CD Player Preferences](image)

10.2. Playing Digital Audio Files

Digital audio has become very popular in recent years. Users enjoy the technology because the sound quality is excellent compared to analog tape or records, and the files are compact (audio files can easily be transferred across the Internet).

To take advantage of this technology, Red Hat Linux includes the powerful X Multimedia System (XMMS), a cross-platform multimedia player which allows you to play several digital audio file formats.
74 Chapter 10. Audio, Video, and General Amusement

Figure 10-3. XMMS Interface

XMMS can be used for more than just playing digital audio files. By default XMMS can play Ogg Vorbis, RIFF wave, and most module formats. Additionally, XMMS can be extended via plugins to play a number of other digital multimedia formats.

To launch XMMS, go to Main Menu => Sound & Video => XMMS.

To launch XMMS from a shell prompt, type the command xmms.

10.2.1. Using XMMS

To play an audio file with XMMS, click the Open button and choose a file from the Load File(s) window.

In Figure 10-4, you see that there are several files to choose from. The files that end in .ogg are Ogg Vorbis files, a popular new audio file format; the .pls file is an audio playlist file. You can use XMMS to add audio files into a list and then save it as a playlist. This can be convenient if you have several audio files and you want to categorize them (for example, by genre or artist). Highlight the file you wish to play (if you have multiple files, click and hold the mouse button and drag it over all of the files you want to open) and click OK. Notice that XMMS begins to play your audio files immediately. To adjust the volume click the volume slider (the long slider above the Open button) to the left to lower the volume or to the right to increase it like a CD player. There are also buttons to stop, pause, and skip (backward and forward) your audio files.

To learn more about using XMMS and its many options, refer to the man page by typing man xmms at a shell prompt.

10.3. Troubleshooting Your Sound Card

If, for some reason, you do not hear sound and know that you do have a sound card installed, you can run the Sound Card Configuration Tool utility.
To use the **Sound Card Configuration Tool**, choose **Main Menu => System Settings => Soundcard Detection**. A small text box pops up prompting you for your root password.

![Figure 10-5. Sound Card Configuration Tool](image)

**Note**

Most sound cards are supported by Red Hat Linux, but there are some sound cards that are not completely compatible or may not work at all. If you are having trouble configuring your sound card, check the Hardware Compatibility List at [http://hardware.redhat.com/](http://hardware.redhat.com/) to see if your card is supported.

The **Sound Card Configuration Tool** utility probes your system for sound cards. If the utility detects a plug and play sound card, it will automatically try to configure the correct settings for your card. You can then click the **Play test sound** button to play a sound sample. If you can hear the sample, select **OK** and your sound card configuration is complete.

**10.3.1. If Sound Card Configuration Tool Does Not Work**

If the **Sound Card Configuration Tool** does not work (if the sample does not play and you still do not have audio sounds), there are alternatives, although they are not quite as simple as running the **Sound Card Configuration Tool**. You can edit your `modules.conf` file as discussed below (this strategy is not recommended for most new users) or refer to the documentation that came with your sound card for more information.

**10.3.1.1. Manual Sound Card Configuration**

If your sound card is not a plug and play card, you can manually edit your `/etc/modules.conf` file to include the sound card module that it should use. For example:

```bash
alias sound sb
alias midi opl3
options opl3 io=0x388
options sb io=0x220 irq=7 dma=0,1 mpu_io=0x300
```

For information on configuring sound manually, refer to the [Linux Sound HOWTO](http://www.tldp.org/HOWTO/Sound-HOWTO/) at the Linux Documentation Project webpage:

10.4. Troubleshooting Your Video Card

Video card configuration is handled during the Red Hat Linux installation (refer to the Red Hat Linux Installation Guide for more information). However, if you did not choose to configure a video card at that time, or if you need to reconfigure your settings, you can use the X Configuration Tool utility. You should do this, for example, if you install a new video card.

Note

The X Configuration Tool backs up your system's original video configuration file to /etc/X11/XF86Config.backup in case you need it to switch back to a previous configuration.

To run the X Configuration Tool, click Main Menu => System Settings => Display. A pop-up window prompts you for your root password. You can also start from a shell prompt by typing the command redhat-config-xfree86, which then prompts you to input your root password. If you are working from a shell prompt and X is not working, redhat-config-xfree86 attempts to start a minimal X session to allow you to continue your configuration. Follow the instructions that appear on the screen. X Configuration Tool attempts to automatically configure your video card and monitor settings for you. Figure 10-6 shows the Advanced tab for configuring your video device manually.

![Figure 10-6. X Configuration Tool](image)

To configure your monitor manually, click the Advanced tab, then click the Configure... button next to the Monitor Type entry. A pop-up window will display a list of monitor models. Choose your model and click OK. You can also let X Configuration Tool probe your monitor for the correct model and vertical/horizontal frequency settings.

To configure your video card manually, click the Advanced tab, then click the Configure... button next to the Video Card entry. A pop-up window will display a list of video card models. Choose your model and click OK. You can also let X Configuration Tool probe your video card for the correct model and settings by clicking the Probe Videocard button.

When you have finished reconfiguring your video card and monitor, you should be able to start an X session and enjoy your graphical desktop environment.

10.5. Games

Playing games under Red Hat Linux is a fun way to pass the time. The games included in Red Hat Linux appeal to quite a large number of video game enthusiasts. Whether you enjoy card games like
Aisle Riot (a solitaire card game), arcade games like Tux Racer, board games like Chess, or space shooting games like Chromium and Maelstrom, you can find it in Red Hat Linux.

To start a game, click Main Menu => Games and select the game of your choice. Figure 10-7 shows a fun game for kids of all ages called Same GNOME. In this game you point your mouse at matching marbles until they start to spin; then, you can click them to make them disappear. The object of the game is to make all the marbles disappear.

![Same GNOME Game](image)

**Figure 10-7. Same GNOME — Match the Marbles Game**

### 10.6. Finding Games Online

There are many more games available within Red Hat Linux and online. For more information, here are a few suggestions:

- http://happypenguin.org/ — the Linux gaming repository.

You can also browse the Internet for linux games using a search engine, such as http://www.google.com/.
Digital images have grown in popularity with the development of the graphical Internet and the increasing quality of digital cameras. There are several types of image files, some of which are created using sophisticated illustration software packages, while others are made from digital sources such as a scanner or camera. You may have downloaded some of these image files from the Web or received them in an email. You may also want to create your own images to send to others. You can view and modify the most common types of image files using the many applications included in Red Hat Linux.

11.1. Viewing Images

This section discusses some of the common tools for viewing image files. Certain tools included in Red Hat Linux are specialized applications with several functions that enhance your image viewing experience; while others are general-purpose file managers that have integrated image viewing functionality.

11.1.1. Using Nautilus to View Images

**Nautilus** is a general-purpose file manager and browser for your graphical desktop environment. **Nautilus** has many functions beyond simple image viewing; however, for this section, we will use it for basic image browsing. For more information about **Nautilus**, see Chapter 2 *Using the Graphical Desktop*.

**Nautilus** is known for its ease-of-use and it handles images with the same ease as it does for other file types. To begin browsing your image collection with **Nautilus**, double-click your home desktop icon:

You will be presented with a view of all files and folders within your home directory. Double-click the image (or the folder containing the image) and **Nautilus** will open the file or folder within its browser window. Figure 11-1 shows that **Nautilus** automatically creates thumbnails of any images in your folders:

![Figure 11-1. Contents of a Folder in Nautilus](image)
Double-click on any thumbnail icon to view the image in its native size. The image will load within the browser window. To increase or decrease the size of the viewed image in Nautilus, click on the zoom buttons next to the **Location:** field as shown in Figure 11-2:

![Figure 11-2. The Zoom Function in Nautilus](image)

Click the + button to increase the size of the image or - to decrease it.

### 11.1.2. Using gThumb

**gThumb** is a powerful image viewer for graphical desktop users that supports several image file formats, including:

- JPG/JPEG
- GIF
- PGM
- XPM
- PNG
- PCX
- TIF/TIFF
- PPM
- BMP

**gThumb** is useful for viewing individual image files as well as browsing collections of files in folders. It supports zoom in and zoom out functions, as well as thumbnail sized preview icons of all image files within a directory. It also supports several advanced options not found in Nautilus.

**gThumb** can be started from your desktop panel. Choose **Main Menu => Graphics => gThumb Image Viewer** or type `gthumb` at a shell prompt to start the application. **gThumb** will browse your user home directory by default. If you have any images in this directory, the gallery panel will automatically generate thumbnails for you to highlight and view in the main display area.
The interface of gThumb is straightforward. Double-click an image preview thumbnail to view it within the main gallery area. The image can be zoomed in and out, set to full screen (which covers your entire screen with the image), and be printed on your configured printer. The toolbar allows you to fit the image to the display window, collect multiple files into a catalog for easier access if they are located in different directories, and write descriptions about the images.

The gThumb interface also has a text field for you to enter a particular path to your image directories. Right-clicking on an image in the display area opens a pop-up menu of file management options such as renaming, moving, copying, and converting an image from one file format to another. You can also set an image as your desktop wallpaper within the pop-up menu.

You can combine functions within gThumb and create a dynamic presentation effect for groups of images within a directory. In the text field below the toolbar, type the path to the directory where your images are located and highlight the first image in the main gallery panel. Click the Slide Show button on the toolbar and you will start a full-screen slide show where gThumb displays images in full screen. By default, each image in the slide show is presented for 4 seconds. You can stop the slide show at any time by pressing [Esc] or by moving your mouse cursor and clicking the Restore Normal View pop-up button that appears on the top left corner of the screen.

11.1.2.1. Changing your Desktop Wallpaper with gThumb

To change your desktop wallpaper with gThumb, right-click on an image, choose Set Image as Wallpaper, and then choose the orientation of the image. You can center the image on the page, which sets the image at its native resolution on the desktop and fills the rest of the space with the default desktop color if the image is smaller than your desktop resolution. You can also tile the image, which fills your desktop with multiple instances of the image. You can also scale and stretch the image, which resizes the image from its native resolution to fit your screen size. To restore your desktop wallpaper to its default, right-click anywhere in the main gallery area and choose Set Image as Wallpaper => Restore.

11.1.2.2. Configuring gThumb

gThumb allows you to customize several settings by choosing Edit => Preferences.
The preferences pop-up menu lets advanced users change several of the default gThumb behaviors. You can choose the layout of the application window, customize a default image directory on startup, change thumbnail preview sizes, and change the interval between cycled images during a slide show.

![GThumb Preferences Dialog Box]

To find out more about using and configuring gThumb, choose Help => Contents from the main menu.

11.2. Manipulating Images with the GIMP

The GNU Image Manipulation Program (GIMP) is a powerful tool that can be used to create, alter, manipulate, and enhance digital image files — photographs, scanned images, computer-generated images, and more. This section offers a quick overview of the GIMP and refers you to comprehensive references for learning more about it.

11.2.1. GIMP Basics

To use the GIMP, you will need to know some of the basics. From a shell prompt, you start the GIMP using the command gimp, or you can start the GIMP from the desktop by choosing Main Menu => Graphics => The GIMP.

Figure 11-5 shows a typical GIMP session in action.
11.2.2. Loading a File

To load an existing file, select **File => Open**. You will see the **Load Image** dialog, as shown in Figure 11-6.
The **Load Image** dialog displays your working directory — the directory you were in when the **GIMP** was launched. You can navigate up and down the file system tree by double-clicking on the **Directories** list on the left, then selecting a file to open from the **Files** list on the right.

File name completion is supported by the **GIMP**. If you type the first letter (or more) of a file name into the **Selection** field and press the [Tab] key, the view will change to only those subdirectories and/or files beginning with that letter or letters.

The file you select appears in the **Selection** field near the bottom of the dialog. A thumbnail preview is displayed in the dialog; alternatively, a **Generate Preview** button is displayed. If you want to see a thumbnail of the image, click on the **Generate Preview** button.

Once you have selected a file, click on the **OK** button to open it. You can also double-click on a file name to open it.

### 11.2.3. Saving a File

To save an image file, right click on the image and choose **File** => **Save** (or **Save as**). You will see the **Save Image** dialog if you choose **Save as** or if you choose **Save** and the file has not been saved before.

The **Save Image** dialog looks almost exactly like the **Load Image** dialog and navigation of the file system tree and choosing files works in the same way.

When you are saving an image, you must choose an image format. The **GIMP** supports a wide variety of image formats, including .gif, .png, .jpg, and .bmp.

### 11.2.4. GIMP Options

Like many applications, the **GIMP** provides more than one method to accomplish tasks. The easiest way to work with images is to right-click the image, which displays a set of menus containing most of the **GIMP**’s many capabilities, including image sizing, rotation, and filter application.

For example, imagine you have a picture that you would like to modify to make it look as if it were clipped from a newspaper. To do this, right-click on the image and select **Filters** => **Distorts** => **Newsprint...**. Select the quantity of lines per inch using the sliders. When you reach a desired quantity and are ready to render the image, click **OK**. The **GIMP** then renders the image with the new effect applied. Figure 11-7 shows an example of an image after the **Newsprint** filter has been applied:

![Figure 11-7. An Image modified with a GIMP Filter](image)

The **Toolbox** also has several easily accessible functions. Using the **Toolbox**, you can add text to images, erase regions of an image, or even fill selected regions with the color of your choice.
For example, if you wish to add text to a file, select the \textbf{button} and click on your image. This loads the \textbf{Text Tool} dialog box, where you can choose a font and type some text in the provided text box. Click \textbf{OK} and your text is displayed as a floating section on the image. You can then move the text to the position you wish using the \textbf{Move Layers} tool. Figure 11-8 shows our photo with exciting new text:

\begin{figure}[h]
\centering
\includegraphics[width=0.5\textwidth]{pirates.png}
\caption{Using the Text Tool on an Image}
\end{figure}

As you can see, the \textbf{GIMP} is a powerful image editing tool, and it takes some time to master all of its functions. Try exploring some of the options yourself. If you make a mistake, do not worry. You can always undo your mistakes by right-clicking on the image and choosing \textbf{Edit} $\Rightarrow$ \textbf{Undo}.

\section*{11.3. Additional Resources}

While this chapter covers several applications briefly, there is so much more you can do with them. Refer to the following resources if you are interested in learning more about the applications in this chapter.

\subsection*{11.3.1. Installed Documentation}

Some applications discussed have online documentation included with the package, accessible right from your PC.

- For more information about using \textbf{gThumb}, refer to the documentation in \textbf{Help} $\Rightarrow$ \textbf{Contents} in the \textbf{gThumb} main menu.

- The \textbf{GIMP} manual page contains some of the more advanced command line options and environment variables associated with it. You can read the manual page by typing \texttt{man gimp} at a shell or terminal prompt. The \textbf{GIMP} also has a help browser accessible by choosing \textbf{Help} $\Rightarrow$ \textbf{Help...} from the \textbf{GIMP} toolbar menu.

\subsection*{11.3.2. Useful Websites}

The Web has several sites of interest if you are looking for more detailed information about an application covered in this chapter:

- \url{http://gthumb.sourceforge.net} — The official \textbf{GThumb} home page.
86 Chapter 11. Working with Images

- http://www.rru.com/~meo/gimp/faq-user.html — A Frequently Asked Questions (FAQ) list for questions commonly asked about the GIMP by GIMP users (as opposed to developers).

11.3.3. Related Books

If you need in-depth information about the many capabilities of the GIMP, try your favorite bookstore. The following books were available at the time of this writing:

- The Artists’ Guide to the GIMP by Michael J. Hammel; Frank Kasper and Associates, Inc.
- GIMP Essential Reference by Alex Harford; New Riders Publishing
- GIMP for Linux Bible by Stephanie Cottrell Bryant, et al; Hungry Minds, Inc.
- GIMP: The Official Handbook by Karin Kylander and Olof S. Kylander; Coriolis Group
- Grokking the GIMP by Carey Bunks; New Riders Publishing
- Sams Teach Yourself GIMP in 24 Hours by Joshua and Ramona Pruitt; Sams
Digital cameras have recently grown in popularity because of their increasing image quality and easy interaction with desktop PCs. Digital cameras create high-quality images that allow you to send to others over the Internet or print on a color printer. Red Hat Linux supports several brands of digital cameras and has applications that help you access, view, and modify your digital photographs.

12.1. Using gtKam

Red Hat Linux supports over 100 digital camera models. So, whether your camera uses USB or serial ports to communicate with your computer, it is likely that Red Hat Linux will support it.

gtKam is a graphical application that allows you to interface with your digital camera. gtKam works directly with your digital camera, allowing you to open, view, save, and delete images directly. You can also download the images to your computer and modify it with image manipulation programs such as The GIMP (refer to Chapter 11 Working with Images for more information about image manipulation tools).

To start gtKam, choose Main Menu => Graphics => Digital Camera Tool. You can also start gtKam by typing gtkam at a shell prompt.

Before you begin using gtKam, you need to configure it to work with your digital camera. From the menu, choose Camera => Add Camera... From the pop-up dialog, you can choose your camera from the drop-down list or let gtKam automatically find your camera by clicking Detect. Click Apply to accept the changes and OK to close the dialog box.

Figure 12-1. Adding a Camera in gtKam

Once you have added your camera, it will be shown as an icon on the left panel of the main gtKam window. You only have to configure gtKam for your camera once; the settings will be saved with each additional use.

Directories shown below the icon may differ depending on your brand of camera. Select the directory that commonly stores your images and the stored images will immediately load as thumbnail images in the main panel. From this panel, click on the images you want, which you can then save to disk by choosing File => Save Selected Photos. If you want to save all of the stored images, choose Select => All, then save the images to disk.
Figure 12-2. Viewing Images with gtKam

For more information about using gtKam, refer to the gtKam page at the gPhoto website:
http://gphoto.sourceforge.net/proj/gtkam/
13.1. Why Use a Shell Prompt

Graphical environments for Linux have come a long way in the past few years. You can be perfectly productive in the X Window System and only have to open a shell prompt to complete a few tasks. However, many Red Hat Linux functions can be completed faster from the shell prompt than from a graphical user interface (GUI). In less time than it might take to open a file manager, locate a directory, and then create, delete, or modify files from a GUI, a task can be finished with just a few commands at a shell prompt.

A shell prompt looks similar to other command-line interfaces with which you might be familiar. Users type commands at a shell prompt, the shell interprets these commands, and then the shell tells the OS what to do. Experienced users can write shell scripts to expand their capabilities even further.

Figure 13-1. A Shell Prompt

This section explains how to navigate the file system, manipulate files, perform simple administration tasks, and other shell prompt basics.

13.2. The History of the Shell

When AT&T software engineers Dennis Ritchie and Ken Thompson were designing UNIX™, they wanted to create a way for people to interact with their new system.

Operating systems at that time came with command interpreters, which could take commands from the user and interpret them so that computers could use them.

But Ritchie and Thompson wanted something more, something that offered better features than the command interpreters available at that time. This lead to the development of the Bourne shell (known as `sh`), created by S.R. Bourne. Since the creation of the Bourne shell, other shells have been developed, such as the C shell (`csh`) and the Korn shell (`ksh`).
When the Free Software Foundation sought a royalty-free shell, developers began to work on the language behind the Bourne shell as well as some of the popular features from other shells available at the time.

The result was the Bourne Again Shell, or bash. Although your Red Hat Linux system includes several different shells, bash is the default shell for interactive users. You can learn more about bash by reading the bash man page (type man bash at a shell prompt).

13.3. Determining Your Current Directory with **pwd**

Once you start looking through directories, it is easy to get lost or forget the name of your current directory. By default, the Bash prompt in Red Hat Linux shows just your current directory, not the entire path.

![Figure 13-2. The Command pwd Shows You Where You Are](image)

To determine the exact location of the current directory at a shell prompt and type the command **pwd**. You will see something such as:

```
/home/sam
```

This example shows that you are in the user sam’s directory, which is in the /home directory.

The command **pwd** stands for print working directory. When you typed **pwd**, you asked your Linux system to display your current location. Your system responded by printing the full path of the current directory in the shell prompt window. When the system responds to requests for information, the response is called **standard output**, and can be printed to the shell prompt or can be redirected to other programs or to other output devices such as printers.

You will find that using **pwd** is very helpful as you learn to navigate your Red Hat Linux system.

13.4. Changing Directories with **cd**

Changing directories is easy as long as you know where you are (your current directory) and how that relates to where you want to go.

To change directories, use the **cd** command. Typing this command by itself will always return you to your home directory; moving to any other directory requires a **pathname**.
You can use absolute or relative pathnames. Absolute paths start at the top of the file system with / (referred to as root) and then look down for the requested directory; relative paths look down from your current directory, wherever that may be. The following directory tree illustrates how cd operates.

```
/
directory1
directory1/directory2
directory1/directory2/directory3
```

If you are currently in directory3 and you want to switch to directory1, you need to move up in the directory tree.

Executing the command

```
cd directory1
```

while you are in directory3, will present you with an error message explaining that there is no such directory. This is because there is no directory1 below directory3.

To move up to directory1, type:

```
cd /directory1
```

This is an example of an absolute path. It tells Linux to start at the top of the directory tree (/) and change to directory1. A path is absolute if the first character is a /. Otherwise, it is a relative path.

Using absolute paths allows you to change to a directory from the / directory, which requires you to know and type the complete path. Using relative paths allows you to change to a directory relative to the directory you are currently in, which can be convenient if you are changing to a subdirectory within your current directory.

The command cd .. tells your system to go up to the directory immediately above the one in which you are currently working. To go up two directories, use the cd ../.. command.

Use the following exercise to test what you have learned so far regarding absolute and relative paths. From your home directory, type the relative path:

```
cd ../../etc/X11
```

After using the full command in the example, you should be in the directory X11, which is where you will find configuration files and directories related to the X Window System.

Take a look at your last cd command. You told your system to:

1. Go up one level to your login directory’s parent directory (probably /home)
2. Then go up to that directory’s parent (which is the root, or /, directory)
3. Then go down to the etc directory
4. Finally, go to the X11 directory

Conversely, using an absolute path would get you to the /etc/X11 directory more quickly. For example:

```
cd /etc/X11
```

Absolute paths start from the root directory (/) and move down to the directory you specify.
Always make sure you know which working directory you are in before you state the relative path to the directory or file you want to get to. You do not have to worry about your position in the file system, though, when you state the absolute path to another directory or file. If you are not sure, type `pwd` and your current working directory will be displayed, which can be your guide for moving up and down directories using relative pathnames.

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>cd</code></td>
<td>returns you to your login directory</td>
</tr>
<tr>
<td><code>cd ~</code></td>
<td>also returns you to your login directory</td>
</tr>
<tr>
<td><code>cd /</code></td>
<td>takes you to the entire system’s root directory</td>
</tr>
<tr>
<td><code>cd /root</code></td>
<td>takes you to the home directory of the root, or superuser, account created at installation; you must be the root user to access this directory</td>
</tr>
<tr>
<td><code>cd /home</code></td>
<td>takes you to the home directory, where user login directories are usually stored</td>
</tr>
<tr>
<td><code>cd ..</code></td>
<td>moves you up one directory</td>
</tr>
<tr>
<td><code>cd ~otheruser</code></td>
<td>takes you to otheruser’s login directory, if otheruser has granted you permission</td>
</tr>
<tr>
<td><code>cd /dir1/subdirfoo</code></td>
<td>regardless of which directory you are in, this absolute path would take you straight to subdirfoo, a subdirectory of dir1</td>
</tr>
<tr>
<td><code>cd ..../dir3/dir2</code></td>
<td>this relative path would take you up two directories, then to dir3, then to the dir2 directory.</td>
</tr>
</tbody>
</table>

Table 13-1. `cd` Options

Now that you are starting to understand how to change directories, see what happens when you change to root’s login directory (the superuser account). Type:

```
cd /root
```

If you are not logged in as root, you are denied permission to access that directory.

Denying access to the root and other users’ accounts (or login directories) is one way your Linux system prevents accidental or malicious tampering. See Section 13.14 Ownership and Permissions.

To change to the root login and root directory, use the `su` command.

```
su
```

Tip

The command `su` means substitute users and it allows you to log in as another user temporarily. When you type `su` by itself and press [Enter], you become root (also called the superuser) while still inside your login shell (your user’s home directory). Typing `su -` makes you become root with root’s login shell; it is as if you had logged in as root originally.
As soon as you give the root password, you will see the changes in your command prompt to show your new, superuser status, the root account designation at the front of the prompt and "#" at the end. When you are done working as root, type `exit` at the prompt, and you will return to your user account.

13.5. View Directory Contents with `ls`

Now that you know how to change directories, it is time to learn how to view the contents of these directories. Using the `ls` command, you can display the contents of your current directory.

Many options are available with the `ls` command. The `ls` command, by itself, does not show all the files in the directory. Some files are hidden files (also called dot files) and can only be seen with an additional option specified to the `ls` command.

Tip

To see all the options of the `ls` command, you can read the man page by typing `man ls` at a shell prompt. If you want to print the man page, at the prompt type `man ls | col -b | lpr`.

Type the command `ls -a`. Now you will see files that begin with dots.

![ls with the -a Option](image)

Hidden files are mostly configuration files which set preferences in programs, window managers, shells, and more. The reason they are hidden is to help prevent any accidental tampering by the user. When you are searching for something in a directory, you are not usually looking for these configuration files, so keep them hidden to help avoid some screen clutter when viewing directories at the shell prompt.

Viewing all the files using the `ls -a` command can give you plenty of detail, but you can view still more information, by adding more than one option.

If you want to see the size of a file or directory, when it was created and more, just add the `long` option (`-l`) to the `ls -a` command. This command shows the file creation date, its size, ownership, permissions, and more.
You do not have to be in the directory whose contents you want to view to use the `ls` command. For example, to see what is in the `/etc/` directory from your home directory, type:

```
ls -al /etc
```

Figure 13-4. Sample `ls` Output for the `/etc` Directory

The following is a short list of some options commonly used with `ls`. Remember, you can view the full list by reading the `ls` man page (`man ls`).

- `-a` — all. Lists all the files in the directory, including the hidden files (`.` filename). The `..` and `.` at the top of your list refer to the parent directory and the current directory, respectively.
- `-l` — long. Lists details about contents, including permissions (modes), owner, group, size, creation date, whether the file is a link to somewhere else on the system and where its link points.
- `-F` — file type. Adds a symbol to the end of each listing. These symbols include `/` to indicate a directory; `@` to indicate a symbolic link to another file; and `*` to indicate an executable file.
- `-r` — reverse. Lists the contents of the directory from back to front.
- `-R` — recursive. This option lists the contents of all directories below the current directory recursively.
- `-S` — size. Sorts files by their sizes.

### 13.6. Locating Files and Directories

There will be times when you know a file or directory exists but you will not know where to find it. Search for a file or directory with the `locate` command.

With `locate`, you will see every file or directory whose name contains the search criterion. For example, if you want to search for all files with the word `finger` in the name, type:

```
locate finger
```

The `locate` command uses a database to locate files and directories that have the word `finger` in the file or directory name. The search results could include a file called `finger.txt`, a file called `point-efinger.txt`, a directory named `fingerthumbnails`, and so on. To learn more about `locate`, read the `locate` man page (type `man locate` at a shell prompt).
The `locate` command works very quickly, as long as the database is up to date. That database is automatically updated on a nightly basis through a `cron` job. `cron` is a small program that runs in the background, performing various tasks (such as updating the `locate` database) at regularly scheduled intervals.

**Tip**
Cron is a daemon that executes tasks at regularly scheduled intervals. To read the `cron` man page, type `man cron` at the shell prompt. Refer to the Red Hat Linux Customization Guide for more information on `cron`.

The `cron` task periodically updates the `slocate` database, which is used to catalog file locations. Switching between operating systems and shutting down your machine at the end of the day can interfere with the automatic database update run by `cron`.

To update the database manually, log in as root (type `su` at a shell prompt and then your root password) and type the command `updatedb`.

After a few minutes, the `slocate` database that is used by the `locate` command will be current.

**Note**
You can run `anacron` to have your system execute commands periodically, with a frequency specified in days. Unlike `cron`, it does not assume that the machine is running continuously. Hence, it can be used on machines that are not running 24 hours a day, to control daily, weekly, and monthly jobs that are usually controlled by `cron`.

Refer to the man page on `anacron` (type `man anacron` at the command line) and the Red Hat Linux Customization Guide for more information.

### 13.7. Printing From The Command Line

Printing is not an involved process whether you click on a button in a GUI or type commands from the command line. This section explains how to print, cancel, and view print jobs from the command line, assuming you have a properly configured printer connected to your system. Refer to Chapter 8 Printer Configuration for more information about setting up your printer.

The `lpr` command, followed by a filename, sends that specified file to the print queue. For example, `lpr foo.txt` prints the `foo.txt` file.

To view the jobs waiting in the print queue, type `lpq` at the command line. Type `lpq`, and you will see information similar to this:

```
active root 389  foo.txt
```

In this example, 389 is the job number.

You can cancel jobs in the queue by typing `lprm` followed by the print job number displayed when you use the `lpq` command. To cancel the `foo.txt` print job, type `lprm 389` and press [Enter].
13.8. Clearing and Resetting the Terminal

After even one `ls` command in a shell prompt, the terminal window you are working in can begin to look crowded. You can always exit from the terminal window and open a new one, but there is a quicker and easier way to clear the contents displayed in the terminal.

Try typing the command `clear` at the shell prompt. The `clear` command does just what it implies: it clears the terminal window.

Sometimes, you may accidentally open a program file or some other non-text file in a terminal window. Once you close the file, you could find that the text you are typing does not match the output on the monitor.

In such cases, type `reset` to return the terminal window to its default values.

13.9. Manipulating Files with `cat`

Red Hat Linux has a utility which can help you keep short lists, gather lists together, and even show you information about your system.

The utility is called `cat`, short for `concatenate`, which means to combine files.

The command `cat` will also display the contents of an entire file on the screen (for example, type `cat filename.txt`). If the file is fairly long, it will quickly scroll past you on the screen. To prevent this, use the `cat filename.txt | less` command.

Using the pipe (|) and the `less` command together displays the file one page at a time. You can then use the up and down arrow keys to move backward and forward through the pages. For more on using pipes to combine two separate functions, see Section 13.10 Pipes and Pagers.

13.9.1. Using Redirection

Redirection means causing the shell to change what it considers to be standard input or where the standard output should be going.

To redirect standard output, use the `>` symbol. Placing `>` after the `cat` command (or after any utility or application that writes to standard output) directs its output to the filename following the symbol.

For example, using `cat` by itself outputs whatever you input to the screen as if it were repeating the line you just typed. The following example shows `cat` repeating every line that is entered:

![Figure 13-5. The cat Command](image)

To redirect the output of `cat` to a file, type the following at a shell prompt (pressing the [Enter] key takes you to the next blank line):
Chapter 13. Shell Prompt Basics

```
cat > sneakers.txt
```

![Figure 13-6. Redirecting Output to a File](image)

Press [Enter] to go to an empty line and use the [Ctrl]-[D] keys to quit `cat`.

Do you notice anything different in Figure 13-6? There are no repeated entries. That is because the standard output from `cat` was redirected. That redirection was to a brand new file you made called `sneakers.txt`.

You can find the file in the directory you were in when you started `cat` (type `ls` if you want to see it listed).

As you learned earlier, you can then use `cat` to read the file. At the prompt, type:

```
cat sneakers.txt
```

⚠️ **Caution**

Be careful when you redirect the output to a file, because you can easily overwrite an existing file! Make sure the name of the file you are creating does not match the name of a pre-existing file, unless you want to replace it.

Use output redirection again for another file and call it `home.txt`. For this example, type the command `cat > home.txt`, then [Enter], followed by:

```
bring the coffee home
take off shoes
put on sneakers
make some coffee
relax!
```

Now, on an empty line, use the [Ctrl]-[D] key combination again to quit `cat`.

Next, use `cat` to join `home.txt` with `sneakers.txt` and redirect the output of both files to a brand new file called `saturday.txt` (you will find an example in Figure 13-7). Type the following:

```
cat sneakers.txt home.txt > saturday.txt
```
You can see that `cat` has added `home.txt` where `sneakers.txt` ended.

### 13.9.2. Appending Standard Output

You can use output redirection to add new information to the end of an existing file. Similar to when you used the `>` symbol, you tell your shell to send the information somewhere other than standard output.

However, when you use `>>`, you are adding information to a file, rather than replacing the contents of a file entirely.

The best explanation is a demonstration. Take two files which have already been created (`sneakers.txt` and `home.txt`) and join them by using the append output symbol. You want to add the information in `home.txt` to the information already in `sneakers.txt`, so type:

```
cat home.txt >> sneakers.txt
```

Now check the file using the command `cat sneakers.txt`. The final output shows the contents of `home.txt` at the end of the file:

```
buy some sneakers
then go to the coffee shop
then buy some coffee
bring the coffee home
take off shoes
put on sneakers
make some coffee
relax!
```

The command you typed appended the output from the file `home.txt` to the file `sneakers.txt`.

By appending the output, you save yourself time (and a bit of disk clutter) by using existing files, rather than creating a new file.

Compare the results of the files `sneakers.txt` and `saturday.txt` now, and you will see that they are identical. To make your comparison, type:

```
cat sneakers.txt; cat saturday.txt
```

The contents of both files will be displayed — first `sneakers.txt`, then `saturday.txt` (as shown in Figure 13-8).
13.9.3. Redirecting Standard Input

Not only can you redirect standard output, you can perform the same type of redirection with standard input.

When you use the redirect standard input symbol `<`, you are telling the shell that you want a file to be read as input for a command.

Use a file you have already created to demonstrate this idea. Type:

```
cat < sneakers.txt
```

Because you used the less-than symbol (`<`) to separate the `cat` command from the file, the output of `sneakers.txt` was read by `cat`.
13.10. Pipes and Pagers

In Linux, pipes connect the standard output of one command to the standard input of another command.

Consider the `ls` command that was discussed earlier. There are plenty of options available with `ls`, but what if the contents of a directory scroll by too quickly for you to view them?

View the contents of the `/etc/` directory with the command:

```
ls -al /etc
```

How do you get a closer look at the output before it moves off the screen?

One way is to pipe the output to a utility called `less`, a pager utility that allows you to view information one page (or screen) at a time.

Use the vertical bar (`|`) to pipe the commands.

```
ls -al /etc | less
```

Now you can view the contents of `/etc` one screen at a time. To move forward a screen, press [Space]; to move back a screen, press [B]; to quit, press [Q]. Alternatively, you can use the arrow keys to navigate with `less`.

To search the output of a text file using `less`, press [/] and then type the keyword you want to search for within the file. For example:

```
/Linux
```

![Tip]

To read startup messages more closely, at a shell prompt, type `dmesg | less`. You will be able to read the file one screen at a time. Use the arrow keys to navigate the file; to search for output, press [/] and type the search term.

Pipes can also be used to print only certain lines from a file. Type:

```
grep coffee sneakers.txt | lpr
```

This command prints every line in the `sneakers.txt` file that mentions the word "coffee" (read more about `grep` in Section 13.11.3 *The grep Command*).

13.10.1. The `more` Command

The main difference between `more` and `less` is that `less` allows backward and forward movement using the arrow keys, while `more` uses the [Spacebar] and the [B] key for forward and backward navigation.

List the contents of the `/etc` directory using `ls` and `more`.

```
ls -al /etc | more
```
Figure 13-10. Piping Output of `ls` to `more`

To search the output of a text file using `more`, press [/] and then type the keyword you want to search for within the file. For example:

```
/foo
```

Use the [Spacebar] to move forward through the pages. Press [q] to exit.

### 13.11. More Commands for Reading Text Files

You have already been introduced to several basic shell prompt commands for reading files in text editors. Here are a few more.

#### 13.11.1. The `head` Command

You can use the `head` command to look at the beginning of a file. The command is:

```
head <filename>
```

`head` can be a useful command, but because it is limited to the first several lines, you will not see how long the file actually is. By default, you can only read the first ten lines of a file. You can change the number of lines displayed by specifying a number option as shown in the following command:

```
head -20 <filename>
```

#### 13.11.2. The `tail` Command

The reverse of `head` is `tail`. Using `tail`, you can view the last ten lines of a file. This can be useful for viewing the last 10 lines of a log file for important system messages. You can also use `tail` to watch log files as they are updated. Using the `-f` option, `tail` automatically print new messages from an open file to the screen in real-time. For example, to actively watch `/var/log/messages`, type the following at a shell prompt as the root user:

```
tail -f /var/log/messages
```
13.11.3. The grep Command

The *grep* command is useful for finding specific character strings in a file. For example, if you want to find every reference made to "coffee" in the file *sneakers.txt*, you would type:

```
grep coffee sneakers.txt
```

You would see every line in that file where the word "coffee" is found.

Tip

Unless otherwise specified, *grep* searches are *case sensitive*. That means that searching for *Coffee* is different than searching for *coffee*. Among *grep*’s options is `-i`, which allows for a case-insensitive search through a file. Read the *grep* man page for more about this command.

13.11.4. I/O Redirection and Pipes

You can use pipes and output redirection when you want to store and/or print information to read at a later time.

You can, for example, use *grep* to search for particular contents of a file, then have those results either saved as a file or sent to a printer.

To print the information about references to "coffee" in *sneakers.txt*, for example, just type:

```
grep coffee sneakers.txt | lpr
```

13.11.5. Wildcards and Regular Expressions

What if you forget the name of the file you are looking for? Using wildcards or regular expressions, you can perform actions on a file or files without knowing the complete filename. Just fill out what you know, then substitute the remainder with a *wildcard*. Wildcards are special symbols that you can substitute for letters, numbers, and symbols that make finding particular directories and files easier than examining long directory listings to find what you are searching for.

Tip

To read more about wildcards and regular expressions, take a look at the *bash* man page (*man bash*). Remember that you can save the file to a text file by typing `man bash | col -b > bash.txt`. Then, you can open and read the file with `less` or `vi` (`vi bash.txt`). If you want to print the file, be aware that it is quite long.

We know the file is called "sneak____.txt," so type:

```
ls sneak*.txt
```

and there is the name of the file:

```
sneakers.txt
```
Chapter 13. Shell Prompt Basics

You will probably use the asterisk (*) most frequently when you are searching. The asterisk will search out everything that matches the pattern you are looking for. So even by typing:

```
ls *.txt
```
or:

```
ls sn*
```

You would find sneakers.txt and any other files whose name ends with .txt or begin with sn. It helps to narrow your search as much as possible.

One way to narrow a search is to use the question mark symbol (?). Like the asterisk, using ? can help locate a file matching a search pattern.

In this case, though, ? is useful for matching a single character, so if you were searching for sneaker?.txt, you would get sneakers.txt as a result, and/or sneakerz.txt, if there were such a filename.

Regular expressions are more complex than the straightforward asterisk or question mark.

When an asterisk, for example, just happens to be part of a filename, as might be the case if the file sneakers.txt was called sneak*.txt, that is when regular expressions can be useful.

Using the backslash (\), you can specify that you do not want to search out everything by using the asterisk, but you are instead looking for a file with an asterisk in the name.

If the file is called sneak*.txt, type:

```
sneak\*.txt
```

Here is a brief list of wildcards and regular expressions:

- * — Matches all characters
- ? — Matches one character in a string
- \* — Matches the * character
- \? — Matches the ? character
- \) — Matches the ) character

13.12. Command History and Tab Completion

It does not take long before the thought of typing the same command over and over becomes unappealing. One minor typing error can ruin lines of a series of commands.

One solution is to use the command line history. By scrolling with the [Up Arrow] and [Down Arrow] keys, you can find plenty of your previously typed commands.

Try it by taking a look again at sneakers.txt (created in Section 13.9.1 Using Redirection. The first time, however, at the shell prompt, type:

```
cat sneakrs.txt
```

Nothing happens, of course, because there is no sneakrs.txt file. No problem. Use the up-arrow key to bring back the command, then use the left-arrow key to get to the point where we missed the "e." Insert the letter and press [Enter] again.

We now see the contents of sneakers.txt.
By default, up to 500 commands can be stored in the bash command line history file.

**Tip**

By typing the `env` command at a shell prompt, we can see the environment variable that controls the size of the command line history. The line which reads, `HISTFILESIZE=500` shows the number of commands that bash will store.

The command line history is actually kept in a file, called `.bash_history` in your login directory. We can read it in a number of ways: by using `vi`, `cat`, `less`, `more`, and others.

Be aware that the file can be long. To read it with the `more` command, from your home directory type:

```
more .bash_history
```

To move forward a screen, press [Space]; to move back a screen, press [b]; to quit, press [q].

**Tip**

To find a command in your history file without having to keep hitting the arrow keys or page through the history file, use `grep`, a powerful search utility (see Section 13.11.3 The grep Command). Here is how you can quickly find a previously used command: say you are searching for a command that is similar to `cat sneak-something`. You have used the command, and you think it might be in your history file. At the shell prompt, type:

```
history | grep sneak
```

Another time-saving tool is known as command completion. If you type part of a file, command, or pathname and then press the [Tab] key, bash will present you with either the remaining portion of the file/path, or a beep (if sound is enabled on your system). If you get a beep, just press [Tab] again to obtain a list of the files/paths that match what has been typed so far.

For example, if you forget the command `updatedb`, but remember a portion of the command, you can `su` to root, then at the shell prompt, type `up`, press the [Tab] key twice and you will see a list of possible completions, including `updatedb` and `uptime`. By typing the partial command `upd` and pressing [Tab] again, your command is completed for you.

### 13.13. Using Multiple Commands

Linux allows you to enter multiple commands at one time. The only requirement is that you separate the commands with a semicolon.

Suppose you have downloaded a new file called `foobar-1.3-2.i386.rpm`, and you want to put it in a new subdirectory within your home directory called `rpms/`, but the subdirectory has not been created. You can combine both the creation of the `rpms/` directory and the moving of your downloaded file into the directory by typing the following at a shell prompt:

```
mkdir rpms/; mv foobar-1.3-2.i386.rpm rpms/
```

Running the combination of commands creates the directory and moves the file in one line.
13.14. Ownership and Permissions

Earlier in this chapter, when you tried to change to root’s login directory, you received the following message:

cd /root
bash: /root: Permission denied

That was one demonstration of Linux’s security features. Linux, like UNIX, is a multi-user system, and file permissions are one way the system protects against malicious tampering.

One way to gain entry when you are denied permission is to su to root, as you learned earlier. This is because whoever knows the root password has complete access.

But switching to the superuser is not always convenient or recommended, since it is easy to make mistakes and alter important configuration files as the superuser.

All files and directories are "owned" by the person who created them. You created the file sneakers.txt (see Section 13.9.1 Using Redirection) in your login directory, so sneakers.txt belongs to you.

That means you can specify who is allowed to read the file, write to the file, or (if it is an application instead of a text file) who can execute the file.

Reading, writing, and executing are the three main settings in permissions. Since users are placed into a group when their accounts are created, you can also specify whether certain groups can read, write to, or execute a file.

Take a closer look at sneakers.txt with the ls command using the -l option (see Figure 13-11).

There is a lot of detail provided here. You can see who can read (r) and write to (w) the file, as well as who created the file (sam), and to which group the owner belongs (sam). Remember that, by default, the name of your group is the same as your login name.

Figure 13-11. Permissions for sneakers.txt

Other information to the right of the group includes file size, date and time of file creation, and file name.

The first column shows current permissions; it has ten slots. The first slot represents the type of file. The remaining nine slots are actually three sets of permissions for three different categories of users.

For example:
Those three sets are the owner of the file, the group in which the file belongs, and "others," meaning other users on the system.

- (rw-) (rw-) (r--) 1 sam sam
| | | |
| | | |
type owner group others

The first item, which specifies the file type, can show one of the following:

- d — a directory
- -(dash) — a regular file (rather than directory or link)
- l — a symbolic link to another program or file elsewhere on the system

Beyond the first item, in each of the following three sets, you will see one of the following:

- r — file can be read
- w — file can be written to
- x — file can be executed (if it is a program)

When you see a dash in owner, group, or others, it means that particular permission has not been granted. Look again at the first column of sneakers.txt and identify its permissions.

ls -l sneakers.txt
-rw-rw-r-- 1 sam sam 150 Mar 19 08:08 sneakers.txt

The file’s owner (in this case, sam) has permission to read and write to the file. The group, sam, has permission to read and write to sneakers.txt, as well. It is not a program, so neither the owner or the group has permission to execute it.

13.14.1. The chmod Command

Use the chmod command to change permissions. This example shows how to change the permissions on sneakers.txt with the chmod command.

The original file looks like this, with its initial permissions settings:

-rw-rw-r-- 1 sam sam 150 Mar 19 08:08 sneakers.txt

If you are the owner of the file or are logged into the root account you can change any permissions for the owner, group, and others.

Right now, the owner and group can read and write to the file. Anyone outside of the group can only read the file (r--).

Caution

Remember that file permissions are a security feature. Whenever you allow anyone else to read, write to, and execute files, you are increasing the risk of files being tampered with, altered, or deleted. As a rule, you should only grant read and write permissions to those who truly need them.

In the following example, you want to allow everyone to write to the file, so they can read it, write notes in it, and save it. That means you will have to change the "others" section of the file permissions.
Take a look at the file first. At the shell prompt, type:

```
ls -l sneakers.txt
```

The previous command displays this file information:

```
-rw-rw-r-- 1 sam sam 150 Mar 19 08:08 sneakers.txt
```

Now, type the following:

```
chmod o+w sneakers.txt
```

The `o+w` command tells the system you want to give others write permission to the file `sneakers.txt`. To check the results, list the file’s details again. Now, the file looks like this:

```
-rw-rw-rw- 1 sam sam 150 Mar 19 08:08 sneakers.txt
```

Now, everyone can read and write to the file.

To remove read and write permissions from `sneakers.txt` use the `chmod` command to take away both the read and write permissions.

```
chmod go-rw sneakers.txt
```

By typing `go-rw`, you are telling the system to remove read and write permissions for the group and for others from the file `sneakers.txt`.

The result will look like this:

```
-rw------- 1 sam sam 150 Mar 19 08:08 sneakers.txt
```

Think of these settings as a kind of shorthand when you want to change permissions with `chmod`, because all you really have to do is remember a few symbols and letters with the `chmod` command. Here is a list of what the shorthand represents:

**Identities**

- `u` — the user who owns the file (that is, the owner)
- `g` — the group to which the user belongs
- `o` — others (not the owner or the owner’s group)
- `a` — everyone or all (`u`, `g`, and `o`)

**Permissions**

- `r` — read access
- `w` — write access
- `x` — execute access

**Actions**

- `+` — adds the permission
- `-` — removes the permission
- `=` — makes it the only permission

Want to test your permissions skills? Remove all permissions from `sneakers.txt` — for everyone.
chmod a-rwx sneakers.txt

Now, see if you can read the file with the command `cat sneakers.txt`, which should return the following:

cat: sneakers.txt: Permission denied

Removing all permissions, including your own, successfully locked the file. But since the file belongs to you, you can always change its permissions back with the following command:

chmod u+rw sneakers.txt

Use the command `cat sneakers.txt` to verify that you, the file owner, can read the file again.

Here are some common examples of settings that can be used with `chmod`:

- `g+w` — adds write access for the group
- `o-rwx` — removes all permissions for others
- `u+x` — allows the file owner to execute the file
- `a+rw` — allows everyone to read and write to the file
- `ug+r` — allows the owner and group to read the file
- `g=rx` — allows only the group to read and execute (not write)

By adding the `-R` option, you can change permissions for entire directory trees.

Because you can not really "execute" a directory as you would an application, when you add or remove execute permission for a directory, you are really allowing (or denying) permission to search through that directory.

If you do not allow others to have execute permission to `tigger`, it will not matter who has read or write access. No one will be able to get into the directory unless they know the exact file name.

For example, type:

```
chmod a-x tigger
```

to remove everyone’s execute permissions.

Here is what happens now when you try to `cd` into `tigger`:

```
bash: tigger: Permission denied
```

Next, restore your own and your group’s access:

```
chmod ug+x tigger
```

Now, if you check your work with `ls -l` you will see that only others will be denied access to the `tigger` directory.

### 13.14.2. Changing Permissions With Numbers

Remember the reference to the shorthand method of `chmod`? Here is another way to change permissions, although it may seem a little complex at first.

Go back to the original permissions for `sneakers.txt`:

```
-rw-rw-r-- 1 sam sam 150 Mar 19 08:08 sneakers.txt
```
Each permission setting can be represented by a numerical value:

- $r = 4$
- $w = 2$
- $x = 1$
- $- = 0$

When these values are added together, the total is used to set specific permissions. For example, if you want read and write permissions, you would have a value of 6; $4 \text{ (read)} + 2 \text{ (write)} = 6$.

For `sneakers.txt`, here are the numerical permissions settings:

- (rw-) (rw-) (r--)
- 4+2+0 4+2+0 4+0+0

The total for the user is six, the total for the group is six, and the total for others is four. The permissions setting is read as 664.

If you want to change `sneakers.txt` so those in your group will not have write access, but can still read the file, remove the access by subtracting two (2) from that set of numbers.

The numerical values, then, would become six, four, and four (644).

To implement these new settings, type:

```bash
cchmod 644 sneakers.txt
```

Now verify the changes by listing the file. Type:

```bash
lst -l sneakers.txt
```

The output should be:

```
-rw-r--r-- 1 sam sam 150 Mar 19 08:08 sneakers.txt
```

Now, neither the group nor others have write permission to `sneakers.txt`. To return the group’s write access for the file, add the value of $w$ (2) to the second set of permissions.

```bash
cchmod 664 sneakers.txt
```

⚠️ Warning

Setting permissions to 666 will allow everyone to read and write to a file or directory. Setting permissions to 777 allows everyone read, write, and execute permission. These permissions could allow tampering with sensitive files, so in general, it is not a good idea to use these settings.

Here is a list of some common settings, numerical values and their meanings:

- `-rw-----(600) — Only the owner has read and write permissions.
- `-rw-r---r-- (644) — Only the owner has read and write permissions; the group and others have read only.
- `-rwx----- (700) — Only the owner has read, write, and execute permissions.`
- rwxr-xr-x (755) — The owner has read, write, and execute permissions; the group and others have only read and execute.
- rwx--x--x (711) — The owner has read, write, and execute permissions; the group and others have only execute.
- rw-rw-rw- (666) — Everyone can read and write to the file. (Be careful with these permissions.)
- rwxrwxrwx (777) — Everyone can read, write, and execute. (Again, this permissions setting can be hazardous.)

Here are some common settings for directories:
- drwx------ (700) — Only the user can read, write in this directory.
- drwxr-xr-x (755) — Everyone can read the directory; users and groups have read and execute permissions.
Your desktop file manager is a powerful and important tool for managing files and directories using the graphical desktop. This chapter discusses various shell prompt commands that can be used to manage files and directories on your Red Hat Linux system. This chapter also discusses compression tools to create archives of your files for backup or to conveniently send to others.

**Note**

Due to system security, unless you are root, you will not be able to gain access to all system-level files and directories. If you do not have the permission to open, delete, or execute a file, you will receive an error message saying your access is denied. This is normal behavior and is used to prevent non-privileged users from modifying or deleting important system files.

### 14.1. A Larger Picture of the File System

Every operating system has a method of storing data in files and directories so that it can keep track of additions, modifications, and other changes.

In Linux, every file is stored in a directory. Directories can also contain directories; these *subdirectories* can also contain files and other subdirectories.

You might think of the file system as a tree-like structure and directories as branches. These directories may contain, or be the "parent" of, directories within it (called *subdirectories*) which hold files and may contain subdirectories of their own.

There would not be a tree without a root, and the same is true for the Linux file system. No matter how far away the directories branch, everything is connected to the root directory, which is represented as a single forward slash (/).

**Tip**

Red Hat Linux uses the term *root* in several different ways, which might be confusing to new users. There is the root account (the superuser, who has permission to do anything), the root account’s home directory (`/root`) and the root directory for the entire file system (`/`). When you are speaking to someone and using the term *root*, be sure to know which root is being discussed.

Unless you are a system administrator or have root (superuser) access, you probably do not have permission to write to the files and directories outside of your home directory. Certain directories are reserved for specific purposes. For example, `/home` is the default location for users’ home directories.

Users that do not have superuser access might find the following directories useful for finding their home directories, reading documentation, or storing temporary files.

- `/home` — Default location for users’ home directories. For example, a user with the username `foo` has the home directory `/home/foo`.
- `/usr/share/doc` — Location of documentation for installed packages. For example, the documentation for the `redhat-config-date` software package is located in `/usr/share/doc/redhat-config-date-<version-number>`.
• /tmp — The reserved directory for all users to store temporary files. Files stored here are not permanent. A system process removes old files from this directory on a periodic basis. Do not write any files or directories that you want to keep here.

Your Red Hat Linux system is compatible with many other Linux distributions because of the Filesystem Hierarchy Standard (FHS). The FHS guidelines help to standardize the way system programs and files are stored on all Linux systems.

To learn more about the FHS, refer to the Red Hat Linux Reference Guide. You can also visit the FHS website at http://www.pathname.com/fhs.

14.2. Identifying and Working with File Types

If you are new to Linux, you may see certain file types that you do not recognize because of their unfamiliar extension. A file’s extension is the last part of a file’s name after the final dot (in the file sneakers.txt,”txt” is that file’s extension).

Here is a brief listing of file extensions and their meanings:

14.2.1. Compressed and Archived Files

• .bz2 — a file compressed with bzip2  
• .gz — a file compressed with gzip  
• .tar — a file archived with tar (short for tape archive), also known as a tar file  
• .tbz — a tarred and bzipped file  
• .tgz — a tarred and gzipped file.  
• .zip — a file compressed with ZIP compression, commonly found in MS-DOS applications. Most compressed files for Linux use the gzip compression, so finding a .zip archive for Linux files is rare.

For information on working with bzip2, gzip, and tar files, refer to Section 14.3 File Compression and Archiving.

14.2.2. File Formats

• .au — an audio file  
• .gif — a GIF image file  
• .html/.htm — an HTML file  
• .jpg — a JPEG image file  
• .pdf — an electronic image of a document; PDF stands for Portable Document Format  
• .png — a PNG image file (short for Portable Network Graphic)  
• .ps — a PostScript file; formatted for printing  
• .txt — a plain ASCII text file  
• .wav — an audio file  
• .xpm — an image file
### 14.2.3. System Files

- `.conf` — a configuration file. Configuration files sometimes use the `.cfg` extension, as well.
- `.lock` — a lock file; determines whether a program or device is in use.
- `.rpm` — a Red Hat Package Manager file used to install software.

### 14.2.4. Programming and Scripting Files

- `.c` — a C program language source code file
- `.cpp` — a C++ program language source code file
- `.h` — a C or C++ program language header file
- `.o` — a program object file
- `.pl` — a Perl script
- `.py` — a Python script
- `.so` — a library file
- `.sh` — a shell script
- `.tcl` — a TCL script

But file extensions are not always used, or used consistently. So what happens when a file does not have an extension, or the file does not seem to be what the extension says it is supposed to be? That is when the `file` command can be helpful.

For example, you find a file called `saturday` without an extension. Using the `file` command, you can tell what type of file it is by typing:

```
file saturday
```

In the example, the command `file saturday` will display ASCII text, telling you it is a text file. Any file that is designated as a text file should be readable by using the `cat`, `more`, or `less` commands, or by using a text editor such as `gedit` or `vi`.

**Tip**

To learn more about `file`, read the man page by typing `man file`.

For more information on helpful commands for reading files, see Chapter 13 *Shell Prompt Basics*.

### 14.3. File Compression and Archiving

Sometimes it is useful to store a group of files in one file so that they can be backed up, easily transferred to another directory, or even transferred to a different computer. It is also sometimes useful to compress files into one file so that they use less disk space and download faster via the Internet.

It is important to understand the distinction between an *archive file* and a *compressed file*. An archive file is a collection of files and directories that are stored in one file. The archive file is not compressed — it uses the same amount of disk space as all the individual files and directories combined. A
compressed file is a collection of files and directories that are stored in one file and stored in a way that uses less disk space than all the individual files and directories combined. If you do not have enough disk space on your computer, you can compress files that you do not use very often or files that you want to save but do not use anymore. You can even create an archive file and then compress it to save disk space.

**Note**

An archive file is not compressed, but a compressed file can be an archive file.

### 14.3.1. Using File Roller

Red Hat Linux includes a graphical utility called **File Roller** that can compress, decompress, and archive files and directories. **File Roller** supports common UNIX and Linux file compression and archiving formats and has a simple interface and extensive help documentation if you need it. It is also integrated into the desktop environment and graphical file manager to make working with archived files easier.

To start **File Roller** click **Main Menu => Accessories => File Roller**. You can also start **File Roller** from a shell prompt by typing `file-roller`. Figure 14-1 shows **File Roller** in action.

**Tip**

If you are using a file manager (such as Nautilus), you can double-click the file you wish to unarchive or decompress to start **File Roller**. The **File Roller** browser window will appear with the decompressed/unarchived file in a folder for you to extract or browse.

![Figure 14-1. File Roller in Action](image)

#### 14.3.1.1. Decompressing and Unarchiving with File Roller

To unarchive and/or decompress a file click the **Open** toolbar button. A file menu will pop up, allowing you to choose the archive you wish to work with. For example, if you have a file called `foo.tar.gz` located in your home directory, highlight the file and click **OK**. The file will appear in the main **File Roller** browser window as a folder, which you can navigate by double-clicking the folder icon. **File**
Roller preserves all directory and subdirectory structures, which is convenient if you are looking for a particular file in the archive. You can extract individual files or entire archives by clicking the Extract button, choosing the directory you would like to save the unarchived files, and clicking OK.

14.3.1.2. Creating Archives with File Roller

If you need to free some hard drive space, or send multiple files or a directory of files to another user, File Roller allows you to create archives of your files and directories. To create a new archive, click New on the toolbar. A file browser will pop up, allowing you to specify an archive name and the compression technique. For example, you may choose a Tar Compressed with gzip (tar.gz) format from the drop-down menu and type the name of the archive file you want to create. Click OK and your new archive is now ready to be filled with files and directories. To add files to your new archive, click Add, which will pop up a browser window (Figure 14-2) that you can navigate to find the file or directory you want to be in the archive. Click OK when you are finished, and click Close to close the archive.

Tip

There is much more you can do with File Roller than is explained here. Refer to the File Roller manual (available by clicking Help => Manual) for more information.

14.3.2. Compressing Files at the Shell Prompt

Compressed files use less disk space and download faster than large, uncompressed files. In Red Hat Linux you can compress files with the compression tools gzip, bzip2, or zip.

The bzip2 compression tool is recommended because it provides the most compression and is found on most UNIX-like operating systems. The gzip compression tool can also be found on most UNIX-like operating systems. If you need to transfer files between Linux and other operating system such
as MS Windows, you should use zip because it is more compatible with the compression utilities on Windows.

<table>
<thead>
<tr>
<th>Compression Tool</th>
<th>File Extension</th>
<th>Uncompression Tool</th>
</tr>
</thead>
<tbody>
<tr>
<td>gzip</td>
<td>.gz</td>
<td>gunzip</td>
</tr>
<tr>
<td>bzip2</td>
<td>.bz2</td>
<td>bunzip2</td>
</tr>
<tr>
<td>zip</td>
<td>.zip</td>
<td>unzip</td>
</tr>
</tbody>
</table>

Table 14-1. Compression Tools

By convention, files compressed with gzip are given the extension .gz, files compressed with bzip2 are given the extension .bz2, and files compressed with zip are given the extension .zip.

Files compressed with gzip are uncompressed with gunzip, files compressed with bzip2 are uncompressed with bunzip2, and files compressed with zip are uncompressed with unzip.

14.3.2.1. Bzip2 and Bunzip2

To use bzip2 to compress a file, type the following command at a shell prompt:

```bash
bzip2 filename
```

The file will be compressed and saved as `filename.bz2`.

To expand the compressed file, type the following command:

```bash
bunzip2 filename.bz2
```

The `filename.bz2` is deleted and replaced with `filename`.

You can use bzip2 to compress multiple files and directories at the same time by listing them with a space between each one:

```bash
bzip2 filename.bz2 file1 file2 file3 /usr/work/school
```

The above command compresses `file1`, `file2`, `file3`, and the contents of the `/usr/work/school` directory (assuming this directory exists) and places them in a file named `filename.bz2`.

Tip

For more information, type `man bzip2` and `man bunzip2` at a shell prompt to read the man pages for `bzip2` and `bunzip2`.

14.3.2.2. Gzip and Gunzip

To use gzip to compress a file, type the following command at a shell prompt:

```bash
gzip filename
```

The file will be compressed and saved as `filename.gz`.

```
To expand the compressed file, type the following command:

`gunzip filename.gz`

The `filename.gz` is deleted and replaced with `filename`.

You can use `gzip` to compress multiple files and directories at the same time by listing them with a space between each one:

`gzip -r filename.gz file1 file2 file3 /usr/work/school`

The above command compresses `file1, file2, file3`, and the contents of the `/usr/work/school` directory (assuming this directory exists) and places them in a file named `filename.gz`.

**Tip**

For more information, type `man gzip` and `man gunzip` at a shell prompt to read the man pages for `gzip` and `gunzip`.

### 14.3.2.3. Zip and Unzip

To compress a file with `zip`, type the following command:

`zip -r filename.zip filesdir`

In this example, `filename.zip` represents the file you are creating and `filesdir` represents the directory you want to put in the new zip file. The `-r` option specifies that you want to include all files contained in the `filesdir` directory *recursively*.

To extract the contents of a `zip` file, type the following command:

`unzip filename.zip`

You can use `zip` to compress multiple files and directories at the same time by listing them with a space between each one:

`zip -r filename.zip file1 file2 file3 /usr/work/school`

The above command compresses `file1, file2, file3`, and the contents of the `/usr/work/school` directory (assuming this directory exists) and places them in a file named `filename.zip`.

**Tip**

For more information, type `man zip` and `man unzip` at a shell prompt to read the man pages for `zip` and `unzip`. 
14.3.3. Archiving Files at the Shell Prompt

A tar file is a collection of several files and/or directories in one file. This is a good way to create backups and archives.

Some of the options used with the tar are:

- `-c` — create a new archive.
- `-f` — when used with the `-c` option, use the filename specified for the creation of the tar file; when used with the `-x` option, unarchive the specified file.
- `-t` — show the list of files in the tar file.
- `-v` — show the progress of the files being archived.
- `-x` — extract files from an archive.
- `-z` — compress the tar file with gzip.
- `-j` — compress the tar file with bzip2.

To create a tar file, type:

```
tar -cvf filename.tar directory/file
```

In this example, `filename.tar` represents the file you are creating and `directory/file` represents the directory and file you want to put in the archived file.

You can `tar` multiple files and directories at the same time by listing them with a space between each one:

```
tar -cvf filename.tar /home/mine/work /home/mine/school
```

The above command places all the files in the `work` and the `school` subdirectories of `/home/mine` in a new file called `filename.tar` in the current directory.

To list the contents of a tar file, type:

```
tar -tlf filename.tar
```

To extract the contents of a tar file, type:

```
tar -xvf filename.tar
```

This command does not remove the tar file, but it places copies of its unarchived contents in the current working directory, preserving any directory structure that the archive file used. For example, if the tarfile contains a file called `bar.txt` within a directory called `foo/`, then extracting the archive file will result in the creation of the directory `foo/` in your current working directory with the file `bar.txt` inside of it.

Remember, the `tar` command does not compress the files by default. To create a tarred and bzipped compressed file, use the `-j` option:

```
tar -cjvf filename.tbz file
```

Tar files compressed with bzip2 are conventionally given the extension `.tbz`; however, sometimes users archive their files using the `.tar.bz2` extension.

The above command creates an archive file and then compresses it as the file `filename.tbz`. If you uncompress the `filename.tbz` file with the `bunzip2` command, the `filename.tbz` file is removed and replaced with `filename.tar`.

You can also expand and unarchive a bzip tar file in one command:
tar -xjvf filename.tbz

To create a tarred and gzipped compressed file, use the -z option:

tar -czvf filename.tgz file

Tar files compressed with gzip are conventionally given the extension .tgz.

This command creates the archive file filename.tar and then compresses it as the file filename.tgz. (The file filename.tar is not saved.) If you uncompress the filename.tgz file with the gunzip command, the filename.tgz file is removed and replaced with filename.tar.

You can expand a gzip tar file in one command:

tar -xzvf filename.tgz

Tip

Type the command man tar for more information about the tar command.

14.4. Manipulating Files at the Shell Prompt

Files can be manipulated using one of the graphical file managers, such as Nautilus or Konqueror. They can also be manipulated using a shell prompt, which is often faster. This section explains how to manipulate files at the shell prompt.

14.4.1. Creating Files

You can create new files either with applications (such as text editors) or by using the command touch, which will create an empty file that you can use to add text or data. To create a file with touch, type the following at a shell prompt.

touch <filename>

Replace <filename> with the name of your choice. If you run a directory listing, you can see that the file contains zero (0) bytes of information because it is an empty file. For example, typing the command ls -l newfile at the shell prompt returns the following output:

```
-rw-rw-r-- 1 sam sam 0 Apr 10 17:09 newfile
```

14.4.2. Copying Files

Like so many other Linux features, there is a variety of ways to manipulate files and directories. You can also use wildcards, as explained in Section 13.11.5 Wildcards and Regular Expressions, to make the process of copying, moving, or deleting multiple files and directories faster.

To copy a file, type the following command.

cp <source> <destination>
Replace `<source>` with the name of the file you want to copy, and `<destination>` with the name of the directory where you want the file to go.

So, to copy the file `sneakers.txt` to the directory `tigger/` in your home directory, move to your home directory and type:

```
cp sneakers.txt tigger/
```

You can use both relative and absolute pathnames with `cp`. Our home directory is the parent of the directory `tigger`; `tigger` is one directory down from our home directory.

Tip

To learn more about relative and absolute pathnames, refer to Section 13.4 Changing Directories with `cd`.

Read the `cp` man page (type `man cp` at the shell prompt) for a full list of the options available with `cp`. Among the options you can use with `cp` are the following:

- `-i` — interactive. Prompts you to confirm if the file is going to overwrite a file in your destination. This is a handy option because it can help prevent you from making mistakes.
- `-r` — recursive. Rather than just copying all the specified files and directories, this will copy the whole directory tree, subdirectories and all.
- `-v` — verbose. Shows the progress of the files as they are being copied.

Now that you have the file `sneakers.txt` in the `tigger` directory, use `cp -i` to copy the file again to the same location.

```
cp -i sneakers.txt tigger
```

To overwrite the file that is already there, press `[Y]` and then `[Enter]`. If you do not want to overwrite the file, press `[N]` and `[Enter].

### 14.4.3. Moving Files

To move files, use the `mv` command. For more about `mv`, see the `mv` man page (type `man mv`).

Common options for `mv` include the following:

- `-i` — interactive. This will prompt you if the file you have selected will overwrite an existing file in the destination directory. This is a good option, because like the `-i` option for `cp`, you will be given the chance to make sure you want to replace an existing file.
- `-f` — force. Overrides the interactive mode and moves without prompting. Unless you know what you are doing, this option is dangerous; be very careful about using it until you become more comfortable with your system.
- `-v` — verbose. Shows the progress of the files as they are being moved.

If you want to move a file out of your home directory and into another existing directory, type the following (you will need to be in your home directory):

```
mv sneakers.txt tigger
```
Alternatively, the same command using absolute pathnames looks like

```
mv sneakers.txt /home/newuser/sneakers.txt /home/newuser/tigger
```

### 14.4.4. Deleting Files and Directories

You learned about creating files with the `touch` command, and you created the directory `tigger` using `mkdir`.

Now you need to learn how to delete files and directories. Deleting files and directories with the `rm` command is a straightforward process. See the `rm` man page for more information. Options for removing files and directories include:

- **-i** — interactive. Prompts you to confirm the deletion. This option can stop you from deleting a file by mistake.
- **-f** — force. Overrides interactive mode and removes the file(s) without prompting. This might not be a good idea, unless you know exactly what you are doing.
- **-v** — verbose. Shows the progress of the files as they are being removed.
- **-r** — recursive. Will delete a directory and all files and subdirectories it contains.

To delete the file `piglet.txt` with the `rm` command, type:

```
rm piglet.txt
```

⚠️ **Warning**

Once a file or directory is removed with the `rm` command, it is gone permanently and cannot be retrieved.

Use the **-i** (interactive) option to give you a second chance to think about whether or not you really want to delete the file.

```
rm -i piglet.txt
rm: remove 'piglet.txt'? 
```

You can also delete files using the wildcard `*`, but be careful, because you can easily delete files you did not intend to throw away.

To remove a file using a wildcard, you would type:

```
rm pig*
```

The above command will remove all files in the directory which start with the letters `pig`.

You can also remove multiple files using the `rm` command. For example:

```
rm piglet.txt sneakers.txt
```

You can use `rmdir` to remove a directory (`rmdir foo`, for example), but only if the directory is empty. To remove directories with `rm`, you must specify the `-r` option.

For example, if you want to recursively remove the directory `tigger` you would type:
rm -r tigger

If you want to combine options, such as forcing a recursive deletion, you can type:

rm -rf tigger

A safer alternative to using \texttt{rm} for removing directories is the \texttt{rmdir} command. With this command, you will not be allowed to use recursive deletions, so a directory which has files in it will not be deleted.

\textbf{Warning}

The \texttt{rm} command can delete your entire file system! If you are logged in as root and you type the simple command \texttt{rm -rf /}, you are in trouble; this command will recursively remove everything on your system.

Read the \texttt{rmdir} man page (\texttt{man rmdir}) to find out more about this command.
Chapter 15.

Installing and Updating Red Hat Linux Packages

Red Hat Linux consists of various software applications and utilities, known as *RPM packages*. A package is just a file that contains a software program.

This chapter explains three ways to update your system: using Red Hat Network, using the online Errata List, and using the Red Hat Linux Installation CD-ROMs.

15.1. Red Hat Network

Red Hat Network is an Internet solution for managing one or more Red Hat Linux systems. All Security Alerts, Bug Fix Alerts, and Enhancement Alerts (collectively known as Errata Alerts) can be downloaded directly from Red Hat using the **Red Hat Update Agent** standalone application or through the RHN website available at http://rhn.redhat.com/.

![Red Hat Network](image)

**Figure 15-1. Your RHN**

Red Hat Network saves users time because they receive email when updated packages are released. Users do not have to search the Web for updated packages or security alerts. By default, Red Hat Network installs the packages as well. Users do not have to learn how to use RPM or worry about resolving software package dependencies; RHN does it all.

Each Red Hat Network account comes with:

- Errata Alerts — learn when Security Alerts, Bug Fix Alerts, and Enhancement Alerts are issued for all the systems in your network through the Basic interface
• Automatic email notifications — receive an email notification when an Errata Alert is issued for your system

• Scheduled Errata Updates — schedule delivery of Errata Updates

• Package installation — Schedule package installation on one or more systems with the click of a button

• Red Hat Update Agent — use the Red Hat Update Agent to download the latest software packages for your system (with optional package installation)

• Red Hat Network website — manage multiple systems, downloaded individual packages, and schedule actions such as Errata Updates through a secure Web browser connection from any computer

To start using Red Hat Network, follow these three basic steps:

1. Create a System Profile using one of the following methods:
   • Registering the system with RHN during the Setup Agent the first time your system boots after installation.
   • Select Main Menu Button => System Tools => Red Hat Network on your desktop.
   • Execute the command up2date from a shell prompt.

2. Log in to RHN at http://rhn.redhat.com/ and entitle the system to a service offering. Everyone receives a free Red Hat Network account for one system. Additional accounts can be purchased.

3. Start scheduling updates through the RHN website or download and install Errata Updates with the Red Hat Update Agent.
Chapter 15. Installing and Updating Red Hat Linux Packages


**Tip**

Red Hat Linux includes the **Red Hat Network Notification Tool**, a convenient panel icon that displays visible alerts when there is an update for your Red Hat Linux system. Refer to the following URL for more information about the applet: http://rhn.redhat.com/help/basic/applet.html

15.2. Errata List

It is recommended that new users use Red Hat Network to download and install/upgrade packages. Updating Errata packages from the Red Hat Linux Errata website is recommended for more experienced Red Hat Linux users. It also requires users to resolve *software dependencies* manually. A software dependency is when a package is dependent on other package being installed.

All Security Alerts, Bug Fix Alerts, and Enhancement Alerts (collective known as Errata Alerts) can also be downloaded from the Red Hat website at http://www.redhat.com/apps/support/errata/. Click on the Red Hat Linux version you are using to view a list of all available errata for Red Hat Linux. Click on the name of the Errata Alert that you want to apply to your system. Instructions for updating the packages are on the individual Errata pages. Red Hat, Inc. tests and approves the RPMs posted on this site. RPMs downloaded from other sites are not supported.

For more information about installing packages downloaded from our errata sites, refer to Section 15.4 *Downloaded Packages*.

15.3. Installation CD-ROMs

Place the first Red Hat Linux CD-ROM in your CD-ROM drive. Select Yes when asked if you want to run the *autorun* program from the CD. It then prompts you for the root password so that you can install packages.

If you enter the correct root password, the **Package Management Tool** interface appears and allows you to select packages groups to install as well as individual packages within the groups.

![Add or Remove Packages](image)

**Figure 15-3. Installing Software with the Package Management Tool**
The Package Management Tool marks what packages are already installed on your system with a checkmark. You can add packages by clicking the checkbox next to each package. To uninstall a package, remove the checkmark (see Figure 15-4).

![Figure 15-4. Individual Package Selection](image)

After selecting packages, click the **Update** button to install or uninstall the selected packages.

15.4. Downloaded Packages

If you have downloaded packages from an errata on the Red Hat website, you can install them by opening your file manager and double-clicking the package you want to install. The Package Management Tool should open up and check the package for any dependencies you need to fulfill before installation, such as package or library files needed. If all goes well, the package will be installed and you can immediately begin using the software from the installed package. However, if there are dependencies, the Package Management Tool will alert you with suggested files and packages you need to install.

![Figure 15-5. RPM Package Dependencies](image)

The packages necessary to fulfill the dependency issues can be installed by following the steps in Section 15.3 Installation CD-ROMs.

Refer to the Red Hat Linux Customization Guide for more information about the Package Management Tool.
Chapter 16.
Frequently Asked Questions

This chapter answers some of the most common questions about using Red Hat Linux that you may ask as you become more familiar with it. From recovering forgotten passwords to troubleshooting package installation problems, this chapter will ease you step-by-step through some common tasks and get you on your way.

16.1. Localhost Login and Password

I have installed Red Hat Linux. After rebooting, I get a message telling me it needs a localhost login and password. What are these?

Unless you specified a host name for your computer, or received that information from a network, your Red Hat Linux installation will call your machine localhost.localdomain by default.

When you get to that initial prompt, it is asking you to log in to your system. If you created a user account with the Setup Agent, you can log in using that user name and password. If you did not create a user account, then you can log in as the super user, also known as root. The root password is the system password you assigned during installation.

It is highly recommended that you create at least one user account for regular use of your Red Hat Linux system. You can create a new user after logging in as root with the User Manager graphical tool or the useradd shell prompt utility. For more information, refer to Section 1.6 Creating a User Account.

16.2. Error Messages During Installation of RPMs

How do I install an RPM from a CD or the Internet? I keep getting an error message when I use rpm.

If you are getting an error message similar to failed to open /var/lib/rpm/packages.rpm, it is because you do not have proper permission to install RPM files.

When you install software, you are often required to make system-wide changes which only root can make, such as creating new directories outside of your user home directory or making changes to your system configuration. If you are using your normal user account, you will not have permission to make such changes by default.

You need to be the root user in order to install RPM files. At a shell prompt, switch to the root user by running the following command:

```
su
```

After entering the root password when prompted, you should then be able to install the RPM file without further errors. For more information about using RPM and Package Management Tool, refer to the Red Hat Linux Customization Guide on the Red Hat Linux Documentation CD or online at http://www.redhat.com/docs/.

16.3. Starting Applications

I installed an application I downloaded from the Internet, and everything seemed to go fine, but I still get "command not found" when I type its name. I think I have the right name, so why will it not start?
If you are trying to start an application from the shell prompt and it is not working, try typing out the full directory path before the name of the application’s executable (such as `/usr/local/bin/my-executable`).

For example, imagine that you have downloaded the `setiathome` client application and want to try it out. You follow the directions for installing the software, which creates a subdirectory in your home directory called `seti/`. Now, start the application using the full path to the executable file as shown below:

```
/home/joe/seti/setiathome
```

The reason you may need to type the full pathnames in order to start an application is because the executable was not placed in a directory where your user shell environment knew it could be found (such as `/usr/local/bin`).

You can customize your settings so that you are not required to use the type the full path to the application each time. To do this, you will have to edit your PATH environment variable.

### 16.3.1. Editing Your PATH

If you frequently start programs that are not located in a directory that your user shell has been configured to search, you will have to edit your user shell configuration file to add the directory containing the executable you wish to run. You can do this by adding the directory to your PATH environment variable.

⚠️ **Caution**

These instructions are intended only for user accounts. Avoid modifying files such as the root user’s `.bash_profile`, because of the potential security risks.

Start a text editor, such as `gedit` or `vi`, at a shell prompt. You can open the file called `.bash_profile` by typing the following:

```
gedit .bash_profile
```

You will see a PATH statement, similar to the one shown below.

```
PATH=$PATH:$HOME/bin:/usr/local/bin:
```

To the end of this statement, add `$HOME/seti` as shown below:

```
PATH=$PATH:$HOME/bin:/usr/local/bin:/$HOME/seti:
```

Save the file and exit the text editor.

You can then make the changes to `.bash_profile` take effect immediately by typing the following command:

```
source .bash_profile
```

By adding paths to your `.bash_profile`, you can place utilities and programs in your path and be able to execute them without having to type `./` in front of the command.
16.4. Accessing a Windows Partition

I have a dual-boot system with Red Hat Linux and Windows 98. Is there a way to access my Windows partition while I am running Linux?

You can access another partition on your system (for example, a Windows partition), in two different ways.

You should first determine where your Windows partition is located by determining what physical hard disk your Windows partition is located in (such as the primary master IDE drive or the the first SCSI drive). To find this information, you can use the Hardware Browser, which lists detailed information about the hardware in your Red Hat Linux system.

To start the Hardware Browser, choose Main Menu => System Tools => Hardware Browser. Figure 16-1 shows Hardware Browser in action.

![Hardware Browser hard disk device listing](image)

Select Hard Drives from the panel and find your Windows partition from the Disk Information displayed. Windows partitions normally use the FAT or FAT32 file system type. This file system type can be mounted and read within Linux; however, if your Windows partition uses NTFS, then you cannot mount and read from it as Red Hat Linux does not support NTFS file systems. Note the Device information for your Windows partition, as this is the device that you mount to access your Windows data.

Once you have determined where your Windows partition is located on your hard drive, log in as root (type su and then enter the root password) at a shell prompt.

Create a directory in which the Windows partition will be mounted by typing the following command. For example:

mkdir /mnt/windows
Before you can access the partition, you will need to mount it in the directory you just created. As root, type the following command at a shell prompt (where /dev/hda1 is the Windows partition you found via Hardware Browser):

```bash
mount -t vfat /dev/hda1 /mnt/windows
```

You may then logout of root user mode and access your Windows data by changing into the mounted Windows partition:

```bash
cd /mnt/windows
```

To automatically mount a Windows partition every time you boot your Red Hat Linux system, you must modify the `/etc/fstab` file, which configures all file systems and disk device mounting options.

At a shell prompt, `su` to root, following the above example.

Next, open the `/etc/fstab` in a text editor by typing (for example):

```bash
gedit /etc/fstab
```

Add the following on a new line (replacing `/dev/hda1` with the Windows partition you found via Hardware Browser):

```bash
/dev/hda1 /mnt/windows vfat auto,umask=0 0 0
```

Save the file and exit your text editor.

The next time the system is rebooted, the `/etc/fstab` file is read, and the Windows partition is automatically mounted in the directory `/mnt/windows`. To access the partition at a shell prompt, type the command `cd /mnt/windows`. To navigate through directories or files with spaces, surround the name of the directory or file with quotation marks, as in `ls "Program Files"`.

### 16.5. Finding Commands Quickly

I was looking at a man page yesterday, but I cannot remember the name of the command I was reading about, and I did not write it down. How do I get the man page back?

The command you used will most likely be stored in a file called `.bash_history`. By default, this file records the last 500 commands you typed at the shell prompt.

You can glimpse the history of your commands by typing `history` at the shell prompt, but the results will speed by too quickly for your to read ever line.

Another way to view `.bash_history` is with a utility such as `less`. Type `less .bash_history` at the shell prompt and the results will display one page at a time. To move forward a screen, press the [Space] bar; to move back a screen, press the [b] key, and to quit, press [q].

Paging through `.bash_history` to find a command can be tedious. Alternatively, you can search through the file for keywords using `grep`, a powerful search utility.

Say you were reading the man page the day before, but cannot recall its name. To search for the command, type:

```bash
history | grep man
```

You will see a list of all the commands you typed which have the word `man` in them.

There are plenty of ways to your command history. For other tips and tricks, see Section 16.6 Tips on Using Command History.
16.6. Tips on Using Command History

What are some other ways I can use command history?

If you type `history`, you will see a numbered list scroll by very quickly, showing you the previous 500 commands you have used.

You probably do not need to see all of the last 500 commands, so the command `history 20` might be useful. This way, only the previous 20 commands you typed will display (you can use any quantity as an argument of the `history` command).

16.6.1. Other Shortcuts

Here are other command history shortcuts which may be useful to you:

- "Bang, bang": Typing `!!` (called "bang bang") executes the last command in the history.
- "Bang number": Typing `!number` (as in `!302`) will execute the command which is numbered 302 in the history file.
- "Bang string": Typing `!string` (as in `!rpm`) will execute a command with the most recent matching string from the history file.
- `[Up arrow] and [down arrow]`: At the shell or GUI terminal prompt, you can press the up arrow to move back through previous commands in your history list (the down arrow will move you forward through the commands) until you find the command you want. Press [Enter] to execute the command, just as if you had typed it on the command line.

16.7. Keep `ls` Output from Scrolling

Whenever I type `ls` I can barely see the output of the directory because it scrolls by too quickly. How can I actually read the output?

To prevent the output of `ls` from scrolling by too quickly, pipe the output to a utility such as `less` or `more`. You will then be able to see the output one screen, or "page" at a time.

To read the contents of `/etc` with `less`, type the following command at the shell prompt:

```
ls -al /etc | less
```

To move forward a screen, press [Space] bar; to move back a screen, press the [b] key; to quit, press [q].

You can achieve the same results with `more`, another paging utility.

16.7.1. Printing `ls` Output

You can also print directory listings by piping the output to a printer in the same way that you piped the output to your screen. If you have configured a printer, type the following to pipe the output of a command to the printer:

```
ls -al /etc | lpr
```
16.8. Forgotten Password

Help! I forgot my root password. How do I log in now?

You can log in using single-user mode and create a new root password.

To enter single-user mode, reboot your computer. If you use the default boot loader, GRUB, you can enter single user mode by performing the following:

1. At the boot loader menu, type [e] to enter into editing mode.
2. You will be presented with a boot entry listing. Look for the line that looks similar to the following:
   `kernel /vmlinuz-2.4.18-0.4 ro root=/dev/hda2`
   Press the arrow key until this line is highlighted and press [e].
3. Press the Spacebar once to add a blank space, then add the word `single` to tell GRUB to boot into single-user Linux mode. Press [Enter] to make the editing change take effect.
4. You will be brought back to the edit mode screen. From here, press [b] and GRUB will boot single-user Linux mode. After it finishes loading, you will be presented with a shell prompt similar to the following:
   `sh-2.05#`
5. You can now change the root password by typing
   `bash# passwd root`
   You will be asked to re-type the password for verification. Once you are finished, the password will be changed. You can then reboot by typing `reboot` at the prompt; then you can log in to root as you normally would.

16.9. Password Maintenance

I forgot or want to change my user account password.

Open a shell prompt and type the following:

`passwd username`

Replace `username` with your normal user name.

The `passwd` command will then ask for the new password, which you will need to enter twice. You can now use the new password to log in to your user account.

16.10. Changing Login from Console to X at Startup

How do I change my login from the console to the graphical screen?

Instead of logging in to your system at the console and typing the `startx` command to start the X Window System, you can configure your system so that you can log in directly to X.

You must edit one file, `/etc/inittab`, by changing just one number in the runlevel section. When you are finished, reboot the computer. The next time you log in, you will have a graphical login prompt.

Open a shell prompt. If you’re in your user account, `su` to root by typing

`su`
Now, type `gedit /etc/inittab` to edit the file with `gedit`. The file `/etc/inittab` will open. Within the first screen, you will see a section of the file which looks like this:

```
# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
# id:3:initdefault:
```

To change from a console to a graphical login, you should change the number in the line `id:3:initdefault:` from a 3 to a 5.

⚠️ **Warning**

Change only the number of the default runlevel from 3 to 5.

Your changed line should look like the following:

```
id:5:initdefault:
```

When you are satisfied with your change, save and exit the file using the [Ctrl]-[x] keys. You will see a message telling you that the file has been modified, and asking you to confirm your change. Type [Y] for yes.

Now, your next login after reboot will be from the graphical screen.
Appendix A.

KDE: The K Desktop Environment

A.1. Introducing KDE

The K Desktop Environment (KDE) is a graphical desktop that uses common graphical objects such as icons, windows, menus, and panels; it allows you to access your Red Hat Linux system and applications using your mouse and keyboard.

This appendix covers the basics of using KDE: system navigation, working with files and applications, and customizing the desktop to suit your needs.

If you would like to learn more about KDE, visit the official website at http://www.kde.org.

A.2. Finding Help

You can access a comprehensive set of documentation about KDE through the HelpCenter.

![Figure A-1. The HelpCenter](image)

You can access the HelpCenter from the Main Menu by selecting Help. To access HelpCenter from the desktop, right-click on the desktop and select the Help => K Desktop Handbook.

The opening screen of the HelpCenter browser appears like Figure A-1. From this main page, you can view help documentation on topics such as using and configuring the desktop, working with the many applications included with KDE, and working with the Konquerer file manager.

A.3. Using The Desktop

Once you start KDE, your default desktop will look similar to Figure A-2.
136 Appendix A. KDE: The K Desktop Environment

Figure A-2. A Typical KDE Desktop

The KDE desktop displays application launchers, document windows, file folders, and so on. You can also access the main menu and configure the desktop to suit your needs.

The long bar across the bottom of the desktop is the panel. The panel contains application launchers, status indicators, and the desktop manager. You can have up to 16 desktops running at the same time in KDE. The panel taskbar shows your currently running applications.

Icons located on the desktop can be files, folders, device links, or application launchers. Click on an icon to open the associated resource.

The KDE desktop works similarly to other graphical desktop environments. You can drag and drop files and application icons to any location on the desktop. You can also add new icons for all types of applications and resources to the desktop, panel, or file manager. The desktop itself is also highly customizable. You can change the appearance of buttons, window and frame decorations, and backgrounds. Configuration tools are also available which allow you to customize the way the desktop behaves at events such as single- and double-clicking mouse buttons and chording keystrokes to create time-saving shortcuts.

The default KDE desktop displays icons for the trash can, your home directory, the Start Here icon for applications and configuration tools, and a diskette icon. You can access any one of these resources by double-clicking on the associated icon.

When you right-click on these icons, you see several options for working with these resources, such as **Delete**, **Rename**, **Move to Trash**, and **Copy**.

You can drag and drop unwanted items such as files you no longer need to the Trash icon. Right-click on the trash can and select **Empty Trash Bin** to delete the items from your system permanently.

### A.4. Using The Panel

The panel stretches across the bottom of the desktop. By default, it contains the main menu icon and quick-launch icons for starting a Web browser, email client, word processor, and other commonly used applications.
Figure A-3. The Panel

The panel is highly configurable. You can add and remove buttons that launch applications easily. Right-click on the panel and select **Configure Panel** to open the panel **Settings**. You can configure panel orientation and size, set a panel **hiding** configuration (where the panel remains hidden until you hover over the panel area), and customize your main menu. Click **Help** at any time to learn more about configuring your panel.

![Panel Settings](image)

Figure A-4. Panel Settings

Other tabs in **Settings** contain options to further customize your panel and taskbar. Click on **Help** for more information on these options.

Applications and utilities can be added easily to the panel. To add an application launcher to the panel, right-click on the panel and choose **Add**. Then select **Application Button** and make your choice from the menus.

**A.4.1. Using The Main Menu**

The Main Menu 🗨️ is the central point for using KDE. Clicking on the Main Menu icon on the panel displays a large master menu from which you can perform tasks such as launch applications, find files, and configure your desktop. The main menu also contains several submenus that organize applications and tools into several categories, including **Graphics**, **Internet**, **Office**, **Games**, and more.

From the Main Menu, you can lock your screen, which will display a password-protected screensaver. You can also run applications from a command line as well as logout of your KDE session.

**A.4.2. Using Applets**

Applets are small applications that run on the panel. There are several types of applets performing functions such as system monitoring, time and date display, and launching applications by typing commands in a text box.

There are some applets that run on the panel by default. This section covers them in detail.
A.4.2.1. Working with Multiple Desktops

By default, KDE provides four desktops that you can use to display multiple applications without having to crowd all of them onto one desktop. Each desktop can hold icons, open applications, and be individually customized.

For example, while you are writing a message in Evolution on desktop one, you can have Mozilla browsing the Web on desktop two, the OpenOffice.org Writer word processor open on desktop three, and so on.

You can change the number and names of desktops available in KDE by making these adjustments:

1. Right-click on the desktop; you will see a brief menu of actions you can choose.
2. Select Configure Desktop; the KDE desktop configuration tool will open.
3. Click the Multiple Desktops icon (see Figure A-5).

![Figure A-5. Virtual Desktop Configuration](image)

You can change the names of your desktops (from Desktop 1, Desktop 2, etc.) by deleting the default names and typing a new name in each desktop’s corresponding text box.

You can also change the number of desktops available to you by adjusting the slider in the Number of Desktops. For more desktops, drag the bar to the right; for fewer desktops, drag the bar to the left.

The Appearance, Behavior, and Paths, and Background icons are where you can make various desktop configuration changes. For example, to customize each virtual desktop to have different backgrounds, click the Background icon, uncheck the Common Background checkbox, click the virtual desktop you want to change, and choose the color or image you want to make your background using the associated tabs.
After you make any adjustments to your desktop configuration, click **Apply** to save the changes. Click **OK** to close the desktop configuration tool.

Buttons for your desktops appear on the panel in the **Desktop Pager**. Click on a tile to move to a different desktop.

**Tip**

You can use the keyboard combination of the [Ctrl] and Function keys to switch desktops. For example, [Ctrl]-[F2] switches to desktop two, [Ctrl]-[F3] takes you to desktop three, and so on.

### A.4.2.2. Viewing The Taskbar

The taskbar displays all running applications, both minimized and displayed, on all desktops.

**Tip**

Another way to bring minimized or background windows to the front is to use the [Alt] and [Tab] keys. To pick an item from the taskbar, hold down both the [Alt]-[Tab] key. To scroll through the tasks, hold down the [Alt] key, while tapping the [Tab] key. When you have found the task you want to maximize and bring to the front, release both keys and the application appears on the desktop.
A.4.3. Adding Icons and Applets to the Panel

To further customize the panel for your particular needs, you can include additional launcher icons to start applications without using the main menu or Start Here.

To add a new launcher to the panel, right-click the panel and choose Add => Application Button and choose the application or resource you wish to add to the panel. This automatically adds an icon on the panel. You can move the icon anywhere you want on the panel by right-clicking the icon and choosing Move Application Button, where Application is the name of the application associated with the icon.

A.4.4. Configuring the KDE Panel

You can hide the panel automatically or manually, place it on any edge of your desktop, change its size and color, and change the way it behaves. To alter the default panel settings, right-click the panel and choose Configure Panel. The Settings window will appear, allowing you to adjust all panel settings, or any one of the specific properties (Arrangement, Hiding, Menus, and so on). Choose the Hiding tab, click Hide automatically, and adjust the number of seconds to elapse before the panel is hidden. Click Apply then OK to close the Settings dialog. The panel will remain hidden until you hover over the panel area to make it reappear.

A.5. Managing Files

Konqueror is the file manager and a Web browser for the KDE desktop. Konqueror allows you to configure your KDE desktop, configure your Red Hat Linux system, play multimedia files, browse digital images, surf the Web, and more from one interface. This section explains some of the ways Konqueror can help you work with and enjoy your Red Hat Linux system.

To start Konqueror for file management, click on your home directory icon.

Konqueror will open up in a window on your desktop, allowing you to navigate through your home directory and throughout your Red Hat Linux file system. After exploring, you can return to your home directory by clicking the Home button on the toolbar.
You can navigate through the file system by clicking on folders within the main window frame or through the hierarchical file system viewer on the navigation panel as shown in Figure A-8. Files and folders in the main window frame can be moved or copied to another folder or sent to the trash. You can also delete files and folders by right-clicking on the item and choosing **Delete**.

**Konqueror** also displays thumbnail icons for text, images, PostScript/PDF files, and Web files. It can also preview sounds from digital audio files.

### A.5.1. The Navigation Panel

Another useful feature of **Konqueror** is the navigation panel. This panel appears on the left side of the **Konqueror** file browser window by default. The navigation panel makes many of your system resources available to you in convenient tabbed icons. Figure A-9 shows the navigation panel.

![Figure A-9. Working with the Navigation Panel](image)

The navigation panel lets you access your Web bookmarks, browsing history, network resources, file system, and has a built-in media player for playing multimedia files without having to open a separate application. The navigation panel makes **Konqueror** an efficient solution for users who want fast and easy access to all of their files and information.

### A.6. Browsing the Web with Konqueror

**Konqueror** not only allows you to browse your local and network file system, but with component technology used throughout KDE, **Konqueror** is also a full featured Web browser, which you can use to explore the World Wide Web.

To launch **Konqueror** choose **Main Menu => Internet => More Internet Applications => Konqueror Web Browser**.
Figure A-10. Welcome to Konqueror

When you first launch Konqueror, you will be presented with an Introduction screen. This screen offers basic instructions for browsing webpages.

If you click Continue at the end of the webpage, you will be presented with the Tips page. This page shows you basic tips for using Konqueror so that you can begin to take advantage of the many features.

By clicking Continue from the Tips screen, you will see the Specifications screen. This screen displays information on supported standards (such as Cascading StyleSheets, plug-ins, and OpenSSL), featured protocols, and more.

To begin your Web session, enter a URL in the Location field.

For additional information on using Konqueror, click on Help (on the top menu panel) and then on Konqueror Handbook.
A.7. Using Konqueror to View Images

You can also use the Konqueror file manager to view images. If you chose KDE as your default desktop environment, click on your home directory desktop icon to access the Konqueror file manager:

Using Konqueror as an image browser works similarly to Nautilus (see Chapter 11 Working with Images for more information). Image files automatically generate thumbnail image icons for you to preview within the file browser window. When you double-click on a thumbnail icon, the browser displays the image in its native size, as shown in Figure A-12.
To zoom in and out of an image, you first need to change the way Konqueror renders the image. From the window menu, choose View => View Mode => Image Viewer Part. This will re-display the image and allow you to rotate and zoom in on the image using the two magnifying glass icons or the magnification percentage drop-down menu on the toolbar, as shown in Figure A-13.

Figure A-13. Image viewing configuration on the Konqueror Toolbar

You can also open the image with more advanced image viewers, as well as with The GIMP. Right-click on the image, choose Open With..., then Other... A pop-up menu will appear allowing you to open the application you wish to use. To launch the GIMP, choose Graphics and scroll down the list of applications. Click on the GIMP icon and click OK, as seen in Figure A-14.

Figure A-14. The Open With... Dialog Box

A.8. KMail

KMail is an email tool for KDE. It has an intuitive graphical interface similar to Evolution that allows you to send and receive email using a graphical interface. To open KMail, click on the Main Menu => Internet => More Internet Applications => KMail.

Before you can really use KMail, you must configure it so it can send and receive mail. To run the configuration tool, select Settings from the KMail toolbar, and click on Configure KMail.

The Configure Mail Client window consists of the following sections: Identities, Network, Appearance, Composer, Security, and Folders. To begin sending and receiving messages you will have to change the settings in the Identities and Network tabs. Have your email information from your service provider or administrator handy so that you can fill in the required information to begin using KMail. For additional information, refer to the KMail user manual (Help => KMail Handbook) or visit KMail’s homepage at http://kmail.kde.org.
Once you have your email settings configured, you can begin sending and receiving email. The folders on the left side of the KMail screen allow you to view emails you have received, emails ready to be sent, emails you have sent, and more.

To compose a mail, click on the new message icon in the tool bar:

Hey Jimmy,

I found a cool new company. They make an operating system called Red Hat Linux. I installed it on my computer and I'm using it to send you this email right now!

http://www.redhat.com

Take a look at it. Linux is great!

Talk to you soon,
John
Once you have composed a message and entered an email address to send the email to, click **Send** in the toolbar.

### A.9. Customizing KDE

KDE allows you to configure the desktop and your system to suit your needs. The KDE Control Center, available by selecting **Main Menu => Control Center**, lets you customize the look and behavior of the desktop. The following list explains some of the configuration options in detail.

**KDE Components**

This section lets you configure the Konqueror file manager and customize certain file operations. You can also associate files to applications that you prefer (for example, assigning all digital music files to open in XMMS instead of the default player).

**Appearance & Themes**

This section allows you to customize the visual aspect of your desktop environment. You can customize background images and configure fonts, themes, icons, panel elements, screensavers, and window border appearance. You can also customize mouse and keyboard events which makes working with the desktop as efficient for your needs as possible.

**Regional & Accessibility**

This section allows you to set country and language options to your particular locale. For users with sight or hearing impairments, you can also configure accessibility features such as audible and visual cues and keyboard/mouse customization.

**System Administration**

This section is an advanced system configuration interface. You will need your root password to configure most of these options. This section allows you to configure system boot settings, Linux kernel configuration, login management, and more. It is strongly recommended that you leave these settings at their default values unless you understand the consequences of changing them.

**Web Browsing**

This section allows you to configure the Konqueror Web browser. You can configure options such as cache sizes, website cookies, plugins, proxy settings (if available), and enhanced browsing using keyword shortcuts.

### A.10. Logging Out of KDE

There are two ways to log out of your KDE session. From the **Main Menu**, select **Logout User**, where *User* is your account username. To log out from the desktop, right-click on the desktop and, from the menu, select **Logout User** where *User* is your account username. In either case click **Logout** and your session will end.

![Figure A-17. KDE Logout Screen](image)
The following table shows some of the Red Hat Linux applications that are available to perform many common tasks. *This is not a complete list of all applications available. Applications in between (parentheses) denotes the formal name of the application.*

<table>
<thead>
<tr>
<th>Category</th>
<th>Recommended Application</th>
<th>Extras</th>
</tr>
</thead>
<tbody>
<tr>
<td>Word Processors</td>
<td>OpenOffice.org Write</td>
<td>KWord</td>
</tr>
<tr>
<td>Spreadsheets</td>
<td>OpenOffice.org Calc</td>
<td>Gnumeric, KSpread</td>
</tr>
<tr>
<td>Presentations</td>
<td>OpenOffice.org Impress</td>
<td>KPresenter, MagicPoint</td>
</tr>
<tr>
<td>Charts and Diagrams</td>
<td>Dia</td>
<td>Kchart, Kivio, XFig</td>
</tr>
<tr>
<td>Graphics</td>
<td>The GIMP, Paint Program (KPaint)</td>
<td>Icon Editor (K Icon Editor)</td>
</tr>
<tr>
<td>Image Viewers</td>
<td>GThumb</td>
<td>Image Viewer (Kuickshow), The GIMP</td>
</tr>
<tr>
<td>Digital Cameras/Scanners</td>
<td>Digital Camera Tool (gtKam), Scanning (XSane)</td>
<td>Scan and OCR Program (Kooka), The GIMP</td>
</tr>
<tr>
<td>PDAs</td>
<td>Jpilot</td>
<td>KPilot, Evolution</td>
</tr>
<tr>
<td>CD Recording</td>
<td>CD Creator, cdrecord, X-CD-Roast</td>
<td>KOnCD</td>
</tr>
<tr>
<td>Text Editors</td>
<td>Text Editor (gedit)</td>
<td>vi, Emacs, Kate</td>
</tr>
<tr>
<td>Email Clients</td>
<td>Evolution</td>
<td>Kmail, Mozilla Mail, mutt</td>
</tr>
<tr>
<td>Web Browsers</td>
<td>Mozilla</td>
<td>Galeon, Konquerer, links, lynx</td>
</tr>
<tr>
<td>Chat/Instant Messaging</td>
<td>Instant Messenger (GAIM)</td>
<td>X-Chat, Chatzilla</td>
</tr>
<tr>
<td>PDF/PostScript Viewers</td>
<td>xpdf</td>
<td>Ghostview</td>
</tr>
<tr>
<td>Personal Finance</td>
<td>Gnucash</td>
<td></td>
</tr>
<tr>
<td>Fax</td>
<td>Fax Viewer (KFax)</td>
<td></td>
</tr>
<tr>
<td>Sound</td>
<td>Audio Player (XMMS), CD Player (GNOME CD), Sound Recorder (GNOME Sound), Volume Monitor (VUMeter)</td>
<td>KDE CD Player, aumix, KDE Sound Mixer, KMid</td>
</tr>
</tbody>
</table>

Table B-1. Applications
Appendix C.

A Comparison of Common DOS and Linux Commands

Many Linux commands typed at a shell prompt are similar to the commands you would type in DOS. In fact, some commands are identical.

This appendix provides common commands used at the DOS prompt in Windows and their counterparts in Linux. Basic examples of how the command are used at the Linux shell prompt are also provided. Note that these commands usually have a number of options. To learn more about each command, read its associated man page (for example, type `man ls` at the shell prompt to read about the `ls` command).

<table>
<thead>
<tr>
<th>Command’s Purpose</th>
<th>MS-DOS</th>
<th>Linux</th>
<th>Basic Linux Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copies files</td>
<td>copy</td>
<td>cp</td>
<td>cp thisfile.txt /home/thisdirectory</td>
</tr>
<tr>
<td>Moves files</td>
<td>move</td>
<td>mv</td>
<td>mv thisfile.txt /home/thisdirectory</td>
</tr>
<tr>
<td>Lists files</td>
<td>dir</td>
<td>ls</td>
<td>ls</td>
</tr>
<tr>
<td>Clears screen</td>
<td>cls</td>
<td>clear</td>
<td>clear</td>
</tr>
<tr>
<td>Closes shell prompt</td>
<td>exit</td>
<td>exit</td>
<td>exit</td>
</tr>
<tr>
<td>Displays or sets date</td>
<td>date</td>
<td>date</td>
<td>date</td>
</tr>
<tr>
<td>Deletes files</td>
<td>del</td>
<td>rm</td>
<td>rm thisfile.txt</td>
</tr>
<tr>
<td>&quot;Echoes&quot; output to the screen</td>
<td>echo</td>
<td>echo</td>
<td>echo this message</td>
</tr>
<tr>
<td>Edits files with simple text editor</td>
<td>edit</td>
<td>gedit()</td>
<td>gedit thisfile.txt</td>
</tr>
<tr>
<td>Compares the contents of files</td>
<td>fc</td>
<td>diff</td>
<td>diff file1 file2</td>
</tr>
<tr>
<td>Finds a string of text in a file</td>
<td>find</td>
<td>grep</td>
<td>grep this word or phrase thisfile.txt</td>
</tr>
<tr>
<td>Formats a diskette (if diskette is in A:)</td>
<td>format a:</td>
<td>mke2fs or mformat()</td>
<td>/sbin/mke2fs /dev/fd0 (/dev/fd0 is the Linux equivalent of A:)</td>
</tr>
<tr>
<td>Displays command help</td>
<td>command /?</td>
<td>man()</td>
<td>man command</td>
</tr>
<tr>
<td>Creates a directory</td>
<td>mkdir</td>
<td>mkdir</td>
<td>mkdir directory</td>
</tr>
<tr>
<td>Views a file</td>
<td>more</td>
<td>less()</td>
<td>less thisfile.txt</td>
</tr>
<tr>
<td>Renames a file</td>
<td>ren</td>
<td>mv()</td>
<td>mv thisfile.txt thatfile.txt</td>
</tr>
</tbody>
</table>
## Table C-1. Similar Commands

<table>
<thead>
<tr>
<th>Command’s Purpose</th>
<th>MS-DOS</th>
<th>Linux</th>
<th>Basic Linux Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displays your location in the file system</td>
<td>chdir</td>
<td>pwd</td>
<td>pwd</td>
</tr>
<tr>
<td>Changes directories with a specified path <em>(absolute path)</em></td>
<td>cd pathname</td>
<td>cd pathname</td>
<td>cd /directory/directory</td>
</tr>
<tr>
<td>Changes directories with a relative path</td>
<td>cd .</td>
<td>cd .</td>
<td>cd ..</td>
</tr>
<tr>
<td>Displays the time</td>
<td>time</td>
<td>date</td>
<td>date</td>
</tr>
<tr>
<td>Shows amount of RAM in use</td>
<td>mem</td>
<td>free</td>
<td>free</td>
</tr>
</tbody>
</table>

**Notes:**

a. Gedit is a graphical text editor; other editors you can use in place of **Gedit** include **Emacs** and **vi**.

b. This formats a disk for the DOS file system.

c. You can also use **info** for some commands.

d. The **more** pager can also be used to page through a file one screen at a time.

e. The **mv** command can both move a file and, if you want to rename a file in the same directory, “move” that file to the same directory with a new name, as seen in this example.
Appendix D.

System Directories

This is a list of the primary Red Hat Linux system directories. Each directory is described briefly. For additional directory information, refer to the Red Hat Linux Customization Guide and the Red Hat Linux Reference Guide.

- `/bin/` — Used to store user commands. The directory `/usr/bin/` also stores user commands.
- `/sbin/` — Location of many system commands, such as `shutdown`. The directory `/usr/sbin/` also contains many system commands.
- `/root/` — The home directory of root, the superuser.
- `/mnt/` — This directory typically contains the mount points for file systems mounted after the system is booted. For example, the default CD-ROM mount point is `/mnt/cdrom/`.
- `/boot/` — Contains the kernel and other files used during system startup.
- `/lost+found/` — Used by `fsck` to place orphaned files (files without names).
- `/lib/` — Contains many library files used by programs in `/bin/` and `/sbin/`. The directory `/usr/lib/` contains more library files for user applications.
- `/dev/` — Stores device files.
- `/etc/` — Contains configuration files and directories.
- `/var/` — For variable (or constantly changing) files, such as log files and the printer spool.
- `/usr/` — Contains files and directories directly relating to users of the system, such as programs and supporting library files.
- `/proc/` — A virtual file system (not actually stored on the disk) that contains system information used by certain programs.
- `/initrd/` — A directory that is used to mount the `initrd.img` image file and load needed device modules during bootup.

⚠️ **Warning**

Do not delete the `/initrd/` directory. You will be unable to boot your computer if you delete the directory and then reboot your Red Hat Linux system.

- `/tmp/` — The temporary directory for users and programs. `/tmp/` allows all users on a system read and write access.
- `/home/` — Default location of user home directories.
- `/opt/` — Directory where optional files and programs are stored. This directory is used mainly by third-party developers for easy installation and uninstallation of their software packages.
Appendix E.

Keyboard Shortcuts

Here are a few keyboard shortcuts you can use to perform common tasks quickly. Many more are available in addition to what is listed here. For more command line and keyboard shortcuts, visit:

http://sunsite.dk/linux-newbie/lnag_commands.html#shortcuts

- **[Ctrl] + [Alt] + [Backspace]** = kills your current X session. Kills your graphical desktop session and returns you to the login screen. Use this if the normal exit procedure does not work.
- **[Ctrl] + [Alt] + [Delete]** = shutdown and reboots your Red Hat Linux system. Shuts down your current session and reboots the OS. Use only when the normal shutdown procedure does not work.
- **[Ctrl] + [Alt] + [Fn]** = switches screens. [Ctrl][Alt] + one of the function keys displays an available screen. By default, [F1] through [F6] are shell prompt screens and [F7] is the graphical desktop screen.
- **[Alt] + [Tab]** = switches tasks in a graphical desktop environment. If you have more than one application open at a time, you can use [Alt] + [Tab] to switch among open tasks and applications.
- **[Ctrl] + [a]** = moves cursor to the beginning of a line. This works in most text editors and in the URL field in Mozilla.
- **[Ctrl] + [d]** = logout of (and close) shell prompt. Use this quick shortcut instead of typing `exit` or `logout`.
- **[Ctrl] + [e]** = moves cursor to end of a line. This works in most text editors and in the URL field in Mozilla.
- **[Ctrl] + [l]** = clears the terminal. This shortcut does the same thing as typing `clear` at a command line.
- **[Ctrl] + [u]** = clears the current line. If you are working in a terminal, use this shortcut to clear the current line from the cursor all the way to the beginning of the line.
- **[Middle Mouse Button]** = pastes highlighted text. Use the left mouse button to highlight the text. Point the cursor to the spot where you want it pasted. Click the middle mouse button to paste it. In a two mouse system, if you configured your mouse to emulate a third mouse button, you can click both the left and right mouse buttons simultaneously to perform a paste.
- **[Tab]** = command autocomplete. Use this command when using a shell prompt. Type the first few characters of a command or filename and then press the [Tab] key. It will automatically complete the command or show all commands that match the characters you typed.
- **[Up] and [Down] Arrow** = shows command history. When using a shell prompt, press the [up] or [down] arrow to scroll through a history of commands you have typed from the current directory. When you see the command you want to use, press [Enter].
- **clear** = clears the shell prompt screen. Type this command to clear all visible data from the shell prompt screen.
- **exit** = logout. Type this at a shell prompt to logout of the current user or root account.
- **history** = shows history of commands. Type this at a shell prompt to see a numbered list of the previous 1000 commands you typed. To display a shorter list of previously used commands, type `history` followed by a space and a number. For example, `history 20`.
- **reset** = refreshes the shell prompt screen. Type this at a shell prompt to refresh the screen if characters are unclear or appear corrupt.
Index

A
accounts
  creating, 7
appending standard output, 98
applets
  adding to KDE panel, 140
  adding to the panel, 16
  on the desktop panel, 14
  panel
  in KDE, 137
applications
  and Red Hat Linux, 147
  starting from shell prompt, 127
archiving files, 113

B
bunzip2, 115
burning CDs, 26
  additional resources, 32
  with CD Creator, 27
  with cdrecord, 30
  with mkisofs, 30
  with X-CD-Roast, 28
bzip2, 115

C
cat, 96
cd, 90
CD-rewritable (CD-RW), 26
  additional resources, 32
  and CD Creator, 27
  and cdrecord, 30
  and mkisofs, 30
  and X-CD-Roast, 28
CD-writable (CD-R), 26
  additional resources, 32
  and CD Creator, 27
  and cdrecord, 30
  and mkisofs, 30
  and X-CD-Roast, 28
cdrecord, 31
CDs, playing, 73
chmod, 105
  numerical settings, 108
clear, 96
command history, 103
  tips, 131
command line options
  printing from, 60
commands
  (See shell prompt)
cat, 101
cat, using, 96
cd, 90
change directories, 90
chmod, 105
  numerical settings, 108
clear, 96
cron, 95
DOS, 149
finding, 130
grep, 101
head, 101
history, 130
locate, 94
ls, 93
  keeping output from scrolling, 131
ls -a, 93
ls -al, 93
ls, common options with, 94
multiple, 104
print working directory (pwd), 90
pwd, 90
reset, 96
rm
  (See files, deleting)
rm -r
  (See directories, deleting)
stringing together, 104
su, 92
tail, 101
common user questions, 127
compressing files, 113
conventions
document, ii
copying and pasting text
  when using X, v
creating graphics
  with OpenOffice.org Draw, 69
creating user accounts, 7
D
date configuration, 21
dateconfig
   (See Time and Date Properties Tool)
desktop
   (See graphical desktop)
applets, 14
background
   changing, 18, 81
KDE, 135
desktops
   multiple
     KDE, 138
devices
   digital cameras, 87
DHCP, 35
digital cameras, 87
directories
   changing, 90
   copying, 119
   deleting, 121
   descriptions, 151
   listing contents, 93
   managing
     from shell prompt, 89
     moving, 120
diskettes, 23
   formatting, 24
     mke2fs, 25
   mounting, 23
   unmounting, 23
   using, 23
DNS
   definition, 35
documents, 63
   OpenOffice.org, 63
   OpenOffice.org Writer, 64
PDF, 72
text files, 70
dot files
   (See hidden files)
drag and drop, v
drawing
   OpenOffice.org Draw, 69

E
e-mail clients, 45
   Evolution, 46
   KMail, 144
   Mozilla Mail, 48
     Newsgroups, 49
     mutt, 50
   plain text, 50
     mutt, 50

environment variables
   PATH, 128
errata
   updating with, 125
Evolution
   (See e-mail clients)
ext2 file system
   and floppy disks, 24

F
FAQ, 127
   accessing a Windows partition, 129
   finding previous used commands, 130
   history tips and tricks, 131
   keeping ls output from scrolling, 131
   login problems, 132
   permissions for installing RPMs, 127
   starting applications, 127
feedback
   contact information for this manual, v
FHS
   (See Filesystem Hierarchy Standard)
file, 113
file manager
   for KDE, 140
   Nautilus, 16
file managers, 111
File Roller, 114
file system
   understanding, 111
file types, 112
files
   archived, 112
   archiving, 113
     with File Roller, 114
   compressed, 112
   compressing, 113
     with File Roller, 114
   copying, 119
   copying at a shell prompt, 119
   creating
     touch, 119
   deleting, 121
   deleting at a shell prompt, 119
   formats, 112
   managing
     from shell prompt, 89
     moving, 120
     moving at a shell prompt, 119
     renaming at a shell prompt, 119
     types of, 112
Filesystem Hierarchy Standard, 112
floppy disks
   (See diskettes)
formatting diskettes, 24

G

games and amusements, 76
  finding more online, 77
getting started
  logging in, 5
  Setup Agent, 1
GIMP, 82
  opening a file, 83
  saving a file, 84
 GNOME desktop
  (See graphical desktop)
 GNOME Print Manager, 58
  change printer settings, 59
 graphical desktop, 13
  applets, 16
  background
    changing, 18, 81
    customizing, 18
  logging out of, 20
  main menu, 14
  Nautilus, 16
  panel, 14
  Start Here, 17
  using, 13
  workspace, 13
 graphical login
  changing to, 132
 graphics
  GIMP, 82
  gThumb, 80
    changing wallpaper with, 81
  gunzip, 115
  gzip, 115

H

 Hardware Browser, 129
 help
  with KDE
    finding, 135
 hidden files, 93
 history
  finding commands using, 130

I

images
  additional resources, 85
  manipulation, 79
    GIMP, 82
  viewing, 79, 79
    gThumb, 80
    Konqueror, 143
    Nautilus, 79
 Internet
  configuring, 35
 Internet Configuration Wizard, 35
 introduction, i
 IP address, 35

K

KDE, 135
  applets
    adding, 140
    multiple desktops, 138
    customizing, 146
  desktop, 135
  desktop icons, 136
  desktops
    multiple, 138
    switching, 139
 documentation, 135
 Konqueror
  navigation panel, 141
  main menu, 137
  panel, 136
  applets, 137
  switching tasks, 139
  Taskbar, 139
  website, 135
 keyboard shortcuts, 153
 KMail
  (See email clients)
 Konqueror
  (See Web browsers)
 KDE file manager, 140
 navigation panel, 141
 viewing images with, 143
L

less, 100
linux commands
  (See shell prompt)
listing directories
  (See commands, ls)
log in, 5
logging in, 5
  graphical, 132
  graphical login, 6
  virtual console login, 6
logging out, 11
  from the desktop, 20
KDE, 146
login problems
  using single-user mode, 132
ls, 93
  printing output, 131
  viewing output, 131

M

main menu
  in KDE, 137
  on the desktop, 14
mk2fs, 25
mkisofs, 31
mouse
  how to use, v
Mozilla
  (See Web browsers)
Mozilla Mail
  (See email clients)
music
  Ogg Vorbis, 73
  Wave, 73
  XMMS, 73
  using, 74
mutt
  (See email clients)

N

Nautilus, 16
  disabling text icons, 17
  disabling thumbnails, 17
  viewing images with, 79
Network Time Protocol
  (See NTP)
new users
  creating accounts, 7
Newsgroups
  (See email clients)
NTP

configuring, 21
ntpd, 21
ntpd, 21

O

online
  connecting with Internet Configuration Wizard, 35
OpenOffice.org, 63
  Draw, 69
  features, 63
  Impress, 67
  Writer, 64, 65
ownership and permissions, 105

P

pagers, 100
  less, 100
panel
  configuring, 16
  configuring the, 140
KDE, 136
  adding applications, 137
  customizing, 137
  hiding, 137
  on the graphical desktop, 14
partitions
  accessing Windows, 129
password
  forgotten, 132
passwords
  secure, 8
PATH, 128
  editing, 127
pathnames
  relative and absolute, 90
PDF
  viewing, 72
  xpdf, 72
peripherals
  digital cameras, 87
permissions
  numerical settings, 108
  setting for new RPMs, 127
permissions and ownership, 105
pipes, 100
plain text
  (See text files)
Point-to-Point Protocol, 35
PPP, 35
presentations
  OpenOffice.org Impress, 67
printer configuration
  adding
local printer, 53
cancel print job, 60
default printer, 56
delete existing printer, 56
driver options, 57
Assume Unknown Data is Text, 57
Convert Text to Postscript, 58
Effective Filter Locale, 58
GhostScript pre-filtering, 58
Media Source, 58
Page Size, 58
Prerender Postscript, 58
Send End-of-Transmission (EOT), 57
Send Form-Feed (FF), 57
edit driver, 57
edit existing printer, 56
GNOME Print Manager, 58
change printer settings, 59
local printer, 53
managing print jobs, 58
modifying existing printers, 56
notification icon, 59
printing from the command line, 60
rename existing printer, 57
test page, 56
viewing print spool, 59
viewing print spool, command line, 60
printing
from command line, 95
pwd, 90

R
Red Hat Network, 123
Red Hat Update Agent, 123
redhat-config-date
(See Time and Date Properties Tool)
redhat-config-time
(See Time and Date Properties Tool)
redirecting standard input, 99
redirection, 96
reset, 96
RHN
(See Red Hat Network)
root, 111
and root login, 111
logging in as, 5
RPM, 125
installing packages, 123
upgrading packages, 123
RPMs
error message while installing, 127
installing with Gnome-RPM, 127

S
Setup Agent, 1
shell, 89
history of, 89
shell prompt, 7
basic commands, 89
chmod, 106
single-user mode, 132
software
installing, 123
upgrading, 123
sound card
configuring, 74
Sound Card Configuration Tool, 74
spreadsheets
OpenOffice.org Calc, 65
standard input
redirecting, 99
standard output
appending, 98
redirecting, 96
Start Here, 17
changing desktop background with, 18
startup messages
dmesg | more, 100
startx, 6
su, 92
superuser
(See commands, su)
switching desktops
KDE, 139
switching tasks
KDE, 139
system directories
descriptions, 151

T
tab completion, 103
Taskbar
KDE, 139
terminal
(See shell prompt)
terms
introductory, 3
text files, 70
editing, 70
from a shell prompt, 71
The Graphical Desktop, 6
time configuration, 21
synchronize with NTP server, 21
time zone configuration, 22
timetool
(See Time and Date Properties Tool)
Trash icon
KDE, 136
troubleshooting
  sound card, 74
  video card, 76

U
unzip, 115
user account
  creating, 7
  importance of, 5
utilities
  cat, 96
  less, 100

V
vi, 71

W
wallpaper
  changing, 18
Web browsers, 39
  Konqueror, 141
  Mozilla, 39
  using, 39
Windows
  accessing on a separate partition
    add line to /etc/fstab, 129
World Wide Web
  browsers, 39
    Mozilla, 39

X
X Configuration Tool, 76
xpdf, 72
The Red Hat Linux manuals are written in DocBook SGML v4.1 format. The HTML and PDF formats are produced using custom DSSSL stylesheets and custom jade wrapper scripts. The DocBook SGML files are written in Emacs with the help of PSGML mode.

Garrett LeSage created the admonition graphics (note, tip, important, caution, and warning). They may be freely redistributed with the Red Hat documentation.

The Red Hat Linux Product Documentation Team consists of the following people:

Sandra A. Moore — Primary Writer/Maintainer of the Red Hat Linux x86 Installation Guide; Contributing Writer to the Red Hat Linux Getting Started Guide

Tammy Fox — Primary Writer/Maintainer of the Red Hat Linux Customization Guide; Contributing Writer to the Red Hat Linux Getting Started Guide; Writer/Maintainer of custom DocBook stylesheets and scripts

Edward C. Bailey — Primary Writer/Maintainer of the Red Hat Linux System Administration Primer; Contributing Writer to the Red Hat Linux x86 Installation Guide

Johnray Fuller — Primary Writer/Maintainer of the Red Hat Linux Reference Guide; Co-writer/Co-maintainer of the Red Hat Linux Security Guide; Contributing Writer to the Red Hat Linux System Administration Primer

John Ha — Primary Writer/Maintainer to the Red Hat Linux Getting Started Guide; Co-writer/Co-maintainer of the Red Hat Linux Security Guide; Contributing Writer to the Red Hat Linux System Administration Primer